Every CVE Search/ Get API key

CVE-2012-3383

The map_meta_cap function in wp-includes/capabilities.php in WordPress 3.4.x before 3.4.2, when...

2.6 LowFix available

CVE-2012-3383 is a low vulnerability (CVSS 2.6) in Wordpress, published July 22, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.10%, the 87th percentile. Fixed in wordpress 3.4.1+dfsg-1.

The map_meta_cap function in wp-includes/capabilities.php in WordPress 3.4.x before 3.4.2, when the multisite feature is enabled, does not properly assign the unfiltered_html capability, which allows remote authenticated users to bypass intended access restrictions and conduct cross-site scripting (XSS) attacks by leveraging the Administrator or Editor role and composing crafted text.

Exploit likelihood

3.10%Up 1.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 2.6

The map_meta_cap function in wp-includes/capabilities.php in WordPress 3.4.x before 3.4.2, when the multisite feature is enabled, does not properly assign the unfiltered_html capability, which allows remote authenticated users to bypass intended access restrictions and conduct cross-site scripting (XSS) attacks by leveraging the Administrator or Editor role and composing crafted text.

Record
CVE-2012-3383
CVSS 2.0
2.6 LowAV:N/AC:H/Au:N/C:N/I:P/A:N
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

The map_meta_cap function in wp-includes/capabilities.php in WordPress 3.4.x before 3.4.2, when the multisite feature is enabled, does not properly assign the unfiltered_html capability, which allows remote authenticated users to bypass intended access restrictions and conduct cross-site scripting (XSS) attacks by leveraging the Administrator or Editor role and composing crafted text.

Record
CVE-2012-3383
Updated
2026-11-02
EUVDEUVD-2012-3355 No score

The map_meta_cap function in wp-includes/capabilities.php in WordPress 3.4.x before 3.4.2, when the multisite feature is enabled, does not properly assign the unfiltered_html capability, which allows remote authenticated users to bypass intended access restrictions and conduct cross-site scripting (XSS) attacks by leveraging the Administrator or Editor role and composing crafted text.

Record
EUVD-2012-3355
Updated
2026-11-03
GitHub AdvisoriesGHSA-56vr-745r-v7wg No score

The map_meta_cap function in wp-includes/capabilities.php in WordPress 3.4.x before 3.4.2, when...

The map_meta_cap function in wp-includes/capabilities.php in WordPress 3.4.x before 3.4.2, when the multisite feature is enabled, does not properly assign the unfiltered_html capability, which allows remote authenticated users to bypass intended access restrictions and conduct cross-site scripting (XSS) attacks by leveraging the Administrator or Editor role and composing crafted text.

Record
GHSA-56vr-745r-v7wg
Updated
2026-11-02
OSV No score

The map_meta_cap function in wp-includes/capabilities.php in WordPress 3.4.x before 3.4.2, when the multisite feature is enabled, does not properly assign the unfiltered_html capability, which allows remote authenticated users to bypass intended access restrictions and conduct cross-site scripting (XSS) attacks by leveraging the Administrator or Editor role and composing crafted text.

Record
CVE-2012-3383
Updated
2026-11-02
OSVDEBIAN-CVE-2012-3383 No score

The map_meta_cap function in wp-includes/capabilities.php in WordPress 3.4.x before 3.4.2, when the multisite feature is enabled, does not properly assign the unfiltered_html capability, which allows remote authenticated users to bypass intended access restrictions and conduct cross-site scripting (XSS) attacks by leveraging the Administrator or Editor role and composing crafted text.

Record
DEBIAN-CVE-2012-3383
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wordpress
Debian:12
before 3.4.1+dfsg-1
3.4.1+dfsg-1
wordpress
Debian:13
before 3.4.1+dfsg-1
3.4.1+dfsg-1
wordpress
Debian:14
before 3.4.1+dfsg-1
3.4.1+dfsg-1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 4 moreShow less
MoveEnter Open