Every CVE Search/ Get API key

CVE-2012-3385

WordPress before 3.4.1 does not properly restrict access to post contents such as private or...

5.0 MediumFix available

CVE-2012-3385 is a medium vulnerability (CVSS 5.0) in Wordpress, published July 22, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.90%, the 79th percentile. Fixed in wordpress 3.4.1+dfsg-1.

WordPress before 3.4.1 does not properly restrict access to post contents such as private or draft posts, which allows remote authors or contributors to obtain sensitive information via unknown vectors.

Exploit likelihood

1.90%Up 0.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

WordPress before 3.4.1 does not properly restrict access to post contents such as private or draft posts, which allows remote authors or contributors to obtain sensitive information via unknown vectors.

Record
CVE-2012-3385
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

WordPress before 3.4.1 does not properly restrict access to post contents such as private or draft posts, which allows remote authors or contributors to obtain sensitive information via unknown vectors.

Record
CVE-2012-3385
Updated
2026-11-02
EUVDEUVD-2012-3357 No score

WordPress before 3.4.1 does not properly restrict access to post contents such as private or draft posts, which allows remote authors or contributors to obtain sensitive information via unknown vectors.

Record
EUVD-2012-3357
Updated
2026-11-03
GitHub AdvisoriesGHSA-jw2g-5g3r-6j73 No score

WordPress before 3.4.1 does not properly restrict access to post contents such as private or...

WordPress before 3.4.1 does not properly restrict access to post contents such as private or draft posts, which allows remote authors or contributors to obtain sensitive information via unknown vectors.

Record
GHSA-jw2g-5g3r-6j73
Updated
2026-11-02
OSV No score

WordPress before 3.4.1 does not properly restrict access to post contents such as private or draft posts, which allows remote authors or contributors to obtain sensitive information via unknown vectors.

Record
CVE-2012-3385
Updated
2026-11-02
OSVDEBIAN-CVE-2012-3385 No score

WordPress before 3.4.1 does not properly restrict access to post contents such as private or draft posts, which allows remote authors or contributors to obtain sensitive information via unknown vectors.

Record
DEBIAN-CVE-2012-3385
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wordpress
Debian:12
before 3.4.1+dfsg-1
3.4.1+dfsg-1
wordpress
Debian:13
before 3.4.1+dfsg-1
3.4.1+dfsg-1
wordpress
Debian:14
before 3.4.1+dfsg-1
3.4.1+dfsg-1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

MoveEnter Open