CVE-2012-3450
pdo_sql_parser.re in the PDO extension in PHP before 5.3.14 and 5.4.x before 5.4.4 does not...
pdo_sql_parser.re in the PDO extension in PHP before 5.3.14 and 5.4.x before 5.4.4 does not properly determine the end of the query string during parsing of prepared statements, which allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted parameter value.
Exploit likelihood
What each source reports
NVD Score used
2.6
pdo_sql_parser.re in the PDO extension in PHP before 5.3.14 and 5.4.x before 5.4.4 does not properly determine the end of the query string during parsing of prepared statements, which allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted parameter value.
- Record
CVE-2012-3450- CVSS 2.0
- 2.6 Low
AV:N/AC:H/Au:N/C:N/I:N/A:P - Updated
- 2026-11-02
CVE List No score
pdo_sql_parser.re in the PDO extension in PHP before 5.3.14 and 5.4.x before 5.4.4 does not properly determine the end of the query string during parsing of prepared statements, which allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted parameter value.
- Record
CVE-2012-3450- Updated
- 2026-11-02
EUVDEUVD-2012-3412 No score
pdo_sql_parser.re in the PDO extension in PHP before 5.3.14 and 5.4.x before 5.4.4 does not properly determine the end of the query string during parsing of prepared statements, which allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted parameter value.
- Record
EUVD-2012-3412- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-72h2-mx43-37v5 No score
pdo_sql_parser.re in the PDO extension in PHP before 5.3.14 and 5.4.x before 5.4.4 does not...
pdo_sql_parser.re in the PDO extension in PHP before 5.3.14 and 5.4.x before 5.4.4 does not properly determine the end of the query string during parsing of prepared statements, which allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted parameter value.
- Record
GHSA-72h2-mx43-37v5- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
php5Debian:6.0 |
before 5.3.3-7+squeeze14, plus listed versions 5.3.3-75.3.3-7+squeeze15.3.3-7+squeeze135.3.3-7+squeeze25.3.3-7+squeeze3 Show 5 moreShow less5.3.3-7+squeeze55.3.3-7+squeeze65.3.3-7+squeeze75.3.3-7+squeeze85.3.3-7+squeeze9 |
5.3.3-7+squeeze14 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | PHP 5.4.3 - PDO Memory Access Violation Denial of Service | 2012-08-02 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2012-3450 is a low vulnerability (CVSS 2.6) in Php, published August 6, 2012. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 11.2%, the 95th percentile. Fixed in php5 5.3.3-7+squeeze14.