Every CVE Search/ Get API key

CVE-2012-3528

Typo3 Backend XSS Vulnerability

3.5 LowFix available

CVE-2012-3528 is a low vulnerability (CVSS 3.5) in Typo3, published August 30, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.03%, the 81st percentile. Fixed in typo3/cms 4.5.19.

Multiple cross-site scripting (XSS) vulnerabilities in the backend in TYPO3 4.5.x before 4.5.19, 4.6.x before 4.6.12 and 4.7.x before 4.7.4 allow remote authenticated backend users to inject arbitrary web script or HTML via unspecified vectors.

Exploit likelihood

2.03%Up 0.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 3.5

Multiple cross-site scripting (XSS) vulnerabilities in the backend in TYPO3 4.5.x before 4.5.19, 4.6.x before 4.6.12 and 4.7.x before 4.7.4 allow remote authenticated backend users to inject arbitrary web script or HTML via unspecified vectors.

Record
CVE-2012-3528
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Multiple cross-site scripting (XSS) vulnerabilities in the backend in TYPO3 4.5.x before 4.5.19, 4.6.x before 4.6.12 and 4.7.x before 4.7.4 allow remote authenticated backend users to inject arbitrary web script or HTML via unspecified vectors.

Record
CVE-2012-3528
Updated
2026-11-02
EUVDEUVD-2022-3073 No score

Multiple cross-site scripting (XSS) vulnerabilities in the backend in TYPO3 4.5.x before 4.5.19, 4.6.x before 4.6.12 and 4.7.x before 4.7.4 allow remote authenticated backend users to inject arbitrary web script or HTML via unspecified vectors.

Record
EUVD-2022-3073
Updated
2026-11-03
GitHub AdvisoriesGHSA-7w6c-5pr4-7qvp No score

Typo3 Backend XSS Vulnerability

Multiple cross-site scripting (XSS) vulnerabilities in the backend in TYPO3 4.5.x before 4.5.19, 4.6.x before 4.6.12 and 4.7.x before 4.7.4 allow remote authenticated backend users to inject arbitrary web script or HTML via unspecified vectors.

Record
GHSA-7w6c-5pr4-7qvp
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-7w6c-5pr4-7qvp No score

Typo3 Backend XSS Vulnerability

Multiple cross-site scripting (XSS) vulnerabilities in the backend in TYPO3 4.5.x before 4.5.19, 4.6.x before 4.6.12 and 4.7.x before 4.7.4 allow remote authenticated backend users to inject arbitrary web script or HTML via unspecified vectors.

Record
GHSA-7w6c-5pr4-7qvp
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
typo3/cms
Packagist
4.5 up to 4.5.19
4.5.19
typo3/cms
Packagist
4.6 up to 4.6.12
4.6.12
typo3/cms
Packagist
4.7 up to 4.7.4
4.7.4
typo3-src
Debian:6.0
before 4.3.9+dfsg1-1+squeeze5, plus listed versions
4.3.9+dfsg1-14.3.9+dfsg1-1+squeeze14.3.9+dfsg1-1+squeeze24.3.9+dfsg1-1+squeeze34.3.9+dfsg1-1+squeeze4
4.3.9+dfsg1-1+squeeze5

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

MoveEnter Open