CVE-2012-3531
Typo3 Install Tool XSS Vulnerability
CVE-2012-3531 is a medium vulnerability (CVSS 4.3) in Typo3, published August 30, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.49%, the 74th percentile. Fixed in typo3/cms 4.5.19.
Cross-site scripting (XSS) vulnerability in the Install Tool in TYPO3 4.5.x before 4.5.19, 4.6.x before 4.6.12 and 4.7.x before 4.7.4 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Exploit likelihood
What each source reports
NVD Score used
4.3
Cross-site scripting (XSS) vulnerability in the Install Tool in TYPO3 4.5.x before 4.5.19, 4.6.x before 4.6.12 and 4.7.x before 4.7.4 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
CVE-2012-3531- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in the Install Tool in TYPO3 4.5.x before 4.5.19, 4.6.x before 4.6.12 and 4.7.x before 4.7.4 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
CVE-2012-3531- Updated
- 2026-11-02
EUVDEUVD-2022-4733 No score
Cross-site scripting (XSS) vulnerability in the Install Tool in TYPO3 4.5.x before 4.5.19, 4.6.x before 4.6.12 and 4.7.x before 4.7.4 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
EUVD-2022-4733- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-p9wg-jvj4-cx26 No score
Typo3 Install Tool XSS Vulnerability
Cross-site scripting (XSS) vulnerability in the Install Tool in TYPO3 4.5.x before 4.5.19, 4.6.x before 4.6.12 and 4.7.x before 4.7.4 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
GHSA-p9wg-jvj4-cx26- Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-p9wg-jvj4-cx26 No score
Typo3 Install Tool XSS Vulnerability
Cross-site scripting (XSS) vulnerability in the Install Tool in TYPO3 4.5.x before 4.5.19, 4.6.x before 4.6.12 and 4.7.x before 4.7.4 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
GHSA-p9wg-jvj4-cx26- Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
typo3/cmsPackagist |
4.5 up to 4.5.19 | 4.5.19 |
typo3/cmsPackagist |
4.6 up to 4.6.12 | 4.6.12 |
typo3/cmsPackagist |
4.7 up to 4.7.4 | 4.7.4 |
typo3-srcDebian:6.0 |
before 4.3.9+dfsg1-1+squeeze5, plus listed versions 4.3.9+dfsg1-14.3.9+dfsg1-1+squeeze14.3.9+dfsg1-1+squeeze24.3.9+dfsg1-1+squeeze34.3.9+dfsg1-1+squeeze4 |
4.3.9+dfsg1-1+squeeze5 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |