Every CVE Search/ Get API key

CVE-2012-3825

Multiple integer overflows in Wireshark 1.4.x before 1.4.13 and 1.6.x before 1.6.8 allow remote...

3.3 LowPublic exploitFix available

Multiple integer overflows in Wireshark 1.4.x before 1.4.13 and 1.6.x before 1.6.8 allow remote attackers to cause a denial of service (infinite loop) via vectors related to the (1) BACapp and (2) Bluetooth HCI dissectors, a different vulnerability than CVE-2012-2392.

Exploit likelihood

3.31%Up 2.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 3.3

Multiple integer overflows in Wireshark 1.4.x before 1.4.13 and 1.6.x before 1.6.8 allow remote attackers to cause a denial of service (infinite loop) via vectors related to the (1) BACapp and (2) Bluetooth HCI dissectors, a different vulnerability than CVE-2012-2392.

Record
CVE-2012-3825
CVSS 2.0
3.3 LowAV:A/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-189
Updated
2026-11-02
CVE List No score

Multiple integer overflows in Wireshark 1.4.x before 1.4.13 and 1.6.x before 1.6.8 allow remote attackers to cause a denial of service (infinite loop) via vectors related to the (1) BACapp and (2) Bluetooth HCI dissectors, a different vulnerability than CVE-2012-2392.

Record
CVE-2012-3825
Updated
2026-11-02
EUVDEUVD-2012-3772 No score

Multiple integer overflows in Wireshark 1.4.x before 1.4.13 and 1.6.x before 1.6.8 allow remote attackers to cause a denial of service (infinite loop) via vectors related to the (1) BACapp and (2) Bluetooth HCI dissectors, a different vulnerability than CVE-2012-2392.

Record
EUVD-2012-3772
Updated
2026-11-03
GitHub AdvisoriesGHSA-w9xg-mh3r-5q8v No score

Multiple integer overflows in Wireshark 1.4.x before 1.4.13 and 1.6.x before 1.6.8 allow remote...

Multiple integer overflows in Wireshark 1.4.x before 1.4.13 and 1.6.x before 1.6.8 allow remote attackers to cause a denial of service (infinite loop) via vectors related to the (1) BACapp and (2) Bluetooth HCI dissectors, a different vulnerability than CVE-2012-2392.

Record
GHSA-w9xg-mh3r-5q8v
Updated
2026-11-02
OSV No score

Multiple integer overflows in Wireshark 1.4.x before 1.4.13 and 1.6.x before 1.6.8 allow remote attackers to cause a denial of service (infinite loop) via vectors related to the (1) BACapp and (2) Bluetooth HCI dissectors, a different vulnerability than CVE-2012-2392.

Record
CVE-2012-3825
Updated
2026-11-02
OSVDEBIAN-CVE-2012-3825 No score

Multiple integer overflows in Wireshark 1.4.x before 1.4.13 and 1.6.x before 1.6.8 allow remote attackers to cause a denial of service (infinite loop) via vectors related to the (1) BACapp and (2) Bluetooth HCI dissectors, a different vulnerability than CVE-2012-2392.

Record
DEBIAN-CVE-2012-3825
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wireshark
Debian:12
before 1.6.8-1
1.6.8-1
wireshark
Debian:13
before 1.6.8-1
1.6.8-1
wireshark
Debian:14
before 1.6.8-1
1.6.8-1
wireshark
Red Hat:enterprise_linux:6::client
before 0:1.8.10-4.el6
0:1.8.10-4.el6
wireshark-debuginfo
Red Hat:enterprise_linux:6::client
before 0:1.8.10-4.el6
0:1.8.10-4.el6
wireshark-devel
Red Hat:enterprise_linux:6::client
before 0:1.8.10-4.el6
0:1.8.10-4.el6
wireshark-gnome
Red Hat:enterprise_linux:6::client
before 0:1.8.10-4.el6
0:1.8.10-4.el6
wireshark
Red Hat:enterprise_linux:6::server
before 0:1.8.10-4.el6
0:1.8.10-4.el6
wireshark-debuginfo
Red Hat:enterprise_linux:6::server
before 0:1.8.10-4.el6
0:1.8.10-4.el6
wireshark-devel
Red Hat:enterprise_linux:6::server
before 0:1.8.10-4.el6
0:1.8.10-4.el6
Show 5 moreShow less
Affected packages
PackageAffectedFixed
wireshark-gnome
Red Hat:enterprise_linux:6::server
before 0:1.8.10-4.el6
0:1.8.10-4.el6
wireshark
Red Hat:enterprise_linux:6::workstation
before 0:1.8.10-4.el6
0:1.8.10-4.el6
wireshark-debuginfo
Red Hat:enterprise_linux:6::workstation
before 0:1.8.10-4.el6
0:1.8.10-4.el6
wireshark-devel
Red Hat:enterprise_linux:6::workstation
before 0:1.8.10-4.el6
0:1.8.10-4.el6
wireshark-gnome
Red Hat:enterprise_linux:6::workstation
before 0:1.8.10-4.el6
0:1.8.10-4.el6

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBWireshark - Multiple Dissector Denial of Service Vulnerabilities2012-05-24

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2012-3825 is a low vulnerability (CVSS 3.3) in Wireshark, published June 30, 2012. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 3.31%, the 88th percentile. Fixed in wireshark 1.6.8-1.

References

Show 135 moreShow less
MoveEnter Open