Every CVE Search/ Get API key

CVE-2012-4291

The CIP dissector in Wireshark 1.4.x before 1.4.15, 1.6.x before 1.6.10, and 1.8.x before 1.8.2...

3.3 LowFix available

The CIP dissector in Wireshark 1.4.x before 1.4.15, 1.6.x before 1.6.10, and 1.8.x before 1.8.2 allows remote attackers to cause a denial of service (memory consumption) via a malformed packet.

Exploit likelihood

1.19%Down 1.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 3.3

The CIP dissector in Wireshark 1.4.x before 1.4.15, 1.6.x before 1.6.10, and 1.8.x before 1.8.2 allows remote attackers to cause a denial of service (memory consumption) via a malformed packet.

Record
CVE-2012-4291
CVSS 2.0
3.3 LowAV:A/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-399
Updated
2026-11-02
CVE List No score

The CIP dissector in Wireshark 1.4.x before 1.4.15, 1.6.x before 1.6.10, and 1.8.x before 1.8.2 allows remote attackers to cause a denial of service (memory consumption) via a malformed packet.

Record
CVE-2012-4291
Updated
2026-11-02
EUVDEUVD-2012-4235 No score

The CIP dissector in Wireshark 1.4.x before 1.4.15, 1.6.x before 1.6.10, and 1.8.x before 1.8.2 allows remote attackers to cause a denial of service (memory consumption) via a malformed packet.

Record
EUVD-2012-4235
Updated
2026-11-03
GitHub AdvisoriesGHSA-32x4-wf82-frg6 No score

The CIP dissector in Wireshark 1.4.x before 1.4.15, 1.6.x before 1.6.10, and 1.8.x before 1.8.2...

The CIP dissector in Wireshark 1.4.x before 1.4.15, 1.6.x before 1.6.10, and 1.8.x before 1.8.2 allows remote attackers to cause a denial of service (memory consumption) via a malformed packet.

Record
GHSA-32x4-wf82-frg6
Updated
2026-11-02
OSV No score

The CIP dissector in Wireshark 1.4.x before 1.4.15, 1.6.x before 1.6.10, and 1.8.x before 1.8.2 allows remote attackers to cause a denial of service (memory consumption) via a malformed packet.

Record
CVE-2012-4291
Updated
2026-11-02
OSVDEBIAN-CVE-2012-4291 No score

The CIP dissector in Wireshark 1.4.x before 1.4.15, 1.6.x before 1.6.10, and 1.8.x before 1.8.2 allows remote attackers to cause a denial of service (memory consumption) via a malformed packet.

Record
DEBIAN-CVE-2012-4291
Updated
2026-11-02
OSVopenSUSE-SU-2024:10199-1 No score

wireshark-2.2.2-1.1 on GA media

These are all security issues fixed in the wireshark-2.2.2-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10199-1
Updated
2026-11-02
OSVUBUNTU-CVE-2012-4291 No score

The CIP dissector in Wireshark 1.4.x before 1.4.15, 1.6.x before 1.6.10, and 1.8.x before 1.8.2 allows remote attackers to cause a denial of service (memory consumption) via a malformed packet.

Record
UBUNTU-CVE-2012-4291
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wireshark
Debian:12
before 1.8.2-1
1.8.2-1
wireshark
Debian:13
before 1.8.2-1
1.8.2-1
wireshark
Debian:14
before 1.8.2-1
1.8.2-1
wireshark
Red Hat:enterprise_linux:5::client_workstation
before 0:1.0.15-5.el5
0:1.0.15-5.el5
wireshark-debuginfo
Red Hat:enterprise_linux:5::client_workstation
before 0:1.0.15-5.el5
0:1.0.15-5.el5
wireshark-gnome
Red Hat:enterprise_linux:5::client_workstation
before 0:1.0.15-5.el5
0:1.0.15-5.el5
wireshark
Red Hat:enterprise_linux:5::client
before 0:1.0.15-5.el5
0:1.0.15-5.el5
wireshark-debuginfo
Red Hat:enterprise_linux:5::client
before 0:1.0.15-5.el5
0:1.0.15-5.el5
wireshark
Red Hat:enterprise_linux:5::server
before 0:1.0.15-5.el5
0:1.0.15-5.el5
wireshark-debuginfo
Red Hat:enterprise_linux:5::server
before 0:1.0.15-5.el5
0:1.0.15-5.el5
Show 14 moreShow less
Affected packages
PackageAffectedFixed
wireshark-gnome
Red Hat:enterprise_linux:5::server
before 0:1.0.15-5.el5
0:1.0.15-5.el5
wireshark
Red Hat:enterprise_linux:6::client
before 0:1.8.10-4.el6
0:1.8.10-4.el6
wireshark-debuginfo
Red Hat:enterprise_linux:6::client
before 0:1.8.10-4.el6
0:1.8.10-4.el6
wireshark-devel
Red Hat:enterprise_linux:6::client
before 0:1.8.10-4.el6
0:1.8.10-4.el6
wireshark-gnome
Red Hat:enterprise_linux:6::client
before 0:1.8.10-4.el6
0:1.8.10-4.el6
wireshark
Red Hat:enterprise_linux:6::server
before 0:1.8.10-4.el6
0:1.8.10-4.el6
wireshark-debuginfo
Red Hat:enterprise_linux:6::server
before 0:1.8.10-4.el6
0:1.8.10-4.el6
wireshark-devel
Red Hat:enterprise_linux:6::server
before 0:1.8.10-4.el6
0:1.8.10-4.el6
wireshark-gnome
Red Hat:enterprise_linux:6::server
before 0:1.8.10-4.el6
0:1.8.10-4.el6
wireshark
Red Hat:enterprise_linux:6::workstation
before 0:1.8.10-4.el6
0:1.8.10-4.el6
wireshark-debuginfo
Red Hat:enterprise_linux:6::workstation
before 0:1.8.10-4.el6
0:1.8.10-4.el6
wireshark-devel
Red Hat:enterprise_linux:6::workstation
before 0:1.8.10-4.el6
0:1.8.10-4.el6
wireshark-gnome
Red Hat:enterprise_linux:6::workstation
before 0:1.8.10-4.el6
0:1.8.10-4.el6
wireshark
openSUSE:Tumbleweed
before 2.2.2-1.1
2.2.2-1.1

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2012-4291 is a low vulnerability (CVSS 3.3) in Wireshark, published August 16, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.19%, the 68th percentile. Fixed in wireshark 1.8.2-1.

References

Show 194 moreShow less
This page doesn't list everything

Left out here: 253 references. The JSON record has them.

MoveEnter Open