Every CVE Search/ Get API key

CVE-2012-4427

The gnome-shell plugin 3.4.1 in GNOME allows remote attackers to force the download and...

6.8 MediumFix available

The gnome-shell plugin 3.4.1 in GNOME allows remote attackers to force the download and installation of arbitrary extensions from extensions.gnome.org via a crafted web page.

Exploit likelihood

1.29%Unchanged since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

The gnome-shell plugin 3.4.1 in GNOME allows remote attackers to force the download and installation of arbitrary extensions from extensions.gnome.org via a crafted web page.

Record
CVE-2012-4427
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-94
Updated
2026-11-02
CVE List No score

The gnome-shell plugin 3.4.1 in GNOME allows remote attackers to force the download and installation of arbitrary extensions from extensions.gnome.org via a crafted web page.

Record
CVE-2012-4427
Updated
2026-11-02
EUVDEUVD-2012-4362 No score

The gnome-shell plugin 3.4.1 in GNOME allows remote attackers to force the download and installation of arbitrary extensions from extensions.gnome.org via a crafted web page.

Record
EUVD-2012-4362
Updated
2026-11-03
GitHub AdvisoriesGHSA-gxj3-vwm6-2f7w No score

The gnome-shell plugin 3.4.1 in GNOME allows remote attackers to force the download and...

The gnome-shell plugin 3.4.1 in GNOME allows remote attackers to force the download and installation of arbitrary extensions from extensions.gnome.org via a crafted web page.

Record
GHSA-gxj3-vwm6-2f7w
Weakness
CWE-94
Updated
2026-11-02
OSV No score

The gnome-shell plugin 3.4.1 in GNOME allows remote attackers to force the download and installation of arbitrary extensions from extensions.gnome.org via a crafted web page.

Record
CVE-2012-4427
Updated
2026-11-02
OSVDEBIAN-CVE-2012-4427 No score

The gnome-shell plugin 3.4.1 in GNOME allows remote attackers to force the download and installation of arbitrary extensions from extensions.gnome.org via a crafted web page.

Record
DEBIAN-CVE-2012-4427
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gnome-shell
Debian:12
before 3.34.0-2
3.34.0-2
gnome-shell
Debian:13
before 3.34.0-2
3.34.0-2
gnome-shell
Debian:14
before 3.34.0-2
3.34.0-2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2012-4427 is a medium vulnerability (CVSS 6.8) in Gnome Gnome-shell, published October 1, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.29%, the 70th percentile. Fixed in gnome-shell 3.34.0-2.

References

Show 4 moreShow less
MoveEnter Open