CVE-2012-4428
openslp: SLPIntersectStringList()' Function has a DoS vulnerability
openslp: SLPIntersectStringList()' Function has a DoS vulnerability
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
openslp: SLPIntersectStringList()' Function has a DoS vulnerability
- Record
CVE-2012-4428- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-125
- Updated
- 2026-11-02
CVE List No score
openslp: SLPIntersectStringList()' Function has a DoS vulnerability
- Record
CVE-2012-4428- Updated
- 2026-11-02
EUVDEUVD-2012-4363 No score
openslp: SLPIntersectStringList()' Function has a DoS vulnerability
- Record
EUVD-2012-4363- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-x95h-4fhf-p9gw No score
openslp: SLPIntersectStringList()' Function has a DoS vulnerability
openslp: SLPIntersectStringList()' Function has a DoS vulnerability
- Record
GHSA-x95h-4fhf-p9gw- Updated
- 2026-11-02
OSVUBUNTU-CVE-2012-4428
7.5
openslp: SLPIntersectStringList()' Function has a DoS vulnerability
- Record
UBUNTU-CVE-2012-4428- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVSUSE-SU-2015:0922-1 No score
Security update for OpenSLP
This update for OpenSLP fixes a bug in SLPIntersectStringList that could lead to an out-of-bounds read (CVE-2012-4428). Additionally, the SLP daemon now always use localtime(3) when writing to log files to avoid having timestamps with different timezones.
Security Issues:
* CVE-2012-4428
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-4428>
- Record
SUSE-SU-2015:0922-1- Updated
- 2026-11-02
OSVUSN-2730-1 No score
openslp-dfsg vulnerabilities
Georgi Geshev discovered that OpenSLP incorrectly handled processing certain service requests. A remote attacker could possibly use this issue to cause OpenSLP to crash, resulting in a denial of service. This issue only affected Ubuntu 12.04 LTS and Ubuntu 14.04 LTS. (CVE-2012-4428)
Qinghao Tang discovered that OpenSLP incorrectly handled processing certain messages. A remote attacker could possibly use this issue to cause OpenSLP to crash, resulting in a denial of service. (CVE-2015-5177)
- Record
USN-2730-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
openslp-dfsgDebian:6.0 |
before 1.2.1-7.8+deb6u1, plus listed versions 1.2.1-7.8 |
1.2.1-7.8+deb6u1 |
openslp-dfsgUbuntu:14.04:LTS |
before 1.2.1-9ubuntu0.2, plus listed versions 1.2.1-9 |
1.2.1-9ubuntu0.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2012-4428 is a high vulnerability (CVSS 7.5) in Openslp, published September 13, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 10.1%, the 95th percentile. Fixed in openslp-dfsg 1.2.1-7.8+deb6u1.
References
security-tracker.debian.org/tracker/CVE-2012-4428
bugzilla.redhat.com/show_bug.cgi?id=CVE-2012-4428
bugzilla.suse.com/show_bug.cgi?id=CVE-2012-4428
access.redhat.com/security/cve/cve-2012-4428
exchange.xforce.ibmcloud.com/vulnerabilities/78732
lists.fedoraproject.org/pipermail/package-announce/2015-May/159059.html
Show 15 moreShow less
openwall.com/lists/oss-security/2012/09/13/27
securityfocus.com/bid/55540
ubuntu.com/usn/USN-2730-1
security.gentoo.org/glsa/201707-05
nvd.nist.gov/vuln/detail/CVE-2012-4428
github.com/advisories/GHSA-x95h-4fhf-p9gw
suse.com/support/update/announcement/2015/suse-su-20150922-1
bugzilla.suse.com/778508
bugzilla.suse.com/855385
suse.com/security/cve/CVE-2012-4428
ubuntu.com/security/CVE-2012-4428
openwall.com/lists/oss-security/2012/09/13
ubuntu.com/security/notices/USN-2730-1
cve.org/CVERecord?id=CVE-2012-4428
ubuntu.com/security/CVE-2015-5177