Every CVE Search/ Get API key

CVE-2012-4437

Cross-site Scripting in SmartyException

4.3 MediumFix available

Cross-site scripting (XSS) vulnerability in the SmartyException class in Smarty (aka smarty-php) before 3.1.12 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors that trigger a Smarty exception.

Exploit likelihood

2.46%Up 0.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in the SmartyException class in Smarty (aka smarty-php) before 3.1.12 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors that trigger a Smarty exception.

Record
CVE-2012-4437
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in the SmartyException class in Smarty (aka smarty-php) before 3.1.12 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors that trigger a Smarty exception.

Record
CVE-2012-4437
Updated
2026-11-02
EUVDEUVD-2022-3376 No score

Cross-site scripting (XSS) vulnerability in the SmartyException class in Smarty (aka smarty-php) before 3.1.12 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors that trigger a Smarty exception.

Record
EUVD-2022-3376
Updated
2026-11-03
GitHub AdvisoriesGHSA-9gqj-ppv2-f2hq No score

Cross-site Scripting in SmartyException

Cross-site scripting (XSS) vulnerability in the SmartyException class in Smarty (aka smarty-php) before 3.1.12 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors that trigger a Smarty exception.

Record
GHSA-9gqj-ppv2-f2hq
Weakness
CWE-79
Updated
2026-11-02
OSV No score

Cross-site scripting (XSS) vulnerability in the SmartyException class in Smarty (aka smarty-php) before 3.1.12 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors that trigger a Smarty exception.

Record
CVE-2012-4437
Updated
2026-11-02
OSVDEBIAN-CVE-2012-4437 No score

Cross-site scripting (XSS) vulnerability in the SmartyException class in Smarty (aka smarty-php) before 3.1.12 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors that trigger a Smarty exception.

Record
DEBIAN-CVE-2012-4437
Updated
2026-11-02
OSVGHSA-9gqj-ppv2-f2hq No score

Cross-site Scripting in SmartyException

Cross-site scripting (XSS) vulnerability in the SmartyException class in Smarty (aka smarty-php) before 3.1.12 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors that trigger a Smarty exception.

Record
GHSA-9gqj-ppv2-f2hq
Weakness
CWE-79
Updated
2026-11-02
OSVMGASA-2014-0468 No score

Updated php-smarty packages fix security vulnerabilities

Cross-site scripting (XSS) vulnerability in the SmartyException class in Smarty (aka smarty-php) before 3.1.12 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors that trigger a Smarty exception (CVE-2012-4437).

Smarty before 3.1.21 allows remote attackers to bypass the secure mode restrictions and execute arbitrary PHP code as demonstrated by "{literal}<{/literal}script language=php>" in a template (CVE-2014-8350).

Record
MGASA-2014-0468
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
smarty/smarty
Packagist
before 3.1.12
3.1.12
smarty3
Debian:12
before 3.1.10-2
3.1.10-2
smarty3
Debian:13
before 3.1.10-2
3.1.10-2
smarty3
Debian:14
before 3.1.10-2
3.1.10-2
smarty/smarty
Packagist
before 3.1.12, plus listed versions
v2.6.24v2.6.25v2.6.26v2.6.27v2.6.28
Show 5 moreShow less
v2.6.29v2.6.30v2.6.31v2.6.33v3.1.11
3.1.12
php-smarty
Mageia:3
before 3.1.21-1.mga3
3.1.21-1.mga3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2012-4437 is a medium vulnerability (CVSS 4.3) in Smarty, published October 1, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.46%, the 84th percentile. Fixed in smarty/smarty 3.1.12.

References

Show 12 moreShow less
MoveEnter Open