CVE-2012-4504
Stack-based buffer overflow in the url::get_pac function in url.cpp in libproxy 0.4.x before 0.4...
Stack-based buffer overflow in the url::get_pac function in url.cpp in libproxy 0.4.x before 0.4.9 allows remote servers to have an unspecified impact via a large proxy.pac file.
Exploit likelihood
What each source reports
NVD Score used
10.0
Stack-based buffer overflow in the url::get_pac function in url.cpp in libproxy 0.4.x before 0.4.9 allows remote servers to have an unspecified impact via a large proxy.pac file.
- Record
CVE-2012-4504- CVSS 2.0
- 10.0 High
AV:N/AC:L/Au:N/C:C/I:C/A:C - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
Stack-based buffer overflow in the url::get_pac function in url.cpp in libproxy 0.4.x before 0.4.9 allows remote servers to have an unspecified impact via a large proxy.pac file.
- Record
CVE-2012-4504- Updated
- 2026-11-02
EUVDEUVD-2012-4433 No score
Stack-based buffer overflow in the url::get_pac function in url.cpp in libproxy 0.4.x before 0.4.9 allows remote servers to have an unspecified impact via a large proxy.pac file.
- Record
EUVD-2012-4433- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-c5fx-qjrf-p783 No score
Stack-based buffer overflow in the url::get_pac function in url.cpp in libproxy 0.4.x before 0.4...
Stack-based buffer overflow in the url::get_pac function in url.cpp in libproxy 0.4.x before 0.4.9 allows remote servers to have an unspecified impact via a large proxy.pac file.
- Record
GHSA-c5fx-qjrf-p783- Weakness
- CWE-119
- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10327-1 No score
libproxy-devel-0.4.13-7.1 on GA media
These are all security issues fixed in the libproxy-devel-0.4.13-7.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10327-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libproxyopenSUSE:Tumbleweed |
before 0.4.13-7.1 | 0.4.13-7.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2012-4504 is a high vulnerability (CVSS 10.0) in Libproxy Project Libproxy, published November 11, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.48%, the 89th percentile. Fixed in libproxy 0.4.13-7.1.
References
lists.opensuse.org/opensuse-updates/2012-10/msg00065.html
secunia.com/advisories/51048
securityfocus.com/bid/55909
groups.google.com/forum?fromgroups=
bugzilla.redhat.com/show_bug.cgi?id=864417
ubuntu.com/usn/USN-1629-1
Show 8 moreShow less
openwall.com/lists/oss-security/2012/10/12/1
openwall.com/lists/oss-security/2012/10/12/5
code.google.com/p/libproxy/source/detail?r=853
exchange.xforce.ibmcloud.com/vulnerabilities/79249
openwall.com/lists/oss-security/2012/10/16/3
nvd.nist.gov/vuln/detail/CVE-2012-4504
github.com/advisories/GHSA-c5fx-qjrf-p783
suse.com/security/cve/CVE-2012-4504