Every CVE Search/ Get API key

CVE-2012-4510

cups-pk-helper before 0.2.3 does not properly wrap the (1) cupsGetFile and (2) cupsPutFile...

5.8 MediumFix available

CVE-2012-4510 is a medium vulnerability (CVSS 5.8) in Cups-pk-helper Project Cups-pk-helper, published October 23, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.22%, the 68th percentile. Fixed in cups-pk-helper 0.2.3-1.

cups-pk-helper before 0.2.3 does not properly wrap the (1) cupsGetFile and (2) cupsPutFile function calls, which allows user-assisted remote attackers to read or overwrite sensitive files using CUPS resources.

Exploit likelihood

1.22%Up 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.8

cups-pk-helper before 0.2.3 does not properly wrap the (1) cupsGetFile and (2) cupsPutFile function calls, which allows user-assisted remote attackers to read or overwrite sensitive files using CUPS resources.

Record
CVE-2012-4510
CVSS 2.0
5.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:N
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

cups-pk-helper before 0.2.3 does not properly wrap the (1) cupsGetFile and (2) cupsPutFile function calls, which allows user-assisted remote attackers to read or overwrite sensitive files using CUPS resources.

Record
CVE-2012-4510
Updated
2026-11-02
EUVDEUVD-2012-4439 No score

cups-pk-helper before 0.2.3 does not properly wrap the (1) cupsGetFile and (2) cupsPutFile function calls, which allows user-assisted remote attackers to read or overwrite sensitive files using CUPS resources.

Record
EUVD-2012-4439
Updated
2026-11-03
GitHub AdvisoriesGHSA-7h7x-v73m-4vv7 No score

cups-pk-helper before 0.2.3 does not properly wrap the (1) cupsGetFile and (2) cupsPutFile...

cups-pk-helper before 0.2.3 does not properly wrap the (1) cupsGetFile and (2) cupsPutFile function calls, which allows user-assisted remote attackers to read or overwrite sensitive files using CUPS resources.

Record
GHSA-7h7x-v73m-4vv7
Updated
2026-11-02
OSV No score

cups-pk-helper before 0.2.3 does not properly wrap the (1) cupsGetFile and (2) cupsPutFile function calls, which allows user-assisted remote attackers to read or overwrite sensitive files using CUPS resources.

Record
CVE-2012-4510
Updated
2026-11-02
OSVDEBIAN-CVE-2012-4510 No score

cups-pk-helper before 0.2.3 does not properly wrap the (1) cupsGetFile and (2) cupsPutFile function calls, which allows user-assisted remote attackers to read or overwrite sensitive files using CUPS resources.

Record
DEBIAN-CVE-2012-4510
Updated
2026-11-02
OSVopenSUSE-SU-2024:10212-1 No score

cups-pk-helper-0.2.6-1.5 on GA media

These are all security issues fixed in the cups-pk-helper-0.2.6-1.5 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10212-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
cups-pk-helper
Debian:12
before 0.2.3-1
0.2.3-1
cups-pk-helper
Debian:13
before 0.2.3-1
0.2.3-1
cups-pk-helper
Debian:14
before 0.2.3-1
0.2.3-1
cups-pk-helper
Debian:6.0
before 0.1.0-3, plus listed versions
0.1.0-2
0.1.0-3
cups-pk-helper
openSUSE:Tumbleweed
before 0.2.6-1.5
0.2.6-1.5

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

MoveEnter Open