Every CVE Search/ Get API key

CVE-2012-4528

The mod_security2 module before 2.7.0 for the Apache HTTP Server allows remote attackers to...

5.0 MediumPublic exploitFix available

CVE-2012-4528 is a medium vulnerability (CVSS 5.0) in Fedoraproject Fedora, published December 28, 2012. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 12.4%, the 96th percentile. Fixed in modsecurity-apache 2.6.6-5.

The mod_security2 module before 2.7.0 for the Apache HTTP Server allows remote attackers to bypass rules, and deliver arbitrary POST data to a PHP application, via a multipart request in which an invalid part precedes the crafted data.

Exploit likelihood

12.4%Down 1.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

The mod_security2 module before 2.7.0 for the Apache HTTP Server allows remote attackers to bypass rules, and deliver arbitrary POST data to a PHP application, via a multipart request in which an invalid part precedes the crafted data.

Record
CVE-2012-4528
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Updated
2026-11-02
CVE List No score

The mod_security2 module before 2.7.0 for the Apache HTTP Server allows remote attackers to bypass rules, and deliver arbitrary POST data to a PHP application, via a multipart request in which an invalid part precedes the crafted data.

Record
CVE-2012-4528
Updated
2026-11-02
EUVDEUVD-2012-4456 No score

The mod_security2 module before 2.7.0 for the Apache HTTP Server allows remote attackers to bypass rules, and deliver arbitrary POST data to a PHP application, via a multipart request in which an invalid part precedes the crafted data.

Record
EUVD-2012-4456
Updated
2026-11-03
GitHub AdvisoriesGHSA-v835-w774-qhww No score

The mod_security2 module before 2.7.0 for the Apache HTTP Server allows remote attackers to...

The mod_security2 module before 2.7.0 for the Apache HTTP Server allows remote attackers to bypass rules, and deliver arbitrary POST data to a PHP application, via a multipart request in which an invalid part precedes the crafted data.

Record
GHSA-v835-w774-qhww
Updated
2026-11-02
OSV No score

The mod_security2 module before 2.7.0 for the Apache HTTP Server allows remote attackers to bypass rules, and deliver arbitrary POST data to a PHP application, via a multipart request in which an invalid part precedes the crafted data.

Record
CVE-2012-4528
Updated
2026-11-02
OSVDEBIAN-CVE-2012-4528 No score

The mod_security2 module before 2.7.0 for the Apache HTTP Server allows remote attackers to bypass rules, and deliver arbitrary POST data to a PHP application, via a multipart request in which an invalid part precedes the crafted data.

Record
DEBIAN-CVE-2012-4528
Updated
2026-11-02
OSVopenSUSE-SU-2024:10034-1 No score

apache2-mod_security2-2.9.0-5.6 on GA media

These are all security issues fixed in the apache2-mod_security2-2.9.0-5.6 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10034-1
Updated
2026-11-02
OSVUBUNTU-CVE-2012-4528 No score

The mod_security2 module before 2.7.0 for the Apache HTTP Server allows remote attackers to bypass rules, and deliver arbitrary POST data to a PHP application, via a multipart request in which an invalid part precedes the crafted data.

Record
UBUNTU-CVE-2012-4528
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
modsecurity-apache
Debian:12
before 2.6.6-5
2.6.6-5
modsecurity-apache
Debian:13
before 2.6.6-5
2.6.6-5
modsecurity-apache
Debian:14
before 2.6.6-5
2.6.6-5
apache2-mod_security2
openSUSE:Tumbleweed
before 2.9.0-5.6
2.9.0-5.6

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBModSecurity - 'POST' Security Bypass2012-10-17

History

History
WhenChangedSources
2026-11-03affected
2026-11-03aliasesEUVD
2026-11-02createdCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

References

Show 15 moreShow less
MoveEnter Open