Every CVE Search/ Get API key

CVE-2012-4885

The wikitext parser in MediaWiki 1.17.x before 1.17.3 and 1.18.x before 1.18.2 allows remote...

5.0 MediumFix available

CVE-2012-4885 is a medium vulnerability (CVSS 5.0) in Mediawiki, published September 9, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.88%, the 79th percentile. Fixed in mediawiki 1:1.19.0-1.

The wikitext parser in MediaWiki 1.17.x before 1.17.3 and 1.18.x before 1.18.2 allows remote attackers to cause a denial of service (infinite loop) via certain input, as demonstrated by the padleft function.

Exploit likelihood

1.88%Up 0.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

The wikitext parser in MediaWiki 1.17.x before 1.17.3 and 1.18.x before 1.18.2 allows remote attackers to cause a denial of service (infinite loop) via certain input, as demonstrated by the padleft function.

Record
CVE-2012-4885
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Updated
2026-11-02
CVE List No score

The wikitext parser in MediaWiki 1.17.x before 1.17.3 and 1.18.x before 1.18.2 allows remote attackers to cause a denial of service (infinite loop) via certain input, as demonstrated by the padleft function.

Record
CVE-2012-4885
Updated
2026-11-02
EUVDEUVD-2012-4810 No score

The wikitext parser in MediaWiki 1.17.x before 1.17.3 and 1.18.x before 1.18.2 allows remote attackers to cause a denial of service (infinite loop) via certain input, as demonstrated by the padleft function.

Record
EUVD-2012-4810
Updated
2026-11-03
GitHub AdvisoriesGHSA-cw9f-6pvh-rr9x No score

The wikitext parser in MediaWiki 1.17.x before 1.17.3 and 1.18.x before 1.18.2 allows remote...

The wikitext parser in MediaWiki 1.17.x before 1.17.3 and 1.18.x before 1.18.2 allows remote attackers to cause a denial of service (infinite loop) via certain input, as demonstrated by the padleft function.

Record
GHSA-cw9f-6pvh-rr9x
Updated
2026-11-02
OSV No score

The wikitext parser in MediaWiki 1.17.x before 1.17.3 and 1.18.x before 1.18.2 allows remote attackers to cause a denial of service (infinite loop) via certain input, as demonstrated by the padleft function.

Record
CVE-2012-4885
Updated
2026-11-02
OSVDEBIAN-CVE-2012-4885 No score

The wikitext parser in MediaWiki 1.17.x before 1.17.3 and 1.18.x before 1.18.2 allows remote attackers to cause a denial of service (infinite loop) via certain input, as demonstrated by the padleft function.

Record
DEBIAN-CVE-2012-4885
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mediawiki
Debian:12
before 1:1.19.0-1
1:1.19.0-1
mediawiki
Debian:13
before 1:1.19.0-1
1:1.19.0-1
mediawiki
Debian:14
before 1:1.19.0-1
1:1.19.0-1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 5 moreShow less
MoveEnter Open