Every CVE Search/ Get API key

CVE-2012-5112

Use-after-free vulnerability in the SVG implementation in WebKit, as used in Google Chrome before...

10.0 HighFix available

Use-after-free vulnerability in the SVG implementation in WebKit, as used in Google Chrome before 22.0.1229.94, allows remote attackers to execute arbitrary code via unspecified vectors.

Exploit likelihood

4.64%Down 3.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 10.0

Use-after-free vulnerability in the SVG implementation in WebKit, as used in Google Chrome before 22.0.1229.94, allows remote attackers to execute arbitrary code via unspecified vectors.

Record
CVE-2012-5112
CVSS 2.0
10.0 HighAV:N/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-399
Updated
2026-11-02
CVE List No score

Use-after-free vulnerability in the SVG implementation in WebKit, as used in Google Chrome before 22.0.1229.94, allows remote attackers to execute arbitrary code via unspecified vectors.

Record
CVE-2012-5112
Updated
2026-11-02
EUVDEUVD-2012-5035 No score

Use-after-free vulnerability in the SVG implementation in WebKit, as used in Google Chrome before 22.0.1229.94, allows remote attackers to execute arbitrary code via unspecified vectors.

Record
EUVD-2012-5035
Updated
2026-11-03
GitHub AdvisoriesGHSA-fqc7-p492-g423 No score

Use-after-free vulnerability in the SVG implementation in WebKit, as used in Google Chrome before...

Use-after-free vulnerability in the SVG implementation in WebKit, as used in Google Chrome before 22.0.1229.94, allows remote attackers to execute arbitrary code via unspecified vectors.

Record
GHSA-fqc7-p492-g423
Updated
2026-11-02
OSVopenSUSE-SU-2024:10461-1 No score

libjavascriptcoregtk-1_0-0-2.4.11-3.3 on GA media

These are all security issues fixed in the libjavascriptcoregtk-1_0-0-2.4.11-3.3 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10461-1
Updated
2026-11-02
OSVUBUNTU-CVE-2012-5112 No score

Use-after-free vulnerability in the SVG implementation in WebKit, as used in Google Chrome before 22.0.1229.94, allows remote attackers to execute arbitrary code via unspecified vectors.

Record
UBUNTU-CVE-2012-5112
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
qtwebkit-source
Ubuntu:16.04:LTS
All versions, plus listed versions
2.3.2-0ubuntu102.3.2-0ubuntu11
None known
gtk3
openSUSE:Tumbleweed
before 2.4.11-3.3
2.4.11-3.3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2012-5112 is a high vulnerability (CVSS 10.0) in Google Chrome, published October 11, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.64%, the 91st percentile. Fixed in gtk3 2.4.11-3.3.

References

Show 50 moreShow less
MoveEnter Open