CVE-2012-5881
Cross-site scripting in yui 2.4.0
Cross-site scripting (XSS) vulnerability in the Flash component infrastructure in YUI 2.4.0 through 2.9.0 allows remote attackers to inject arbitrary web script or HTML via vectors related to charts.swf, a similar issue to CVE-2010-4207.
Exploit likelihood
What each source reports
NVD Score used
4.3
Cross-site scripting (XSS) vulnerability in the Flash component infrastructure in YUI 2.4.0 through 2.9.0 allows remote attackers to inject arbitrary web script or HTML via vectors related to charts.swf, a similar issue to CVE-2010-4207.
- Record
CVE-2012-5881- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in the Flash component infrastructure in YUI 2.4.0 through 2.9.0 allows remote attackers to inject arbitrary web script or HTML via vectors related to charts.swf, a similar issue to CVE-2010-4207.
- Record
CVE-2012-5881- Updated
- 2026-11-02
EUVDEUVD-2022-4384 No score
Cross-site scripting (XSS) vulnerability in the Flash component infrastructure in YUI 2.4.0 through 2.9.0 allows remote attackers to inject arbitrary web script or HTML via vectors related to charts.swf, a similar issue to CVE-2010-4207.
- Record
EUVD-2022-4384- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-jjg9-mf63-vqrp No score
Cross-site scripting in yui 2.4.0
Cross-site scripting (XSS) vulnerability in the Flash component infrastructure in YUI 2.4.0 through 2.9.0 allows remote attackers to inject arbitrary web script or HTML via vectors related to charts.swf, a similar issue to CVE-2010-4207.
- Record
GHSA-jjg9-mf63-vqrp- Weakness
- CWE-79
- Updated
- 2026-11-02
OSVCLSA-2026-1773965916 No score
TuxCare security update for yui2 (1 CVE)
TuxCare rebuilt yui2 to address 1 CVE. Fixed in 2.9.0-tuxcare.1.
- Record
CLSA-2026-1773965916- Updated
- 2026-11-02
OSVGHSA-jjg9-mf63-vqrp No score
Cross-site scripting in yui 2.4.0
Cross-site scripting (XSS) vulnerability in the Flash component infrastructure in YUI 2.4.0 through 2.9.0 allows remote attackers to inject arbitrary web script or HTML via vectors related to charts.swf, a similar issue to CVE-2010-4207.
- Record
GHSA-jjg9-mf63-vqrp- Weakness
- CWE-79
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2012-5881 No score
Cross-site scripting (XSS) vulnerability in the Flash component infrastructure in YUI 2.4.0 through 2.9.0 allows remote attackers to inject arbitrary web script or HTML via vectors related to charts.swf, a similar issue to CVE-2010-4207.
- Record
UBUNTU-CVE-2012-5881- Updated
- 2026-11-02
Affected products
Affected packages
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2012-5881 is a medium vulnerability (CVSS 4.3) in Yahoo Yui, published November 16, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.45%, the 84th percentile. Fixed in yui2 2.9.0-tuxcare.1.
References
yuiblog.com/blog/2012/11/05/post-mortem-swf-vulnerability-in-yui-2
yuiblog.com/blog/2012/10/30/security-announcement-swf-vulnerability-in-yui-2
securityfocus.com/bid/56385
exchange.xforce.ibmcloud.com/vulnerabilities/80118
yuilibrary.com/support/20121030-vulnerability
nvd.nist.gov/vuln/detail/CVE-2012-5881
github.com/advisories/GHSA-jjg9-mf63-vqrp
ubuntu.com/security/CVE-2012-5881
cve.org/CVERecord?id=CVE-2012-5881