Every CVE Search/ Get API key

CVE-2012-6135

RubyGems passenger gem allows remote attackers to delete files

7.5 HighFix available

CVE-2012-6135 is a high vulnerability (CVSS 7.5) in Phusion Passenger, published November 19, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.31%, the 83rd percentile. Fixed in passenger 4.0.0.rc4.

RubyGems passenger 4.0.0 betas 1 and 2 allows remote attackers to delete arbitrary files during the startup process.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

2.31%Up 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

RubyGems passenger 4.0.0 betas 1 and 2 allows remote attackers to delete arbitrary files during the startup process.

Record
CVE-2012-6135
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0
6.4 MediumAV:N/AC:L/Au:N/C:N/I:P/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

RubyGems passenger 4.0.0 betas 1 and 2 allows remote attackers to delete arbitrary files during the startup process.

Record
CVE-2012-6135
Updated
2026-11-02
EUVDEUVD-2022-1680 No score

RubyGems passenger 4.0.0 betas 1 and 2 allows remote attackers to delete arbitrary files during the startup process.

Record
EUVD-2022-1680
Updated
2026-11-03
GitHub AdvisoriesGHSA-8mw8-j583-vqfg 7.5

RubyGems passenger gem allows remote attackers to delete files

RubyGems passenger 4.0.0 betas 1 and 2 allows remote attackers to delete arbitrary files during the startup process.

Affects both open source and Enterprise versions (4.0.0.beta1, 4.0.0.beta2).

Record
GHSA-8mw8-j583-vqfg
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-20
Updated
2026-11-02
OSVGHSA-8mw8-j583-vqfg 7.5

RubyGems passenger gem allows remote attackers to delete files

RubyGems passenger 4.0.0 betas 1 and 2 allows remote attackers to delete arbitrary files during the startup process.

Affects both open source and Enterprise versions (4.0.0.beta1, 4.0.0.beta2).

Record
GHSA-8mw8-j583-vqfg
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-20
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
passenger
RubyGems
before 4.0.0.rc4
4.0.0.rc4
passenger
RubyGems
before 4.0.0.rc4, plus listed versions
1.0.11.0.21.0.31.0.41.0.5
Show 45 moreShow less
2.0.12.0.22.0.32.0.42.0.52.0.62.1.22.1.32.2.02.2.12.2.102.2.112.2.122.2.132.2.142.2.152.2.22.2.32.2.42.2.52.2.62.2.72.2.82.2.93.0.03.0.0.pre13.0.0.pre23.0.0.pre33.0.0.pre43.0.13.0.103.0.113.0.123.0.133.0.143.0.153.0.173.0.183.0.193.0.23.0.213.0.33.0.43.0.53.0.6
4.0.0.rc4

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 5 moreShow less
This page doesn't list everything

Left out here: 5 versions. The JSON record has them.

MoveEnter Open