CVE-2012-6147
Typo3 Backend API XSS Vulnerability
Cross-site scripting (XSS) vulnerability in the tree render API (TCA-Tree) in the Backend API in TYPO3 4.5.x before 4.5.21, 4.6.x before 4.6.14, and 4.7.x before 4.7.6 allows remote authenticated backend users to inject arbitrary web script or HTML via unspecified vectors.
Exploit likelihood
What each source reports
NVD Score used
3.5
Cross-site scripting (XSS) vulnerability in the tree render API (TCA-Tree) in the Backend API in TYPO3 4.5.x before 4.5.21, 4.6.x before 4.6.14, and 4.7.x before 4.7.6 allows remote authenticated backend users to inject arbitrary web script or HTML via unspecified vectors.
- Record
CVE-2012-6147- CVSS 2.0
- 3.5 Low
AV:N/AC:M/Au:S/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in the tree render API (TCA-Tree) in the Backend API in TYPO3 4.5.x before 4.5.21, 4.6.x before 4.6.14, and 4.7.x before 4.7.6 allows remote authenticated backend users to inject arbitrary web script or HTML via unspecified vectors.
- Record
CVE-2012-6147- Updated
- 2026-11-02
EUVDEUVD-2022-5001 No score
Cross-site scripting (XSS) vulnerability in the tree render API (TCA-Tree) in the Backend API in TYPO3 4.5.x before 4.5.21, 4.6.x before 4.6.14, and 4.7.x before 4.7.6 allows remote authenticated backend users to inject arbitrary web script or HTML via unspecified vectors.
- Record
EUVD-2022-5001- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-qmmw-ch2q-j6xx No score
Typo3 Backend API XSS Vulnerability
Cross-site scripting (XSS) vulnerability in the tree render API (TCA-Tree) in the Backend API in TYPO3 4.5.x before 4.5.21, 4.6.x before 4.6.14, and 4.7.x before 4.7.6 allows remote authenticated backend users to inject arbitrary web script or HTML via unspecified vectors.
- Record
GHSA-qmmw-ch2q-j6xx- Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-qmmw-ch2q-j6xx No score
Typo3 Backend API XSS Vulnerability
Cross-site scripting (XSS) vulnerability in the tree render API (TCA-Tree) in the Backend API in TYPO3 4.5.x before 4.5.21, 4.6.x before 4.6.14, and 4.7.x before 4.7.6 allows remote authenticated backend users to inject arbitrary web script or HTML via unspecified vectors.
- Record
GHSA-qmmw-ch2q-j6xx- Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
typo3/cmsPackagist |
4.5.0 up to 4.5.21 | 4.5.21 |
typo3/cmsPackagist |
4.6.0 up to 4.6.14 | 4.6.14 |
typo3/cmsPackagist |
4.7.0 up to 4.7.6 | 4.7.6 |
typo3-srcDebian:6.0 |
before 4.3.9+dfsg1-1+squeeze7, plus listed versions 4.3.9+dfsg1-14.3.9+dfsg1-1+squeeze14.3.9+dfsg1-1+squeeze24.3.9+dfsg1-1+squeeze34.3.9+dfsg1-1+squeeze44.3.9+dfsg1-1+squeeze54.3.9+dfsg1-1+squeeze6 |
4.3.9+dfsg1-1+squeeze7 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2012-6147 is a low vulnerability (CVSS 3.5) in Typo3, published November 15, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.82%, the 78th percentile. Fixed in typo3/cms 4.5.21.