Every CVE Search/ Get API key

CVE-2012-6497

Authlogic Information Exposure vulnerability

5.0 MediumFix available

CVE-2012-6497 is a medium vulnerability (CVSS 5.0) in Rubyonrails Rails, published January 4, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.74%, the 86th percentile. Fixed in authlogic 3.3.0.

The Authlogic gem for Ruby on Rails, when used with certain versions before 3.2.10, makes potentially unsafe find_by_id method calls, which might allow remote attackers to conduct CVE-2012-6496 SQL injection attacks via a crafted parameter in environments that have a known secret_token value, as demonstrated by a value contained in secret_token.rb in an open-source product.

Exploit likelihood

2.74%Up 1.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

The Authlogic gem for Ruby on Rails, when used with certain versions before 3.2.10, makes potentially unsafe find_by_id method calls, which might allow remote attackers to conduct CVE-2012-6496 SQL injection attacks via a crafted parameter in environments that have a known secret_token value, as demonstrated by a value contained in secret_token.rb in an open-source product.

Record
CVE-2012-6497
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-89
Updated
2026-11-02
CVE List No score

The Authlogic gem for Ruby on Rails, when used with certain versions before 3.2.10, makes potentially unsafe find_by_id method calls, which might allow remote attackers to conduct CVE-2012-6496 SQL injection attacks via a crafted parameter in environments that have a known secret_token value, as demonstrated by a value contained in secret_token.rb in an open-source product.

Record
CVE-2012-6497
Updated
2026-11-02
EUVDEUVD-2022-5249 No score

The Authlogic gem for Ruby on Rails, when used with certain versions before 3.2.10, makes potentially unsafe find_by_id method calls, which might allow remote attackers to conduct CVE-2012-6496 SQL injection attacks via a crafted parameter in environments that have a known secret_token value, as demonstrated by a value contained in secret_token.rb in an open-source product.

Record
EUVD-2022-5249
Updated
2026-11-03
GitHub AdvisoriesGHSA-rx7j-mw4c-76g9 No score

Authlogic Information Exposure vulnerability

The Authlogic gem for Ruby on Rails prior to version 3.3.0 makes potentially unsafe find_by_id method calls, which might allow remote attackers to conduct CVE-2012-6496 SQL injection attacks via a crafted parameter in environments that have a known secret_token value, as demonstrated by a value contained in secret_token.rb in an open-source product.

Record
GHSA-rx7j-mw4c-76g9
Weakness
CWE-200
Updated
2026-11-02
OSV No score

The Authlogic gem for Ruby on Rails, when used with certain versions before 3.2.10, makes potentially unsafe find_by_id method calls, which might allow remote attackers to conduct CVE-2012-6496 SQL injection attacks via a crafted parameter in environments that have a known secret_token value, as demonstrated by a value contained in secret_token.rb in an open-source product.

Record
CVE-2012-6497
Updated
2026-11-02
OSVDEBIAN-CVE-2012-6497 No score

The Authlogic gem for Ruby on Rails, when used with certain versions before 3.2.10, makes potentially unsafe find_by_id method calls, which might allow remote attackers to conduct CVE-2012-6496 SQL injection attacks via a crafted parameter in environments that have a known secret_token value, as demonstrated by a value contained in secret_token.rb in an open-source product.

Record
DEBIAN-CVE-2012-6497
Updated
2026-11-02
OSVGHSA-rx7j-mw4c-76g9 No score

Authlogic Information Exposure vulnerability

The Authlogic gem for Ruby on Rails prior to version 3.3.0 makes potentially unsafe find_by_id method calls, which might allow remote attackers to conduct CVE-2012-6496 SQL injection attacks via a crafted parameter in environments that have a known secret_token value, as demonstrated by a value contained in secret_token.rb in an open-source product.

Record
GHSA-rx7j-mw4c-76g9
Weakness
CWE-200
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
authlogic
RubyGems
before 3.3.0
3.3.0
rails
Debian:12
before 2.3.14.1
2.3.14.1
rails
Debian:13
before 2.3.14.1
2.3.14.1
rails
Debian:14
before 2.3.14.1
2.3.14.1
rails
Debian:6.0
before 2.3.5-1.2+squeeze4, plus listed versions
2.3.5-1.22.3.5-1.2+squeeze0.12.3.5-1.2+squeeze12.3.5-1.2+squeeze22.3.5-1.2+squeeze3
2.3.5-1.2+squeeze4
authlogic
RubyGems
before 3.3.0, plus listed versions
0.10.41.0.01.1.01.1.11.1.2
Show 45 moreShow less
1.2.01.2.11.2.21.3.01.3.11.3.21.3.31.3.41.3.51.3.61.3.71.3.81.3.91.4.01.4.11.4.21.4.32.0.02.0.12.0.112.0.122.0.132.0.142.0.22.0.32.0.42.0.52.0.62.0.72.0.82.0.92.1.02.1.12.1.102.1.112.1.22.1.32.1.42.1.52.1.62.1.72.1.83.0.03.0.13.0.2
3.3.0

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 6 moreShow less
This page doesn't list everything

Left out here: 6 versions. The JSON record has them.

MoveEnter Open