Every CVE Search/ Get API key

CVE-2012-6618

The av_probe_input_buffer function in libavformat/utils.c in FFmpeg before 1.0.2, when running...

2.6 LowFix available

The av_probe_input_buffer function in libavformat/utils.c in FFmpeg before 1.0.2, when running with certain -probesize values, allows remote attackers to cause a denial of service (crash) via a crafted MP3 file, possibly related to frame size or lack of sufficient "frames to estimate rate."

Exploit likelihood

1.58%Up 0.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 2.6

The av_probe_input_buffer function in libavformat/utils.c in FFmpeg before 1.0.2, when running with certain -probesize values, allows remote attackers to cause a denial of service (crash) via a crafted MP3 file, possibly related to frame size or lack of sufficient "frames to estimate rate."

Record
CVE-2012-6618
CVSS 2.0
2.6 LowAV:N/AC:H/Au:N/C:N/I:N/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

The av_probe_input_buffer function in libavformat/utils.c in FFmpeg before 1.0.2, when running with certain -probesize values, allows remote attackers to cause a denial of service (crash) via a crafted MP3 file, possibly related to frame size or lack of sufficient "frames to estimate rate."

Record
CVE-2012-6618
Updated
2026-11-02
EUVDEUVD-2012-6464 No score

The av_probe_input_buffer function in libavformat/utils.c in FFmpeg before 1.0.2, when running with certain -probesize values, allows remote attackers to cause a denial of service (crash) via a crafted MP3 file, possibly related to frame size or lack of sufficient "frames to estimate rate."

Record
EUVD-2012-6464
Updated
2026-11-03
GitHub AdvisoriesGHSA-c3mp-24r8-cfj3 No score

The av_probe_input_buffer function in libavformat/utils.c in FFmpeg before 1.0.2, when running...

The av_probe_input_buffer function in libavformat/utils.c in FFmpeg before 1.0.2, when running with certain -probesize values, allows remote attackers to cause a denial of service (crash) via a crafted MP3 file, possibly related to frame size or lack of sufficient "frames to estimate rate."

Record
GHSA-c3mp-24r8-cfj3
Weakness
CWE-119
Updated
2026-11-02
OSV No score

The av_probe_input_buffer function in libavformat/utils.c in FFmpeg before 1.0.2, when running with certain -probesize values, allows remote attackers to cause a denial of service (crash) via a crafted MP3 file, possibly related to frame size or lack of sufficient "frames to estimate rate."

Record
CVE-2012-6618
Updated
2026-11-02
OSVDEBIAN-CVE-2012-6618 No score

The av_probe_input_buffer function in libavformat/utils.c in FFmpeg before 1.0.2, when running with certain -probesize values, allows remote attackers to cause a denial of service (crash) via a crafted MP3 file, possibly related to frame size or lack of sufficient "frames to estimate rate."

Record
DEBIAN-CVE-2012-6618
Updated
2026-11-02
OSVopenSUSE-SU-2024:10926-1 No score

libav-tools-12.3-1.17 on GA media

These are all security issues fixed in the libav-tools-12.3-1.17 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10926-1
Updated
2026-11-02
OSVUBUNTU-CVE-2012-6618 No score

The av_probe_input_buffer function in libavformat/utils.c in FFmpeg before 1.0.2, when running with certain -probesize values, allows remote attackers to cause a denial of service (crash) via a crafted MP3 file, possibly related to frame size or lack of sufficient "frames to estimate rate."

Record
UBUNTU-CVE-2012-6618
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ffmpeg
Debian:12
before 7:2.4.1-1
7:2.4.1-1
ffmpeg
Debian:13
before 7:2.4.1-1
7:2.4.1-1
ffmpeg
Debian:14
before 7:2.4.1-1
7:2.4.1-1
libav
Debian:7
before 6:0.8.12-1, plus listed versions
6:0.8.10-16:0.8.6-16:0.8.7-16:0.8.8-16:0.8.9-1
6:0.8.12-1
libav
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
6:0.8.7-1ubuntu26:9.10-1ubuntu16:9.10-1ubuntu26:9.10-1ubuntu56:9.10-1ubuntu6
Show 9 moreShow less
6:9.10-1ubuntu76:9.11-2ubuntu16:9.11-2ubuntu26:9.13-0ubuntu0.14.04.16:9.14-0ubuntu0.14.04.16:9.16-0ubuntu0.14.04.16:9.18-0ubuntu0.14.04.16:9.20-0ubuntu0.14.04.16:9.20-0ubuntu0.14.04.1+esm1
None known
qtwebengine-opensource-src
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
5.9.1+dfsg-45.9.1+dfsg-4ubuntu15.9.2+dfsg-2ubuntu15.9.3+dfsg-0ubuntu15.9.4+dfsg-0ubuntu15.9.5+dfsg-0ubuntu25.9.5+dfsg-0ubuntu2+esm1
None known
qtwebengine-opensource-src
Ubuntu:Pro:20.04:LTS
All versions, plus listed versions
5.12.4+dfsg-1ubuntu15.12.4+dfsg-1ubuntu35.12.5+dfsg-3ubuntu15.12.5+dfsg-6ubuntu25.12.5+dfsg-7
Show 4 moreShow less
5.12.5+dfsg-7build15.12.8+dfsg-0ubuntu15.12.8+dfsg-0ubuntu1.15.12.8+dfsg-0ubuntu1.1+esm1
None known
qtwebengine-opensource-src
Ubuntu:Pro:22.04:LTS
All versions, plus listed versions
5.15.6+dfsg-15.15.6+dfsg-25.15.7+dfsg-25.15.8+dfsg-15.15.8+dfsg-1build1
Show 4 moreShow less
5.15.8+dfsg-1build25.15.8+dfsg-25.15.9+dfsg-15.15.9+dfsg-1ubuntu0.1~esm1
None known
qtwebengine-opensource-src
Ubuntu:Pro:24.04:LTS
All versions, plus listed versions
5.15.15+dfsg-25.15.15+dfsg-2build25.15.15+dfsg-2ubuntu15.15.16+dfsg-15.15.16+dfsg-1ubuntu25.15.16+dfsg-1ubuntu45.15.16+dfsg-35.15.16+dfsg-3ubuntu0.1~esm1
None known
qtwebengine-opensource-src
Ubuntu:25.10
All versions, plus listed versions
5.15.18+dfsg-25.15.18+dfsg-2build15.15.19+dfsg-15.15.19+dfsg2-1
None known
qtwebengine-opensource-src
Ubuntu:26.10
All versions, plus listed versions
5.15.19+dfsg2-45.15.19+dfsg2-65.15.19+dfsg2-7
None known
qtwebengine-opensource-src
Ubuntu:Pro:26.04:LTS
All versions, plus listed versions
5.15.19+dfsg2-15.15.19+dfsg2-1build15.15.19+dfsg2-25.15.19+dfsg2-35.15.19+dfsg2-45.15.19+dfsg2-4ubuntu0.1~esm1
None known
libav-tools
openSUSE:Tumbleweed
From an advisory covering 12 CVEs
before 12.3-1.17
12.3-1.17

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2012-6618 is a low vulnerability (CVSS 2.6) in Ffmpeg, published December 24, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.58%, the 75th percentile. Fixed in ffmpeg 7:2.4.1-1.

References

Show 19 moreShow less
MoveEnter Open