Every CVE Search/ Get API key

CVE-2012-6635

wp-admin/includes/class-wp-posts-list-table.php in WordPress before 3.3.3 does not properly...

4.0 MediumFix available

wp-admin/includes/class-wp-posts-list-table.php in WordPress before 3.3.3 does not properly restrict excerpt-view access, which allows remote authenticated users to obtain sensitive information by visiting a draft.

Exploit likelihood

1.76%Up 0.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.0

wp-admin/includes/class-wp-posts-list-table.php in WordPress before 3.3.3 does not properly restrict excerpt-view access, which allows remote authenticated users to obtain sensitive information by visiting a draft.

Record
CVE-2012-6635
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:P/I:N/A:N
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

wp-admin/includes/class-wp-posts-list-table.php in WordPress before 3.3.3 does not properly restrict excerpt-view access, which allows remote authenticated users to obtain sensitive information by visiting a draft.

Record
CVE-2012-6635
Updated
2026-11-02
EUVDEUVD-2012-6481 No score

wp-admin/includes/class-wp-posts-list-table.php in WordPress before 3.3.3 does not properly restrict excerpt-view access, which allows remote authenticated users to obtain sensitive information by visiting a draft.

Record
EUVD-2012-6481
Updated
2026-11-03
GitHub AdvisoriesGHSA-3g9q-9jqp-362q No score

wp-admin/includes/class-wp-posts-list-table.php in WordPress before 3.3.3 does not properly...

wp-admin/includes/class-wp-posts-list-table.php in WordPress before 3.3.3 does not properly restrict excerpt-view access, which allows remote authenticated users to obtain sensitive information by visiting a draft.

Record
GHSA-3g9q-9jqp-362q
Updated
2026-11-02
OSV No score

wp-admin/includes/class-wp-posts-list-table.php in WordPress before 3.3.3 does not properly restrict excerpt-view access, which allows remote authenticated users to obtain sensitive information by visiting a draft.

Record
CVE-2012-6635
Updated
2026-11-02
OSVDEBIAN-CVE-2012-6635 No score

wp-admin/includes/class-wp-posts-list-table.php in WordPress before 3.3.3 does not properly restrict excerpt-view access, which allows remote authenticated users to obtain sensitive information by visiting a draft.

Record
DEBIAN-CVE-2012-6635
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wordpress
Debian:12
before 3.4+dfsg-1
3.4+dfsg-1
wordpress
Debian:13
before 3.4+dfsg-1
3.4+dfsg-1
wordpress
Debian:14
before 3.4+dfsg-1
3.4+dfsg-1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2012-6635 is a medium vulnerability (CVSS 4.0) in Wordpress, published January 21, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.76%, the 78th percentile. Fixed in wordpress 3.4+dfsg-1.

References

MoveEnter Open