CVE-2012-6655
An issue exists AccountService 0.6.37 in the user_change_password_authorized_cb() function in...
An issue exists AccountService 0.6.37 in the user_change_password_authorized_cb() function in user.c which could let a local users obtain encrypted passwords.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
3.3
An issue exists AccountService 0.6.37 in the user_change_password_authorized_cb() function in user.c which could let a local users obtain encrypted passwords.
- Record
CVE-2012-6655- CVSS 3.1
- 3.3 Low
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N - CVSS 2.0
- 2.1 Low
AV:L/AC:L/Au:N/C:P/I:N/A:N - Weakness
- CWE-732
- Updated
- 2026-11-02
CVE List No score
An issue exists AccountService 0.6.37 in the user_change_password_authorized_cb() function in user.c which could let a local users obtain encrypted passwords.
- Record
CVE-2012-6655- Updated
- 2026-11-02
EUVDEUVD-2012-6501 No score
An issue exists AccountService 0.6.37 in the user_change_password_authorized_cb() function in user.c which could let a local users obtain encrypted passwords.
- Record
EUVD-2012-6501- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-mwwg-gjh6-9grp No score
An issue exists AccountService 0.6.37 in the user_change_password_authorized_cb() function in...
An issue exists AccountService 0.6.37 in the user_change_password_authorized_cb() function in user.c which could let a local users obtain encrypted passwords.
- Record
GHSA-mwwg-gjh6-9grp- Updated
- 2026-11-02
OSVAZL-44049
3.3
CVE-2012-6655 affecting package accountsservice for versions less than 23.13.9-1
An issue exists AccountService 0.6.37 in the user_change_password_authorized_cb() function in user.c which could let a local users obtain encrypted passwords.
- Record
AZL-44049- CVSS 3.1
- 3.3 Low
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N - Updated
- 2026-11-02
OSV
3.3
An issue exists AccountService 0.6.37 in the user_change_password_authorized_cb() function in user.c which could let a local users obtain encrypted passwords.
- Record
CVE-2012-6655- CVSS 3.1
- 3.3 Low
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2012-6655
3.3
An issue exists AccountService 0.6.37 in the user_change_password_authorized_cb() function in user.c which could let a local users obtain encrypted passwords.
- Record
DEBIAN-CVE-2012-6655- CVSS 3.1
- 3.3 Low
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2012-6655
3.3
An issue exists AccountService 0.6.37 in the user_change_password_authorized_cb() function in user.c which could let a local users obtain encrypted passwords.
- Record
UBUNTU-CVE-2012-6655- CVSS 3.1
- 3.3 Low
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N - Updated
- 2026-11-02
OSVUSN-6687-1 No score
accountsservice vulnerability
It was discovered that AccountsService called a helper incorrectly when performing password change operations. A local attacker could possibly use this issue to obtain encrypted passwords.
- Record
USN-6687-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
accountsserviceAzure Linux:3 |
before 23.13.9-1 | 23.13.9-1 |
accountsserviceDebian:12 |
before 22.08.8-4 | 22.08.8-4 |
accountsserviceDebian:13 |
before 22.08.8-4 | 22.08.8-4 |
accountsserviceDebian:14 |
before 22.08.8-4 | 22.08.8-4 |
accountsserviceUbuntu:Pro:14.04:LTS |
All versions, plus listed versions 0.6.34-0ubuntu60.6.34-0ubuntu70.6.35-0ubuntu10.6.35-0ubuntu20.6.35-0ubuntu3 Show 10 moreShow less0.6.35-0ubuntu40.6.35-0ubuntu50.6.35-0ubuntu60.6.35-0ubuntu70.6.35-0ubuntu7.10.6.35-0ubuntu7.20.6.35-0ubuntu7.30.6.35-0ubuntu7.3+esm20.6.35-0ubuntu7.3+esm30.6.35-0ubuntu7.3+esm4 |
None known |
accountsserviceUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 0.6.40-2ubuntu50.6.40-2ubuntu60.6.40-2ubuntu70.6.40-2ubuntu80.6.40-2ubuntu9 Show 8 moreShow less0.6.40-2ubuntu100.6.40-2ubuntu110.6.40-2ubuntu11.10.6.40-2ubuntu11.20.6.40-2ubuntu11.30.6.40-2ubuntu11.60.6.40-2ubuntu11.6+esm10.6.40-2ubuntu11.6+esm2 |
None known |
accountsserviceUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 0.6.42-0ubuntu30.6.42-0ubuntu40.6.45-1ubuntu10.6.45-1ubuntu1.30.6.45-1ubuntu1.3+esm10.6.45-1ubuntu1.3+esm2 |
None known |
accountsserviceUbuntu:20.04:LTS |
before 0.6.55-0ubuntu12~20.04.7, plus listed versions 0.6.55-0ubuntu100.6.55-0ubuntu110.6.55-0ubuntu12~20.04.10.6.55-0ubuntu12~20.04.20.6.55-0ubuntu12~20.04.40.6.55-0ubuntu12~20.04.50.6.55-0ubuntu12~20.04.6 |
0.6.55-0ubuntu12~20.04.7 |
accountsserviceUbuntu:22.04:LTS |
before 22.07.5-2ubuntu1.5, plus listed versions 0.6.55-0ubuntu140.6.55-3ubuntu10.6.55-3ubuntu20.6.55-3ubuntu40.6.55-3ubuntu5 Show 4 moreShow less0.6.55-3ubuntu622.07.5-2ubuntu122.07.5-2ubuntu1.322.07.5-2ubuntu1.4 |
22.07.5-2ubuntu1.5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2012-6655 is a low vulnerability (CVSS 3.3) in Accountsservice Project Accountsservice, published November 27, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.45%, the 39th percentile. Fixed in accountsservice 23.13.9-1.