Every CVE Search/ Get API key

CVE-2012-6684

RedCloth Cross-site Scripting vulnerability

4.3 MediumFix available

Cross-site scripting (XSS) vulnerability in the RedCloth library 4.2.9 for Ruby and earlier allows remote attackers to inject arbitrary web script or HTML via a javascript: URI.

Exploit likelihood

2.25%Up 1.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in the RedCloth library 4.2.9 for Ruby and earlier allows remote attackers to inject arbitrary web script or HTML via a javascript: URI.

Record
CVE-2012-6684
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in the RedCloth library 4.2.9 for Ruby and earlier allows remote attackers to inject arbitrary web script or HTML via a javascript: URI.

Record
CVE-2012-6684
Updated
2026-11-02
EUVDEUVD-2017-0295 No score

Cross-site scripting (XSS) vulnerability in the RedCloth library 4.2.9 for Ruby and earlier allows remote attackers to inject arbitrary web script or HTML via a javascript: URI.

Record
EUVD-2017-0295
Updated
2026-11-03
GitHub AdvisoriesGHSA-r23g-3qw4-gfh2 No score

RedCloth Cross-site Scripting vulnerability

Cross-site scripting (XSS) vulnerability in the RedCloth library 4.2.9 for Ruby and earlier allows remote attackers to inject arbitrary web script or HTML via a javascript: URI.

Record
GHSA-r23g-3qw4-gfh2
Weakness
CWE-79
Updated
2026-11-02
OSV No score

Cross-site scripting (XSS) vulnerability in the RedCloth library 4.2.9 for Ruby and earlier allows remote attackers to inject arbitrary web script or HTML via a javascript: URI.

Record
CVE-2012-6684
Updated
2026-11-02
OSVDEBIAN-CVE-2012-6684 No score

Cross-site scripting (XSS) vulnerability in the RedCloth library 4.2.9 for Ruby and earlier allows remote attackers to inject arbitrary web script or HTML via a javascript: URI.

Record
DEBIAN-CVE-2012-6684
Updated
2026-11-02
OSVGHSA-r23g-3qw4-gfh2 No score

RedCloth Cross-site Scripting vulnerability

Cross-site scripting (XSS) vulnerability in the RedCloth library 4.2.9 for Ruby and earlier allows remote attackers to inject arbitrary web script or HTML via a javascript: URI.

Record
GHSA-r23g-3qw4-gfh2
Weakness
CWE-79
Updated
2026-11-02
OSVopenSUSE-SU-2024:10401-1 No score

ruby2.2-rubygem-RedCloth-4.3.2-1.5 on GA media

These are all security issues fixed in the ruby2.2-rubygem-RedCloth-4.3.2-1.5 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10401-1
Updated
2026-11-02
OSVUBUNTU-CVE-2012-6684 No score

Cross-site scripting (XSS) vulnerability in the RedCloth library 4.2.9 for Ruby and earlier allows remote attackers to inject arbitrary web script or HTML via a javascript: URI.

Record
UBUNTU-CVE-2012-6684
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
redcloth
RubyGems
before 4.3.0
4.3.0
ruby-redcloth
Debian:12
before 4.2.9-4
4.2.9-4
ruby-redcloth
Debian:13
before 4.2.9-4
4.2.9-4
ruby-redcloth
Debian:14
before 4.2.9-4
4.2.9-4
redcloth
Debian:6.0
before 4.2.2-1.1+deb6u1, plus listed versions
4.2.2-1.1
4.2.2-1.1+deb6u1
ruby-redcloth
Debian:7
before 4.2.9-2+deb7u2, plus listed versions
4.2.9-24.2.9-2+deb7u1
4.2.9-2+deb7u2
RedCloth
RubyGems
before 4.3.0, plus listed versions
3.0.03.0.13.0.23.0.33.0.4
Show 20 moreShow less
4.0.04.0.14.0.24.0.34.0.44.1.04.1.14.1.94.2.04.2.14.2.24.2.34.2.44.2.4.pre14.2.4.pre24.2.4.pre34.2.54.2.74.2.84.2.9
4.3.0

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2012-6684 is a medium vulnerability (CVSS 4.3) in Redcloth Library, published January 8, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.25%, the 82nd percentile. Fixed in redcloth 4.3.0.

References

Show 7 moreShow less
MoveEnter Open