Every CVE Search/ Get API key

CVE-2012-6697

InspIRCd before 2.0.7 allows remote attackers to cause a denial of service (infinite loop).

7.5 HighFix available

InspIRCd before 2.0.7 allows remote attackers to cause a denial of service (infinite loop).

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.89%Up 0.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

InspIRCd before 2.0.7 allows remote attackers to cause a denial of service (infinite loop).

Record
CVE-2012-6697
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-399
Updated
2026-11-02
CVE List No score

InspIRCd before 2.0.7 allows remote attackers to cause a denial of service (infinite loop).

Record
CVE-2012-6697
Updated
2026-11-02
EUVDEUVD-2012-6539 No score

InspIRCd before 2.0.7 allows remote attackers to cause a denial of service (infinite loop).

Record
EUVD-2012-6539
Updated
2026-11-03
GitHub AdvisoriesGHSA-8f8x-ff7m-w6wj 7.5

InspIRCd before 2.0.7 allows remote attackers to cause a denial of service (infinite loop).

InspIRCd before 2.0.7 allows remote attackers to cause a denial of service (infinite loop).

Record
GHSA-8f8x-ff7m-w6wj
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSV 7.5

InspIRCd before 2.0.7 allows remote attackers to cause a denial of service (infinite loop).

Record
CVE-2012-6697
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2012-6697 7.5

InspIRCd before 2.0.7 allows remote attackers to cause a denial of service (infinite loop).

Record
DEBIAN-CVE-2012-6697
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2012-6697 7.5

InspIRCd before 2.0.7 allows remote attackers to cause a denial of service (infinite loop).

Record
UBUNTU-CVE-2012-6697
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
inspircd
Debian:12
before 2.0.16-1
2.0.16-1
inspircd
Debian:13
before 2.0.16-1
2.0.16-1
inspircd
Debian:6.0
From an advisory covering 3 CVEs
before 1.1.22+dfsg-4+squeeze2, plus listed versions
1.1.22+dfsg-41.1.22+dfsg-4+squeeze1
1.1.22+dfsg-4+squeeze2
inspircd
Debian:7
From an advisory covering 3 CVEs
before 2.0.5-1+deb7u1, plus listed versions
2.0.5-1
2.0.5-1+deb7u1
inspircd
Ubuntu:14.04:LTS
before 2.0.5-1+deb7u1build0.14.04.1, plus listed versions
2.0.5-1
2.0.5-1+deb7u1build0.14.04.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2012-6697 is a high vulnerability (CVSS 7.5) in Inspire Ircd Inspircd, published April 15, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.89%, the 79th percentile. Fixed in inspircd 2.0.16-1.

References

Show 5 moreShow less
MoveEnter Open