Every CVE Search/ Get API key

CVE-2013-0184

Rack vulnerable to Denial of Service

4.3 MediumFix available

CVE-2013-0184 is a medium vulnerability (CVSS 4.3) in Rack Project Rack, published March 1, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.42%, the 84th percentile. Fixed in rack 1.1.5.

Unspecified vulnerability in Rack::Auth::AbstractRequest in Rack 1.1.x before 1.1.5, 1.2.x before 1.2.7, 1.3.x before 1.3.9, and 1.4.x before 1.4.4 allows remote attackers to cause a denial of service via unknown vectors related to "symbolized arbitrary strings."

Exploit likelihood

2.42%Up 1.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Unspecified vulnerability in Rack::Auth::AbstractRequest in Rack 1.1.x before 1.1.5, 1.2.x before 1.2.7, 1.3.x before 1.3.9, and 1.4.x before 1.4.4 allows remote attackers to cause a denial of service via unknown vectors related to "symbolized arbitrary strings."

Record
CVE-2013-0184
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Updated
2026-11-02
CVE List No score

Unspecified vulnerability in Rack::Auth::AbstractRequest in Rack 1.1.x before 1.1.5, 1.2.x before 1.2.7, 1.3.x before 1.3.9, and 1.4.x before 1.4.4 allows remote attackers to cause a denial of service via unknown vectors related to "symbolized arbitrary strings."

Record
CVE-2013-0184
Updated
2026-11-02
EUVDEUVD-2022-5315 No score

Unspecified vulnerability in Rack::Auth::AbstractRequest in Rack 1.1.x before 1.1.5, 1.2.x before 1.2.7, 1.3.x before 1.3.9, and 1.4.x before 1.4.4 allows remote attackers to cause a denial of service via unknown vectors related to "symbolized arbitrary strings."

Record
EUVD-2022-5315
Updated
2026-11-03
GitHub AdvisoriesGHSA-v882-ccj6-jc48 No score

Rack vulnerable to Denial of Service

Unspecified vulnerability in Rack::Auth::AbstractRequest in Rack 1.1.x before 1.1.5, 1.2.x before 1.2.7, 1.3.x before 1.3.9, and 1.4.x before 1.4.4 allows remote attackers to cause a denial of service via unknown vectors related to "symbolized arbitrary strings."

Record
GHSA-v882-ccj6-jc48
Updated
2026-11-02
OSV No score

Unspecified vulnerability in Rack::Auth::AbstractRequest in Rack 1.1.x before 1.1.5, 1.2.x before 1.2.7, 1.3.x before 1.3.9, and 1.4.x before 1.4.4 allows remote attackers to cause a denial of service via unknown vectors related to "symbolized arbitrary strings."

Record
CVE-2013-0184
Updated
2026-11-02
OSVDEBIAN-CVE-2013-0184 No score

Unspecified vulnerability in Rack::Auth::AbstractRequest in Rack 1.1.x before 1.1.5, 1.2.x before 1.2.7, 1.3.x before 1.3.9, and 1.4.x before 1.4.4 allows remote attackers to cause a denial of service via unknown vectors related to "symbolized arbitrary strings."

Record
DEBIAN-CVE-2013-0184
Updated
2026-11-02
OSVGHSA-v882-ccj6-jc48 No score

Rack vulnerable to Denial of Service

Unspecified vulnerability in Rack::Auth::AbstractRequest in Rack 1.1.x before 1.1.5, 1.2.x before 1.2.7, 1.3.x before 1.3.9, and 1.4.x before 1.4.4 allows remote attackers to cause a denial of service via unknown vectors related to "symbolized arbitrary strings."

Record
GHSA-v882-ccj6-jc48
Updated
2026-11-02
OSVUBUNTU-CVE-2013-0184 No score

Unspecified vulnerability in Rack::Auth::AbstractRequest in Rack 1.1.x before 1.1.5, 1.2.x before 1.2.7, 1.3.x before 1.3.9, and 1.4.x before 1.4.4 allows remote attackers to cause a denial of service via unknown vectors related to "symbolized arbitrary strings."

Record
UBUNTU-CVE-2013-0184
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
rack
RubyGems
1.1.0 up to 1.1.5
1.1.5
rack
RubyGems
1.2.0 up to 1.2.7
1.2.7
rack
RubyGems
1.3.0 up to 1.3.9
1.3.9
rack
RubyGems
1.4.0 up to 1.4.4
1.4.4
ruby-rack
Debian:12
before 1.4.1-2.1
1.4.1-2.1
ruby-rack
Debian:13
before 1.4.1-2.1
1.4.1-2.1
ruby-rack
Debian:14
before 1.4.1-2.1
1.4.1-2.1
librack-ruby
Debian:6.0
before 1.1.0-4+squeeze1, plus listed versions
1.1.0-4
1.1.0-4+squeeze1
rack
RubyGems
1.1.0 up to 1.1.5, plus listed versions
1.1.11.1.1.pre1.1.21.1.31.1.4
1.1.5
rack
RubyGems
1.2.0 up to 1.2.7, plus listed versions
1.2.11.2.21.2.31.2.41.2.51.2.6
1.2.7
rack
RubyGems
1.3.0 up to 1.3.9, plus listed versions
1.3.11.3.21.3.31.3.41.3.51.3.61.3.71.3.8
1.3.9
rack
RubyGems
1.4.0 up to 1.4.4, plus listed versions
1.4.11.4.21.4.3
1.4.4
ruby-rack
Ubuntu:14.04:LTS
before 1.5.2-1
1.5.2-1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 9 moreShow less
MoveEnter Open