Every CVE Search/ Get API key

CVE-2013-0222

The SUSE coreutils-i18n.patch for GNU coreutils allows context-dependent attackers to cause a...

2.1 Low

The SUSE coreutils-i18n.patch for GNU coreutils allows context-dependent attackers to cause a denial of service (segmentation fault and crash) via a long string to the uniq command, which triggers a stack-based buffer overflow in the alloca function.

Exploit likelihood

0.38%Down 0.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 2.1

The SUSE coreutils-i18n.patch for GNU coreutils allows context-dependent attackers to cause a denial of service (segmentation fault and crash) via a long string to the uniq command, which triggers a stack-based buffer overflow in the alloca function.

Record
CVE-2013-0222
CVSS 2.0
2.1 LowAV:L/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

The SUSE coreutils-i18n.patch for GNU coreutils allows context-dependent attackers to cause a denial of service (segmentation fault and crash) via a long string to the uniq command, which triggers a stack-based buffer overflow in the alloca function.

Record
CVE-2013-0222
Updated
2026-11-02
EUVDEUVD-2013-0256 No score

The SUSE coreutils-i18n.patch for GNU coreutils allows context-dependent attackers to cause a denial of service (segmentation fault and crash) via a long string to the uniq command, which triggers a stack-based buffer overflow in the alloca function.

Record
EUVD-2013-0256
Updated
2026-11-03
GitHub AdvisoriesGHSA-833h-pm7q-jw8w No score

The SUSE coreutils-i18n.patch for GNU coreutils allows context-dependent attackers to cause a...

The SUSE coreutils-i18n.patch for GNU coreutils allows context-dependent attackers to cause a denial of service (segmentation fault and crash) via a long string to the uniq command, which triggers a stack-based buffer overflow in the alloca function.

Record
GHSA-833h-pm7q-jw8w
Weakness
CWE-119
Updated
2026-11-02
OSVopenSUSE-SU-2024:10390-1 No score

coreutils-8.26-1.1 on GA media

These are all security issues fixed in the coreutils-8.26-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10390-1
Updated
2026-11-02
OSVSUSE-SU-2015:0792-1 No score

Recommended update for coreutils

This update for coreutils provides the following fixes and enhancements:

* cp(1) could read from freed memory and could even make corrupt
  copies. This could happen with a very fragmented and sparse input
  file, on file systems supporting filemap extent scanning.
  (bnc#892862)
* Improve ls(1) efficiency on large directories by caching some system
  call error codes (ENOTSUP for example) and not calling them again for
  files in the same device. (bnc#886129)
Record
SUSE-SU-2015:0792-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
coreutils
Red Hat:enterprise_linux:6::client
From an advisory covering 3 CVEs
before 0:8.4-31.el6
0:8.4-31.el6
coreutils-debuginfo
Red Hat:enterprise_linux:6::client
From an advisory covering 3 CVEs
before 0:8.4-31.el6
0:8.4-31.el6
coreutils-libs
Red Hat:enterprise_linux:6::client
From an advisory covering 3 CVEs
before 0:8.4-31.el6
0:8.4-31.el6
coreutils
Red Hat:enterprise_linux:6::computenode
From an advisory covering 3 CVEs
before 0:8.4-31.el6
0:8.4-31.el6
coreutils-debuginfo
Red Hat:enterprise_linux:6::computenode
From an advisory covering 3 CVEs
before 0:8.4-31.el6
0:8.4-31.el6
coreutils-libs
Red Hat:enterprise_linux:6::computenode
From an advisory covering 3 CVEs
before 0:8.4-31.el6
0:8.4-31.el6
coreutils
Red Hat:enterprise_linux:6::server
From an advisory covering 3 CVEs
before 0:8.4-31.el6
0:8.4-31.el6
coreutils-debuginfo
Red Hat:enterprise_linux:6::server
From an advisory covering 3 CVEs
before 0:8.4-31.el6
0:8.4-31.el6
coreutils-libs
Red Hat:enterprise_linux:6::server
From an advisory covering 3 CVEs
before 0:8.4-31.el6
0:8.4-31.el6
coreutils
Red Hat:enterprise_linux:6::workstation
From an advisory covering 3 CVEs
before 0:8.4-31.el6
0:8.4-31.el6
coreutils-debuginfo
Red Hat:enterprise_linux:6::workstation
From an advisory covering 3 CVEs
before 0:8.4-31.el6
0:8.4-31.el6
coreutils-libs
Red Hat:enterprise_linux:6::workstation
From an advisory covering 3 CVEs
before 0:8.4-31.el6
0:8.4-31.el6
coreutils
openSUSE:Tumbleweed
From an advisory covering 5 CVEs
before 8.26-1.1
8.26-1.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-0222 is a low vulnerability (CVSS 2.1) in Opensuse, published November 23, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.38%, the 32nd percentile. No source names a fixed version.

References

Show 36 moreShow less
MoveEnter Open