Every CVE Search/ Get API key

CVE-2013-0334

Bundler may install gems from a different source than expected

5.0 MediumFix available

Bundler before 1.7, when multiple top-level source lines are used, allows remote attackers to install arbitrary gems by creating a gem with the same name as another gem in a different source.

Exploit likelihood

4.30%Up 2.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

Bundler before 1.7, when multiple top-level source lines are used, allows remote attackers to install arbitrary gems by creating a gem with the same name as another gem in a different source.

Record
CVE-2013-0334
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

Bundler before 1.7, when multiple top-level source lines are used, allows remote attackers to install arbitrary gems by creating a gem with the same name as another gem in a different source.

Record
CVE-2013-0334
Updated
2026-11-02
EUVDEUVD-2022-2347 No score

Bundler before 1.7, when multiple top-level source lines are used, allows remote attackers to install arbitrary gems by creating a gem with the same name as another gem in a different source.

Record
EUVD-2022-2347
Updated
2026-11-03
GitHub AdvisoriesGHSA-49jx-9cmc-xjxm No score

Bundler may install gems from a different source than expected

Bundler before 1.7, when multiple top-level source lines are used, allows remote attackers to install arbitrary gems by creating a gem with the same name as another gem in a different source.

Record
GHSA-49jx-9cmc-xjxm
Weakness
CWE-20
Updated
2026-11-02
OSVGHSA-49jx-9cmc-xjxm No score

Bundler may install gems from a different source than expected

Bundler before 1.7, when multiple top-level source lines are used, allows remote attackers to install arbitrary gems by creating a gem with the same name as another gem in a different source.

Record
GHSA-49jx-9cmc-xjxm
Weakness
CWE-20
Updated
2026-11-02
OSVSUSE-SU-2015:0795-1 No score

Security update for rubygem-bundler

The Rubygem Bundler was updated to version 1.7.0.

Bundler 1.7 is a security-only release to address CVE-2013-0334, a vulnerability where a gem might be installed from an unintended source server, particularly while using both rubygems.org and gems.github.com.

Upstream changes entry with more explanations:

Any Gemfile with multiple top-level source lines cannot reliably control the gem server that a particular gem is fetched from. As a result, Bundler might install the wrong gem if more than one source provides a gem with the same name.

This is especially possible in the case of Github's legacy gem server, hosted at gems.github.com. An attacker might create a malicious gem on Rubygems.org with the same name as a commonly-used Github gem. From that point forward, running bundle install might result in the malicious gem being used instead of the expected gem.

To mitigate this, the Bundler and Rubygems.org teams worked together to copy almost every gem hosted on gems.github.com to rubygems.org, reducing the number of gems that can be used for such an attack.

Resolution:

To resolve this issue, upgrade to Bundler 1.7 by running gem install bundler. The next time you run bundle install for any Gemfile that contains multiple sources, each gem available from multiple sources will print a warning.

For every warning printed, edit the Gemfile to either specify a :source option for that gem, or move the gem line into a block that is passed to a source method call.

For detailed information about the changes to how sources are handled in Bundler version 1.7, see the release announcement.

Security Issues:

* CVE-2013-0334
  <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-0334>
Record
SUSE-SU-2015:0795-1
Updated
2026-11-02
OSVUBUNTU-CVE-2013-0334 No score

Bundler before 1.7, when multiple top-level source lines are used, allows remote attackers to install arbitrary gems by creating a gem with the same name as another gem in a different source.

Record
UBUNTU-CVE-2013-0334
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
bundler
RubyGems
before 1.7.0
1.7.0
bundler
RubyGems
before 1.7.0, plus listed versions
0.3.00.3.10.4.00.4.10.5.0
Show 45 moreShow less
0.6.00.7.00.7.10.7.20.7.3.pre0.7.3.pre20.8.00.8.10.9.00.9.0.pre10.9.0.pre20.9.0.pre30.9.0.pre40.9.0.pre50.9.10.9.1.pre10.9.100.9.110.9.120.9.130.9.140.9.150.9.160.9.170.9.180.9.190.9.20.9.200.9.210.9.220.9.230.9.240.9.250.9.260.9.30.9.40.9.50.9.60.9.70.9.80.9.91.0.01.0.0.beta.11.0.0.beta.101.0.0.beta.2
1.7.0
rubygem-bundler-doc
Red Hat:enterprise_linux:7::client
before 0:1.7.8-3.el7
0:1.7.8-3.el7
rubygem-thor-doc
Red Hat:enterprise_linux:7::client
before 0:0.19.1-1.el7
0:0.19.1-1.el7
rubygem-bundler
Red Hat:enterprise_linux:7::client
before 0:1.7.8-3.el7
0:1.7.8-3.el7
rubygem-thor
Red Hat:enterprise_linux:7::client
before 0:0.19.1-1.el7
0:0.19.1-1.el7
rubygem-bundler-doc
Red Hat:enterprise_linux:7::computenode
before 0:1.7.8-3.el7
0:1.7.8-3.el7
rubygem-thor-doc
Red Hat:enterprise_linux:7::computenode
before 0:0.19.1-1.el7
0:0.19.1-1.el7
rubygem-bundler
Red Hat:enterprise_linux:7::computenode
before 0:1.7.8-3.el7
0:1.7.8-3.el7
rubygem-thor
Red Hat:enterprise_linux:7::computenode
before 0:0.19.1-1.el7
0:0.19.1-1.el7
Show 8 moreShow less
Affected packages
PackageAffectedFixed
rubygem-bundler-doc
Red Hat:enterprise_linux:7::server
before 0:1.7.8-3.el7
0:1.7.8-3.el7
rubygem-thor-doc
Red Hat:enterprise_linux:7::server
before 0:0.19.1-1.el7
0:0.19.1-1.el7
rubygem-bundler
Red Hat:enterprise_linux:7::server
before 0:1.7.8-3.el7
0:1.7.8-3.el7
rubygem-thor
Red Hat:enterprise_linux:7::server
before 0:0.19.1-1.el7
0:0.19.1-1.el7
rubygem-bundler-doc
Red Hat:enterprise_linux:7::workstation
before 0:1.7.8-3.el7
0:1.7.8-3.el7
rubygem-thor-doc
Red Hat:enterprise_linux:7::workstation
before 0:0.19.1-1.el7
0:0.19.1-1.el7
rubygem-bundler
Red Hat:enterprise_linux:7::workstation
before 0:1.7.8-3.el7
0:1.7.8-3.el7
rubygem-thor
Red Hat:enterprise_linux:7::workstation
before 0:0.19.1-1.el7
0:0.19.1-1.el7

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-0334 is a medium vulnerability (CVSS 5.0) in Bundler, published October 31, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.30%, the 91st percentile. Fixed in bundler 1.7.0.

References

Show 20 moreShow less
This page doesn't list everything

Left out here: 100 versions. The JSON record has them.

MoveEnter Open