CVE-2013-1427
The configuration file for the FastCGI PHP support for lighttpd before 1.4.28 on Debian GNU/Linux...
The configuration file for the FastCGI PHP support for lighttpd before 1.4.28 on Debian GNU/Linux creates a socket file with a predictable name in /tmp, which allows local users to hijack the PHP control socket and perform unauthorized actions such as forcing the use of a different version of PHP via a symlink attack or a race condition.
Exploit likelihood
What each source reports
NVD Score used
1.9
The configuration file for the FastCGI PHP support for lighttpd before 1.4.28 on Debian GNU/Linux creates a socket file with a predictable name in /tmp, which allows local users to hijack the PHP control socket and perform unauthorized actions such as forcing the use of a different version of PHP via a symlink attack or a race condition.
- Record
CVE-2013-1427- CVSS 2.0
- 1.9 Low
AV:L/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-310
- Updated
- 2026-11-02
CVE List No score
The configuration file for the FastCGI PHP support for lighttpd before 1.4.28 on Debian GNU/Linux creates a socket file with a predictable name in /tmp, which allows local users to hijack the PHP control socket and perform unauthorized actions such as forcing the use of a different version of PHP via a symlink attack or a race condition.
- Record
CVE-2013-1427- Updated
- 2026-11-02
EUVDEUVD-2013-1465 No score
The configuration file for the FastCGI PHP support for lighttpd before 1.4.28 on Debian GNU/Linux creates a socket file with a predictable name in /tmp, which allows local users to hijack the PHP control socket and perform unauthorized actions such as forcing the use of a different version of PHP via a symlink attack or a race condition.
- Record
EUVD-2013-1465- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-4hqm-jw29-p8wm No score
The configuration file for the FastCGI PHP support for lighttpd before 1.4.28 on Debian GNU/Linux...
The configuration file for the FastCGI PHP support for lighttpd before 1.4.28 on Debian GNU/Linux creates a socket file with a predictable name in /tmp, which allows local users to hijack the PHP control socket and perform unauthorized actions such as forcing the use of a different version of PHP via a symlink attack or a race condition.
- Record
GHSA-4hqm-jw29-p8wm- Updated
- 2026-11-02
OSV No score
The configuration file for the FastCGI PHP support for lighttpd before 1.4.28 on Debian GNU/Linux creates a socket file with a predictable name in /tmp, which allows local users to hijack the PHP control socket and perform unauthorized actions such as forcing the use of a different version of PHP via a symlink attack or a race condition.
- Record
CVE-2013-1427- Updated
- 2026-11-02
OSVDEBIAN-CVE-2013-1427 No score
The configuration file for the FastCGI PHP support for lighttpd before 1.4.28 on Debian GNU/Linux creates a socket file with a predictable name in /tmp, which allows local users to hijack the PHP control socket and perform unauthorized actions such as forcing the use of a different version of PHP via a symlink attack or a race condition.
- Record
DEBIAN-CVE-2013-1427- Updated
- 2026-11-02
OSVUBUNTU-CVE-2013-1427 No score
The configuration file for the FastCGI PHP support for lighttpd before 1.4.28 on Debian GNU/Linux creates a socket file with a predictable name in /tmp, which allows local users to hijack the PHP control socket and perform unauthorized actions such as forcing the use of a different version of PHP via a symlink attack or a race condition.
- Record
UBUNTU-CVE-2013-1427- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
lighttpdDebian:12 |
before 1.4.31-4 | 1.4.31-4 |
lighttpdDebian:13 |
before 1.4.31-4 | 1.4.31-4 |
lighttpdDebian:14 |
before 1.4.31-4 | 1.4.31-4 |
lighttpdDebian:6.0 |
before 1.4.28-2+squeeze1.3, plus listed versions 1.4.28-21.4.28-2+squeeze11.4.28-2+squeeze1.11.4.28-2+squeeze1.2 |
1.4.28-2+squeeze1.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2013-1427 is a low vulnerability (CVSS 1.9) in Lighttpd, published March 15, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.35%, the 28th percentile. Fixed in lighttpd 1.4.31-4.
References
osvdb.org/91462
exchange.xforce.ibmcloud.com/vulnerabilities/82897
securityfocus.com/bid/58528
debian.org/security/2013/dsa-2649
nvd.nist.gov/vuln/detail/CVE-2013-1427
github.com/advisories/GHSA-4hqm-jw29-p8wm
security-tracker.debian.org/tracker/CVE-2013-1427
ubuntu.com/security/CVE-2013-1427
cve.org/CVERecord?id=CVE-2013-1427