Every CVE Search/ Get API key

CVE-2013-1801

HTTParty does not restrict casts of string values

7.5 HighFix available

The httparty gem 0.9.0 and earlier for Ruby does not properly restrict casts of string values, which might allow remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service (memory and CPU consumption) by leveraging Action Pack support for YAML type conversion, a similar vulnerability to CVE-2013-0156.

Exploit likelihood

4.41%Up 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

The httparty gem 0.9.0 and earlier for Ruby does not properly restrict casts of string values, which might allow remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service (memory and CPU consumption) by leveraging Action Pack support for YAML type conversion, a similar vulnerability to CVE-2013-0156.

Record
CVE-2013-1801
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

The httparty gem 0.9.0 and earlier for Ruby does not properly restrict casts of string values, which might allow remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service (memory and CPU consumption) by leveraging Action Pack support for YAML type conversion, a similar vulnerability to CVE-2013-0156.

Record
CVE-2013-1801
Updated
2026-11-02
EUVDEUVD-2017-0272 No score

The httparty gem 0.9.0 and earlier for Ruby does not properly restrict casts of string values, which might allow remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service (memory and CPU consumption) by leveraging Action Pack support for YAML type conversion, a similar vulnerability to CVE-2013-0156.

Record
EUVD-2017-0272
Updated
2026-11-03
GitHub AdvisoriesGHSA-mgx3-27hr-mfgp No score

HTTParty does not restrict casts of string values

The httparty gem 0.9.0 and earlier for Ruby does not properly restrict casts of string values, which might allow remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service (memory and CPU consumption) by leveraging Action Pack support for YAML type conversion, a similar vulnerability to CVE-2013-0156.

Record
GHSA-mgx3-27hr-mfgp
Weakness
CWE-74
Updated
2026-11-02
OSVGHSA-mgx3-27hr-mfgp No score

HTTParty does not restrict casts of string values

The httparty gem 0.9.0 and earlier for Ruby does not properly restrict casts of string values, which might allow remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service (memory and CPU consumption) by leveraging Action Pack support for YAML type conversion, a similar vulnerability to CVE-2013-0156.

Record
GHSA-mgx3-27hr-mfgp
Weakness
CWE-74
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
httparty
RubyGems
through 0.9.0
0.10.0
httparty
RubyGems
before 0.10.0, plus listed versions
0.1.00.1.10.1.20.1.30.1.5
Show 39 moreShow less
0.1.60.1.70.1.80.2.00.2.10.2.100.2.20.2.30.2.40.2.50.2.60.2.70.2.80.2.90.3.00.3.10.4.00.4.10.4.20.4.30.4.40.4.50.5.00.5.10.5.20.6.00.6.10.7.00.7.20.7.30.7.40.7.60.7.70.7.80.8.00.8.10.8.20.8.30.9.0
0.10.0

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-1801 is a high vulnerability (CVSS 7.5) in Jnunemaker Httparty, published April 9, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.41%, the 91st percentile. Fixed in httparty 0.10.0.

References

MoveEnter Open