Every CVE Search/ Get API key

CVE-2013-1912

Buffer overflow in HAProxy 1.4 through 1.4.22 and 1.5-dev through 1.5-dev17, when HTTP keep-alive...

5.1 MediumFix available

CVE-2013-1912 is a medium vulnerability (CVSS 5.1) in Haproxy, published April 10, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.57%, the 92nd percentile. Fixed in haproxy 1.4.23-1.

Buffer overflow in HAProxy 1.4 through 1.4.22 and 1.5-dev through 1.5-dev17, when HTTP keep-alive is enabled, using HTTP keywords in TCP inspection rules, and running with rewrite rules that appends to requests, allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via crafted pipelined HTTP requests that prevent request realignment from occurring.

Exploit likelihood

5.57%Down 2.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.1

Buffer overflow in HAProxy 1.4 through 1.4.22 and 1.5-dev through 1.5-dev17, when HTTP keep-alive is enabled, using HTTP keywords in TCP inspection rules, and running with rewrite rules that appends to requests, allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via crafted pipelined HTTP requests that prevent request realignment from occurring.

Record
CVE-2013-1912
CVSS 2.0
5.1 MediumAV:N/AC:H/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Buffer overflow in HAProxy 1.4 through 1.4.22 and 1.5-dev through 1.5-dev17, when HTTP keep-alive is enabled, using HTTP keywords in TCP inspection rules, and running with rewrite rules that appends to requests, allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via crafted pipelined HTTP requests that prevent request realignment from occurring.

Record
CVE-2013-1912
Updated
2026-11-02
EUVDEUVD-2013-1906 No score

Buffer overflow in HAProxy 1.4 through 1.4.22 and 1.5-dev through 1.5-dev17, when HTTP keep-alive is enabled, using HTTP keywords in TCP inspection rules, and running with rewrite rules that appends to requests, allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via crafted pipelined HTTP requests that prevent request realignment from occurring.

Record
EUVD-2013-1906
Updated
2026-11-03
GitHub AdvisoriesGHSA-xgv2-5whc-jjqv No score

Buffer overflow in HAProxy 1.4 through 1.4.22 and 1.5-dev through 1.5-dev17, when HTTP keep-alive...

Buffer overflow in HAProxy 1.4 through 1.4.22 and 1.5-dev through 1.5-dev17, when HTTP keep-alive is enabled, using HTTP keywords in TCP inspection rules, and running with rewrite rules that appends to requests, allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via crafted pipelined HTTP requests that prevent request realignment from occurring.

Record
GHSA-xgv2-5whc-jjqv
Weakness
CWE-119
Updated
2026-11-02
OSV No score

Buffer overflow in HAProxy 1.4 through 1.4.22 and 1.5-dev through 1.5-dev17, when HTTP keep-alive is enabled, using HTTP keywords in TCP inspection rules, and running with rewrite rules that appends to requests, allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via crafted pipelined HTTP requests that prevent request realignment from occurring.

Record
CVE-2013-1912
Updated
2026-11-02
OSVDEBIAN-CVE-2013-1912 No score

Buffer overflow in HAProxy 1.4 through 1.4.22 and 1.5-dev through 1.5-dev17, when HTTP keep-alive is enabled, using HTTP keywords in TCP inspection rules, and running with rewrite rules that appends to requests, allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via crafted pipelined HTTP requests that prevent request realignment from occurring.

Record
DEBIAN-CVE-2013-1912
Updated
2026-11-02
OSVopenSUSE-SU-2024:10114-1 No score

haproxy-1.7.0-1.1 on GA media

These are all security issues fixed in the haproxy-1.7.0-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10114-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
haproxy
Debian:12
before 1.4.23-1
1.4.23-1
haproxy
Debian:13
before 1.4.23-1
1.4.23-1
haproxy
Debian:14
before 1.4.23-1
1.4.23-1
haproxy
Debian:6.0
before 1.4.8-1+squeeze1, plus listed versions
1.4.8-1
1.4.8-1+squeeze1
haproxy
Red Hat:openshift:1::el6
before 0:1.4.22-5.el6op
0:1.4.22-5.el6op
haproxy-debuginfo
Red Hat:openshift:1::el6
before 0:1.4.22-5.el6op
0:1.4.22-5.el6op
haproxy
Red Hat:enterprise_linux:6::server
before 0:1.4.22-4.el6_4
0:1.4.22-4.el6_4
haproxy-debuginfo
Red Hat:enterprise_linux:6::server
before 0:1.4.22-4.el6_4
0:1.4.22-4.el6_4
haproxy
openSUSE:Tumbleweed
before 1.7.0-1.1
1.7.0-1.1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 21 moreShow less
MoveEnter Open