Every CVE Search/ Get API key

CVE-2013-1966

Arbitrary code execution in Apache Struts

9.3 HighPublic exploitFix available

Apache Struts 2 before 2.3.14.2 allows remote attackers to execute arbitrary OGNL code via a crafted request that is not properly handled when using the includeParams attribute in the (1) URL or (2) A tag.

Exploit likelihood

73.7%Up 69.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.3

Apache Struts 2 before 2.3.14.2 allows remote attackers to execute arbitrary OGNL code via a crafted request that is not properly handled when using the includeParams attribute in the (1) URL or (2) A tag.

Record
CVE-2013-1966
CVSS 2.0
9.3 HighAV:N/AC:M/Au:N/C:C/I:C/A:C
Weakness
CWE-94
Updated
2026-11-02
CVE List No score

Apache Struts 2 before 2.3.14.2 allows remote attackers to execute arbitrary OGNL code via a crafted request that is not properly handled when using the includeParams attribute in the (1) URL or (2) A tag.

Record
CVE-2013-1966
Updated
2026-11-02
EUVDEUVD-2022-2901 No score

Apache Struts 2 before 2.3.14.2 allows remote attackers to execute arbitrary OGNL code via a crafted request that is not properly handled when using the includeParams attribute in the (1) URL or (2) A tag.

Record
EUVD-2022-2901
Updated
2026-11-03
GitHub AdvisoriesGHSA-737w-mh58-cxjp No score

Arbitrary code execution in Apache Struts

Apache Struts 2 before 2.3.14.2 allows remote attackers to execute arbitrary OGNL code via a crafted request that is not properly handled when using the includeParams attribute in the (1) URL or (2) A tag.

Record
GHSA-737w-mh58-cxjp
Weakness
CWE-94
Updated
2026-11-02
OSVGHSA-737w-mh58-cxjp No score

Arbitrary code execution in Apache Struts

Apache Struts 2 before 2.3.14.2 allows remote attackers to execute arbitrary OGNL code via a crafted request that is not properly handled when using the includeParams attribute in the (1) URL or (2) A tag.

Record
GHSA-737w-mh58-cxjp
Weakness
CWE-94
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.struts:struts2-core
Maven
2.0.0 up to 2.3.14.2
2.3.14.2
org.apache.struts.xwork:xwork-core
Maven
2.0.0 up to 2.3.14.2
2.3.14.2
org.apache.struts:struts2-core
Maven
2.0.0 up to 2.3.14.2, plus listed versions
2.0.112.0.11.12.0.11.22.0.122.0.14
Show 23 moreShow less
2.0.52.0.62.0.82.0.92.1.22.1.62.1.82.1.8.12.2.12.2.1.12.2.32.2.3.12.3.12.3.1.12.3.1.22.3.122.3.142.3.14.12.3.32.3.42.3.4.12.3.72.3.8
2.3.14.2
org.apache.struts.xwork:xwork-core
Maven
2.0.0 up to 2.3.14.2, plus listed versions
2.2.12.2.1.12.2.32.2.3.12.3.1
Show 10 moreShow less
2.3.1.12.3.1.22.3.122.3.142.3.14.12.3.32.3.42.3.4.12.3.72.3.8
2.3.14.2

Public exploits

Links only. Every CVE stores no exploit code.

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, Metasploit, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-1966 is a high vulnerability (CVSS 9.3) in Apache Struts, published July 10, 2013. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 73.7%, the 99th percentile. Fixed in org.apache.struts:struts2-core 2.3.14.2.

References

MoveEnter Open