Every CVE Search/ Get API key

CVE-2013-1980

Buffer overflow in the get_dsmp function in loaders/masi_load.c in libxmp before 4.1.0 allows...

6.8 MediumFix available

Buffer overflow in the get_dsmp function in loaders/masi_load.c in libxmp before 4.1.0 allows remote attackers to execute arbitrary code via a crafted MASI file.

Exploit likelihood

3.70%Down 3.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

Buffer overflow in the get_dsmp function in loaders/masi_load.c in libxmp before 4.1.0 allows remote attackers to execute arbitrary code via a crafted MASI file.

Record
CVE-2013-1980
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Buffer overflow in the get_dsmp function in loaders/masi_load.c in libxmp before 4.1.0 allows remote attackers to execute arbitrary code via a crafted MASI file.

Record
CVE-2013-1980
Updated
2026-11-02
EUVDEUVD-2013-1968 No score

Buffer overflow in the get_dsmp function in loaders/masi_load.c in libxmp before 4.1.0 allows remote attackers to execute arbitrary code via a crafted MASI file.

Record
EUVD-2013-1968
Updated
2026-11-03
GitHub AdvisoriesGHSA-9qqf-p84p-rm35 No score

Buffer overflow in the get_dsmp function in loaders/masi_load.c in libxmp before 4.1.0 allows...

Buffer overflow in the get_dsmp function in loaders/masi_load.c in libxmp before 4.1.0 allows remote attackers to execute arbitrary code via a crafted MASI file.

Record
GHSA-9qqf-p84p-rm35
Weakness
CWE-119
Updated
2026-11-02
OSV No score

Buffer overflow in the get_dsmp function in loaders/masi_load.c in libxmp before 4.1.0 allows remote attackers to execute arbitrary code via a crafted MASI file.

Record
CVE-2013-1980
Updated
2026-11-02
OSVDEBIAN-CVE-2013-1980 No score

Buffer overflow in the get_dsmp function in loaders/masi_load.c in libxmp before 4.1.0 allows remote attackers to execute arbitrary code via a crafted MASI file.

Record
DEBIAN-CVE-2013-1980
Updated
2026-11-02
OSVopenSUSE-SU-2024:10173-1 No score

libxmp-devel-4.4.0-1.3 on GA media

These are all security issues fixed in the libxmp-devel-4.4.0-1.3 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10173-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
xmp
Debian:12
before 3.4.0-3
3.4.0-3
xmp
Debian:13
before 3.4.0-3
3.4.0-3
xmp
Debian:14
before 3.4.0-3
3.4.0-3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-1980 is a medium vulnerability (CVSS 6.8) in Extended Module Player Project Module Player, published February 11, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.70%, the 89th percentile. Fixed in xmp 3.4.0-3.

References

Show 5 moreShow less
MoveEnter Open