Every CVE Search/ Get API key

CVE-2013-2038

The NMEA0183 driver in gpsd before 3.9 allows remote attackers to cause a denial of service ...

4.3 MediumFix available

The NMEA0183 driver in gpsd before 3.9 allows remote attackers to cause a denial of service (daemon termination) and possibly execute arbitrary code via a GPS packet with a malformed $GPGGA interpreted sentence that lacks certain fields and a terminator. NOTE: a separate issue in the AIS driver was also reported, but it might not be a vulnerability.

Exploit likelihood

4.15%Down 0.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

The NMEA0183 driver in gpsd before 3.9 allows remote attackers to cause a denial of service (daemon termination) and possibly execute arbitrary code via a GPS packet with a malformed $GPGGA interpreted sentence that lacks certain fields and a terminator. NOTE: a separate issue in the AIS driver was also reported, but it might not be a vulnerability.

Record
CVE-2013-2038
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

The NMEA0183 driver in gpsd before 3.9 allows remote attackers to cause a denial of service (daemon termination) and possibly execute arbitrary code via a GPS packet with a malformed $GPGGA interpreted sentence that lacks certain fields and a terminator. NOTE: a separate issue in the AIS driver was also reported, but it might not be a vulnerability.

Record
CVE-2013-2038
Updated
2026-11-02
EUVDEUVD-2013-2020 No score

The NMEA0183 driver in gpsd before 3.9 allows remote attackers to cause a denial of service (daemon termination) and possibly execute arbitrary code via a GPS packet with a malformed $GPGGA interpreted sentence that lacks certain fields and a terminator. NOTE: a separate issue in the AIS driver was also reported, but it might not be a vulnerability.

Record
EUVD-2013-2020
Updated
2026-11-03
GitHub AdvisoriesGHSA-ph76-84x2-r5q2 No score

The NMEA0183 driver in gpsd before 3.9 allows remote attackers to cause a denial of service ...

The NMEA0183 driver in gpsd before 3.9 allows remote attackers to cause a denial of service (daemon termination) and possibly execute arbitrary code via a GPS packet with a malformed $GPGGA interpreted sentence that lacks certain fields and a terminator. NOTE: a separate issue in the AIS driver was also reported, but it might not be a vulnerability.

Record
GHSA-ph76-84x2-r5q2
Weakness
CWE-20
Updated
2026-11-02
OSV No score

The NMEA0183 driver in gpsd before 3.9 allows remote attackers to cause a denial of service (daemon termination) and possibly execute arbitrary code via a GPS packet with a malformed $GPGGA interpreted sentence that lacks certain fields and a terminator. NOTE: a separate issue in the AIS driver was also reported, but it might not be a vulnerability.

Record
CVE-2013-2038
Updated
2026-11-02
OSVDEBIAN-CVE-2013-2038 No score

The NMEA0183 driver in gpsd before 3.9 allows remote attackers to cause a denial of service (daemon termination) and possibly execute arbitrary code via a GPS packet with a malformed $GPGGA interpreted sentence that lacks certain fields and a terminator. NOTE: a separate issue in the AIS driver was also reported, but it might not be a vulnerability.

Record
DEBIAN-CVE-2013-2038
Updated
2026-11-02
OSVUBUNTU-CVE-2013-2038 No score

The NMEA0183 driver in gpsd before 3.9 allows remote attackers to cause a denial of service (daemon termination) and possibly execute arbitrary code via a GPS packet with a malformed $GPGGA interpreted sentence that lacks certain fields and a terminator. NOTE: a separate issue in the AIS driver was also reported, but it might not be a vulnerability.

Record
UBUNTU-CVE-2013-2038
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gpsd
Debian:12
before 3.6-5
3.6-5
gpsd
Debian:13
before 3.6-5
3.6-5
gpsd
Debian:14
before 3.6-5
3.6-5

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-2038 is a medium vulnerability (CVSS 4.3) in Gpsd Project Gpsd, published May 2, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.15%, the 90th percentile. Fixed in gpsd 3.6-5.

References

Show 7 moreShow less
MoveEnter Open