Every CVE Search/ Get API key

CVE-2013-2110

Heap-based buffer overflow in the php_quot_print_encode function in ext/standard/quot_print.c in...

5.0 Medium

Heap-based buffer overflow in the php_quot_print_encode function in ext/standard/quot_print.c in PHP before 5.3.26 and 5.4.x before 5.4.16 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted argument to the quoted_printable_encode function.

Exploit likelihood

6.75%Up 5.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

Heap-based buffer overflow in the php_quot_print_encode function in ext/standard/quot_print.c in PHP before 5.3.26 and 5.4.x before 5.4.16 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted argument to the quoted_printable_encode function.

Record
CVE-2013-2110
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Heap-based buffer overflow in the php_quot_print_encode function in ext/standard/quot_print.c in PHP before 5.3.26 and 5.4.x before 5.4.16 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted argument to the quoted_printable_encode function.

Record
CVE-2013-2110
Updated
2026-11-02
EUVDEUVD-2013-2080 No score

Heap-based buffer overflow in the php_quot_print_encode function in ext/standard/quot_print.c in PHP before 5.3.26 and 5.4.x before 5.4.16 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted argument to the quoted_printable_encode function.

Record
EUVD-2013-2080
Updated
2026-11-03
GitHub AdvisoriesGHSA-ppq4-pxjf-2xx4 No score

Heap-based buffer overflow in the php_quot_print_encode function in ext/standard/quot_print.c in...

Heap-based buffer overflow in the php_quot_print_encode function in ext/standard/quot_print.c in PHP before 5.3.26 and 5.4.x before 5.4.16 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted argument to the quoted_printable_encode function.

Record
GHSA-ppq4-pxjf-2xx4
Weakness
CWE-119
Updated
2026-11-02
OSVMGASA-2013-0172 No score

Updated php packages fix security vulnerabilies

Heap based buffer overflow in quoted_printable_encode() in PHP before version 5.4.16 (CVE-2013-2110).

Integer overflow in the SdnToJewish function in jewish.c in the Calendar component in PHP before 5.3.26 and 5.4.x before 5.4.16 allows context-dependent attackers to cause a denial of service (application hang) via a large argument to the jdtojewish function. (CVE-2013-4635)

This update provides PHP version 5.4.16 which fixes this as well as several other issues.

Record
MGASA-2013-0172
Updated
2026-11-02
OSVMGASA-2013-0176 No score

Updated php package fixes several issues

Fixed php bug #64879 (Heap based buffer overflow in quoted_printable_encode, CVE-2013-2110).

Integer overflow in the SdnToJewish function in jewish.c in the Calendar component in PHP before 5.3.26 and 5.4.x before 5.4.16 allows context-dependent attackers to cause a denial of service (application hang) via a large argument to the jdtojewish function. (CVE-2013-4635)

See the changelog for additional bug fixes.

Record
MGASA-2013-0176
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
php
Mageia:3
From an advisory covering 2 CVEs
before 5.4.16-1.mga3
5.4.16-1.mga3
php-apc
Mageia:3
From an advisory covering 2 CVEs
before 3.1.14-7.1.mga3
3.1.14-7.1.mga3
php-gd-bundled
Mageia:3
From an advisory covering 2 CVEs
before 5.4.16-1.mga3
5.4.16-1.mga3
php-timezonedb
Mageia:3
From an advisory covering 2 CVEs
before 2013.3-1.mga3
2013.3-1.mga3
php
Mageia:2
From an advisory covering 2 CVEs
before 5.3.26-1.mga2
5.3.26-1.mga2
php-apc
Mageia:2
From an advisory covering 2 CVEs
before 3.1.13-1.8.mga2
3.1.13-1.8.mga2
php-eaccelerator
Mageia:2
From an advisory covering 2 CVEs
before 0.9.6.1-10.10.mga2
0.9.6.1-10.10.mga2
php-gd-bundled
Mageia:2
From an advisory covering 2 CVEs
before 5.3.26-1.mga2
5.3.26-1.mga2
php-timezonedb
Mageia:2
From an advisory covering 2 CVEs
before 2013.3-1.mga2
2013.3-1.mga2
php-firebird
Mageia:2
From an advisory covering 2 CVEs
before 5.3.26-1.mga2
5.3.26-1.mga2
php-pdo_firebird
Mageia:2
From an advisory covering 2 CVEs
before 5.3.26-1.mga2
5.3.26-1.mga2

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-2110 is a medium vulnerability (CVSS 5.0) in Php, published June 18, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.75%, the 94th percentile. No source names a fixed version.

References

Show 7 moreShow less
MoveEnter Open