CVE-2013-2115
Code injection in Apache Struts
Apache Struts 2 before 2.3.14.2 allows remote attackers to execute arbitrary OGNL code via a crafted request that is not properly handled when using the includeParams attribute in the (1) URL or (2) A tag. NOTE: this issue is due to an incomplete fix for CVE-2013-1966.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.1
Apache Struts 2 before 2.3.14.2 allows remote attackers to execute arbitrary OGNL code via a crafted request that is not properly handled when using the includeParams attribute in the (1) URL or (2) A tag. NOTE: this issue is due to an incomplete fix for CVE-2013-1966.
- Record
CVE-2013-2115- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 9.3 High
AV:N/AC:M/Au:N/C:C/I:C/A:C - Weakness
- CWE-94
- Updated
- 2026-11-02
CVE List No score
Apache Struts 2 before 2.3.14.2 allows remote attackers to execute arbitrary OGNL code via a crafted request that is not properly handled when using the includeParams attribute in the (1) URL or (2) A tag. NOTE: this issue is due to an incomplete fix for CVE-2013-1966.
- Record
CVE-2013-2115- Updated
- 2026-11-02
EUVDEUVD-2022-3001 No score
Apache Struts 2 before 2.3.14.2 allows remote attackers to execute arbitrary OGNL code via a crafted request that is not properly handled when using the includeParams attribute in the (1) URL or (2) A tag. NOTE: this issue is due to an incomplete fix for CVE-2013-1966.
- Record
EUVD-2022-3001- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-7ghm-rpc7-p7g5
8.1
Code injection in Apache Struts
A vulnerability introduced by forcing parameter inclusion in the URL and Anchor Tag allows remote command execution, session access and manipulation and XSS attacks.
both the s:url and s:a tag provide an includeParams attribute.
The main scope of that attribute is to understand whether includes http request parameter or not.
The allowed values of includeParams are:
none - include no parameters in the URL (default)
get - include only GET parameters in the URL
all - include both GET and POST parameters in the URL
A request that included a specially crafted request parameter could be used to inject arbitrary OGNL code into the stack, afterward used as request parameter of an URL or A tag , which will cause a further evaluation.
The second evaluation happens when the URL/A tag tries to resolve every parameters present in the original request. This lets malicious users put arbitrary OGNL statements into any request parameter (not necessarily managed by the code) and have it evaluated as an OGNL expression to enable method execution and execute arbitrary methods, bypassing Struts and OGNL library protections.
The issue was originally addressed by Struts 2.3.14.1 and Security Announcement S2-013. However, the solution introduced with 2.3.14.1 did not address all possible attack vectors, such that every version of Struts 2 before 2.3.14.2 is still vulnerable to such attacks.
- Record
GHSA-7ghm-rpc7-p7g5- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-94
- Updated
- 2026-11-02
OSVGHSA-7ghm-rpc7-p7g5
8.1
Code injection in Apache Struts
A vulnerability introduced by forcing parameter inclusion in the URL and Anchor Tag allows remote command execution, session access and manipulation and XSS attacks.
both the s:url and s:a tag provide an includeParams attribute.
The main scope of that attribute is to understand whether includes http request parameter or not.
The allowed values of includeParams are:
none - include no parameters in the URL (default)
get - include only GET parameters in the URL
all - include both GET and POST parameters in the URL
A request that included a specially crafted request parameter could be used to inject arbitrary OGNL code into the stack, afterward used as request parameter of an URL or A tag , which will cause a further evaluation.
The second evaluation happens when the URL/A tag tries to resolve every parameters present in the original request. This lets malicious users put arbitrary OGNL statements into any request parameter (not necessarily managed by the code) and have it evaluated as an OGNL expression to enable method execution and execute arbitrary methods, bypassing Struts and OGNL library protections.
The issue was originally addressed by Struts 2.3.14.1 and Security Announcement S2-013. However, the solution introduced with 2.3.14.1 did not address all possible attack vectors, such that every version of Struts 2 before 2.3.14.2 is still vulnerable to such attacks.
- Record
GHSA-7ghm-rpc7-p7g5- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-94
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.struts:struts2-coreMaven |
2.0.0 up to 2.3.14.2 | 2.3.14.2 |
org.apache.struts.xwork:xwork-coreMaven |
2.0.0 up to 2.3.14.2 | 2.3.14.2 |
org.apache.struts:struts2-coreMaven |
2.0.0 up to 2.3.14.2, plus listed versions 2.0.112.0.11.12.0.11.22.0.122.0.14 Show 23 moreShow less2.0.52.0.62.0.82.0.92.1.22.1.62.1.82.1.8.12.2.12.2.1.12.2.32.2.3.12.3.12.3.1.12.3.1.22.3.122.3.142.3.14.12.3.32.3.42.3.4.12.3.72.3.8 |
2.3.14.2 |
org.apache.struts.xwork:xwork-coreMaven |
2.0.0 up to 2.3.14.2, plus listed versions 2.2.12.2.1.12.2.32.2.3.12.3.1 Show 10 moreShow less2.3.1.12.3.1.22.3.122.3.142.3.14.12.3.32.3.42.3.4.12.3.72.3.8 |
2.3.14.2 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | Apache Struts - includeParams Remote Code Execution (Metasploit) | 2013-06-05 |
| Metasploit | Apache Struts includeParams Remote Code Execution | 2013-05-24 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, Metasploit, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2013-2115 is a high vulnerability (CVSS 8.1) in Apache Struts, published July 10, 2013. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 74.6%, the 99th percentile. Fixed in org.apache.struts:struts2-core 2.3.14.2.
References
securityfocus.com/bid/60167
bugzilla.redhat.com/show_bug.cgi?id=967656
struts.apache.org/development/2.x/docs/s2-014.html
cwiki.apache.org/confluence/display/WW/S2-014
nvd.nist.gov/vuln/detail/CVE-2013-2115
cwiki.apache.org/confluence/display/WW/S2-013
Show 8 moreShow less
github.com/apache/struts/commit/d7804297e319c7a12245e1b536e565fcea6d650
github.com/apache/struts/commit/d934c6e7430b7b98e43a0a085a2304bd31a75c3d
github.com/apache/struts/commit/ea96d18d0f75c390d2595648efa3563785c272c6
github.com/apache/struts/commit/fed4f8e8a4ec69b5e7612b92d8ce3e476680474
issues.apache.org/jira/browse/WW-4063
web.archive.org/web/20140212000331/http://www.securityfocus.com/bid/60167
github.com/advisories/GHSA-7ghm-rpc7-p7g5
github.com/apache/struts