Every CVE Search/ Get API key

CVE-2013-2134

Arbitrary code execution in Apache Struts 2

9.3 HighPublic exploitFix available

Apache Struts 2 before 2.3.14.3 allows remote attackers to execute arbitrary OGNL code via a request with a crafted action name that is not properly handled during wildcard matching, a different vulnerability than CVE-2013-2135.

Exploit likelihood

70.2%Up 50.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.3

Apache Struts 2 before 2.3.14.3 allows remote attackers to execute arbitrary OGNL code via a request with a crafted action name that is not properly handled during wildcard matching, a different vulnerability than CVE-2013-2135.

Record
CVE-2013-2134
CVSS 2.0
9.3 HighAV:N/AC:M/Au:N/C:C/I:C/A:C
Weakness
CWE-94
Updated
2026-11-02
CVE List No score

Apache Struts 2 before 2.3.14.3 allows remote attackers to execute arbitrary OGNL code via a request with a crafted action name that is not properly handled during wildcard matching, a different vulnerability than CVE-2013-2135.

Record
CVE-2013-2134
Updated
2026-11-02
EUVDEUVD-2022-3996 No score

Apache Struts 2 before 2.3.14.3 allows remote attackers to execute arbitrary OGNL code via a request with a crafted action name that is not properly handled during wildcard matching, a different vulnerability than CVE-2013-2135.

Record
EUVD-2022-3996
Updated
2026-11-03
GitHub AdvisoriesGHSA-gqqm-564f-vvxq No score

Arbitrary code execution in Apache Struts 2

Apache Struts 2 before 2.3.14.3 allows remote attackers to execute arbitrary OGNL code via a request with a crafted action name that is not properly handled during wildcard matching, a different vulnerability than CVE-2013-2135.

Record
GHSA-gqqm-564f-vvxq
Weakness
CWE-94
Updated
2026-11-02
OSVGHSA-gqqm-564f-vvxq No score

Arbitrary code execution in Apache Struts 2

Apache Struts 2 before 2.3.14.3 allows remote attackers to execute arbitrary OGNL code via a request with a crafted action name that is not properly handled during wildcard matching, a different vulnerability than CVE-2013-2135.

Record
GHSA-gqqm-564f-vvxq
Weakness
CWE-94
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.struts:struts2-core
Maven
2.0.0 up to 2.3.14.3
2.3.14.3
org.apache.struts.xwork:xwork-core
Maven
2.0.0 up to 2.3.14.3
2.3.14.3
org.apache.struts:struts2-core
Maven
2.0.0 up to 2.3.14.3, plus listed versions
2.0.112.0.11.12.0.11.22.0.122.0.14
Show 24 moreShow less
2.0.52.0.62.0.82.0.92.1.22.1.62.1.82.1.8.12.2.12.2.1.12.2.32.2.3.12.3.12.3.1.12.3.1.22.3.122.3.142.3.14.12.3.14.22.3.32.3.42.3.4.12.3.72.3.8
2.3.14.3
org.apache.struts.xwork:xwork-core
Maven
2.0.0 up to 2.3.14.3, plus listed versions
2.2.12.2.1.12.2.32.2.3.12.3.1
Show 11 moreShow less
2.3.1.12.3.1.22.3.122.3.142.3.14.12.3.14.22.3.32.3.42.3.4.12.3.72.3.8
2.3.14.3

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBApache Struts - OGNL Expression Injection2013-06-05

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-2134 is a high vulnerability (CVSS 9.3) in Apache Struts, published July 16, 2013. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 70.2%, the 99th percentile. Fixed in org.apache.struts:struts2-core 2.3.14.3.

References

Show 16 moreShow less
MoveEnter Open