Every CVE Search/ Get API key

CVE-2013-2135

Arbitrary code execution in Apache Struts 2

9.3 HighFix available

Apache Struts 2 before 2.3.14.3 allows remote attackers to execute arbitrary OGNL code via a request with a crafted value that contains both "${}" and "%{}" sequences, which causes the OGNL code to be evaluated twice.

Exploit likelihood

13.8%Up 9.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.3

Apache Struts 2 before 2.3.14.3 allows remote attackers to execute arbitrary OGNL code via a request with a crafted value that contains both "${}" and "%{}" sequences, which causes the OGNL code to be evaluated twice.

Record
CVE-2013-2135
CVSS 2.0
9.3 HighAV:N/AC:M/Au:N/C:C/I:C/A:C
Weakness
CWE-94
Updated
2026-11-02
CVE List No score

Apache Struts 2 before 2.3.14.3 allows remote attackers to execute arbitrary OGNL code via a request with a crafted value that contains both "${}" and "%{}" sequences, which causes the OGNL code to be evaluated twice.

Record
CVE-2013-2135
Updated
2026-11-02
EUVDEUVD-2022-4835 No score

Apache Struts 2 before 2.3.14.3 allows remote attackers to execute arbitrary OGNL code via a request with a crafted value that contains both "${}" and "%{}" sequences, which causes the OGNL code to be evaluated twice.

Record
EUVD-2022-4835
Updated
2026-11-03
GitHub AdvisoriesGHSA-pw8r-x2qm-3h5m No score

Arbitrary code execution in Apache Struts 2

Apache Struts 2 before 2.3.14.3 allows remote attackers to execute arbitrary OGNL code via a request with a crafted value that contains both "${}" and "%{}" sequences, which causes the OGNL code to be evaluated twice.

Record
GHSA-pw8r-x2qm-3h5m
Weakness
CWE-94
Updated
2026-11-02
OSVGHSA-pw8r-x2qm-3h5m No score

Arbitrary code execution in Apache Struts 2

Apache Struts 2 before 2.3.14.3 allows remote attackers to execute arbitrary OGNL code via a request with a crafted value that contains both "${}" and "%{}" sequences, which causes the OGNL code to be evaluated twice.

Record
GHSA-pw8r-x2qm-3h5m
Weakness
CWE-94
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.struts:struts2-core
Maven
2.0.0 up to 2.3.14.3
2.3.14.3
org.apache.struts.xwork:xwork-core
Maven
2.0.0 up to 2.3.14.3
2.3.14.3
org.apache.struts:struts2-core
Maven
2.0.0 up to 2.3.14.3, plus listed versions
2.0.112.0.11.12.0.11.22.0.122.0.14
Show 24 moreShow less
2.0.52.0.62.0.82.0.92.1.22.1.62.1.82.1.8.12.2.12.2.1.12.2.32.2.3.12.3.12.3.1.12.3.1.22.3.122.3.142.3.14.12.3.14.22.3.32.3.42.3.4.12.3.72.3.8
2.3.14.3
org.apache.struts.xwork:xwork-core
Maven
2.0.0 up to 2.3.14.3, plus listed versions
2.2.12.2.1.12.2.32.2.3.12.3.1
Show 11 moreShow less
2.3.1.12.3.1.22.3.122.3.142.3.14.12.3.14.22.3.32.3.42.3.4.12.3.72.3.8
2.3.14.3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-2135 is a high vulnerability (CVSS 9.3) in Apache Struts, published July 16, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 13.8%, the 96th percentile. Fixed in org.apache.struts:struts2-core 2.3.14.3.

References

Show 13 moreShow less
MoveEnter Open