CVE-2013-2175
HAProxy 1.4 before 1.4.24 and 1.5 before 1.5-dev19, when configured to use hdr_ip or other "hdr_*...
HAProxy 1.4 before 1.4.24 and 1.5 before 1.5-dev19, when configured to use hdr_ip or other "hdr_*" functions with a negative occurrence count, allows remote attackers to cause a denial of service (negative array index usage and crash) via an HTTP header with a certain number of values, related to the MAX_HDR_HISTORY variable.
Exploit likelihood
What each source reports
NVD Score used
5.0
HAProxy 1.4 before 1.4.24 and 1.5 before 1.5-dev19, when configured to use hdr_ip or other "hdr_*" functions with a negative occurrence count, allows remote attackers to cause a denial of service (negative array index usage and crash) via an HTTP header with a certain number of values, related to the MAX_HDR_HISTORY variable.
- Record
CVE-2013-2175- CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-20, CWE-284
- Updated
- 2026-11-02
CVE List No score
HAProxy 1.4 before 1.4.24 and 1.5 before 1.5-dev19, when configured to use hdr_ip or other "hdr_*" functions with a negative occurrence count, allows remote attackers to cause a denial of service (negative array index usage and crash) via an HTTP header with a certain number of values, related to the MAX_HDR_HISTORY variable.
- Record
CVE-2013-2175- Updated
- 2026-11-02
EUVDEUVD-2013-2134 No score
HAProxy 1.4 before 1.4.24 and 1.5 before 1.5-dev19, when configured to use hdr_ip or other "hdr_*" functions with a negative occurrence count, allows remote attackers to cause a denial of service (negative array index usage and crash) via an HTTP header with a certain number of values, related to the MAX_HDR_HISTORY variable.
- Record
EUVD-2013-2134- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-4wh9-9j6m-2gcq No score
HAProxy 1.4 before 1.4.24 and 1.5 before 1.5-dev19, when configured to use hdr_ip or other "hdr_*...
HAProxy 1.4 before 1.4.24 and 1.5 before 1.5-dev19, when configured to use hdr_ip or other "hdr_*" functions with a negative occurrence count, allows remote attackers to cause a denial of service (negative array index usage and crash) via an HTTP header with a certain number of values, related to the MAX_HDR_HISTORY variable.
- Record
GHSA-4wh9-9j6m-2gcq- Weakness
- CWE-20
- Updated
- 2026-11-02
OSV No score
HAProxy 1.4 before 1.4.24 and 1.5 before 1.5-dev19, when configured to use hdr_ip or other "hdr_*" functions with a negative occurrence count, allows remote attackers to cause a denial of service (negative array index usage and crash) via an HTTP header with a certain number of values, related to the MAX_HDR_HISTORY variable.
- Record
CVE-2013-2175- Updated
- 2026-11-02
OSVDEBIAN-CVE-2013-2175 No score
HAProxy 1.4 before 1.4.24 and 1.5 before 1.5-dev19, when configured to use hdr_ip or other "hdr_*" functions with a negative occurrence count, allows remote attackers to cause a denial of service (negative array index usage and crash) via an HTTP header with a certain number of values, related to the MAX_HDR_HISTORY variable.
- Record
DEBIAN-CVE-2013-2175- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10114-1 No score
haproxy-1.7.0-1.1 on GA media
These are all security issues fixed in the haproxy-1.7.0-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10114-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
haproxyDebian:12 |
before 1.4.24-1 | 1.4.24-1 |
haproxyDebian:13 |
before 1.4.24-1 | 1.4.24-1 |
haproxyDebian:14 |
before 1.4.24-1 | 1.4.24-1 |
haproxyDebian:6.0 |
before 1.4.8-1+squeeze1, plus listed versions 1.4.8-1 |
1.4.8-1+squeeze1 |
haproxyRed Hat:enterprise_linux:6::server |
before 0:1.4.22-5.el6_4 | 0:1.4.22-5.el6_4 |
haproxy-debuginfoRed Hat:enterprise_linux:6::server |
before 0:1.4.22-5.el6_4 | 0:1.4.22-5.el6_4 |
haproxyRed Hat:openshift:1.2::el6 |
before 0:1.4.22-6.el6op | 0:1.4.22-6.el6op |
haproxy-debuginfoRed Hat:openshift:1.2::el6 |
before 0:1.4.22-6.el6op | 0:1.4.22-6.el6op |
haproxyopenSUSE:Tumbleweed |
before 1.7.0-1.1 | 1.7.0-1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2013-2175 is a medium vulnerability (CVSS 5.0) in Haproxy, published June 19, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.59%, the 89th percentile. Fixed in haproxy 1.4.24-1.
References
rhn.redhat.com/errata/RHSA-2013-1204.html
marc.info?l=haproxy&m=137147915029705&w=2
secunia.com/advisories/54344
bugzilla.redhat.com/show_bug.cgi?id=974259
debian.org/security/2013/dsa-2711
rhn.redhat.com/errata/RHSA-2013-1120.html
Show 17 moreShow less
ubuntu.com/usn/USN-1889-1
nvd.nist.gov/vuln/detail/CVE-2013-2175
github.com/advisories/GHSA-4wh9-9j6m-2gcq
security-tracker.debian.org/tracker/CVE-2013-2175
access.redhat.com/errata/RHSA-2013:1120
access.redhat.com/security/updates/classification
access.redhat.com/support/offerings/techpreview
security.access.redhat.com/data/csaf/v2/advisories/2013/rhsa-2013_1120.json
access.redhat.com/security/cve/CVE-2013-2175
cve.org/CVERecord?id=CVE-2013-2175
access.redhat.com/errata/RHSA-2013:1204
security.access.redhat.com/data/csaf/v2/advisories/2013/rhsa-2013_1204.json
suse.com/security/cve/CVE-2012-2391
suse.com/security/cve/CVE-2013-1912
suse.com/security/cve/CVE-2013-2175
suse.com/security/cve/CVE-2014-6269
suse.com/security/cve/CVE-2015-3281