Every CVE Search/ Get API key

CVE-2013-2178

The apache-auth.conf, apache-nohome.conf, apache-noscript.conf, and apache-overflows.conf files...

5.0 MediumFix available

The apache-auth.conf, apache-nohome.conf, apache-noscript.conf, and apache-overflows.conf files in Fail2ban before 0.8.10 do not properly validate log messages, which allows remote attackers to block arbitrary IP addresses via certain messages in a request.

Exploit likelihood

1.76%Up 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

The apache-auth.conf, apache-nohome.conf, apache-noscript.conf, and apache-overflows.conf files in Fail2ban before 0.8.10 do not properly validate log messages, which allows remote attackers to block arbitrary IP addresses via certain messages in a request.

Record
CVE-2013-2178
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

The apache-auth.conf, apache-nohome.conf, apache-noscript.conf, and apache-overflows.conf files in Fail2ban before 0.8.10 do not properly validate log messages, which allows remote attackers to block arbitrary IP addresses via certain messages in a request.

Record
CVE-2013-2178
Updated
2026-11-02
EUVDEUVD-2013-2137 No score

The apache-auth.conf, apache-nohome.conf, apache-noscript.conf, and apache-overflows.conf files in Fail2ban before 0.8.10 do not properly validate log messages, which allows remote attackers to block arbitrary IP addresses via certain messages in a request.

Record
EUVD-2013-2137
Updated
2026-11-03
GitHub AdvisoriesGHSA-4339-77hj-xqhj No score

The apache-auth.conf, apache-nohome.conf, apache-noscript.conf, and apache-overflows.conf files...

The apache-auth.conf, apache-nohome.conf, apache-noscript.conf, and apache-overflows.conf files in Fail2ban before 0.8.10 do not properly validate log messages, which allows remote attackers to block arbitrary IP addresses via certain messages in a request.

Record
GHSA-4339-77hj-xqhj
Weakness
CWE-20
Updated
2026-11-02
OSV No score

The apache-auth.conf, apache-nohome.conf, apache-noscript.conf, and apache-overflows.conf files in Fail2ban before 0.8.10 do not properly validate log messages, which allows remote attackers to block arbitrary IP addresses via certain messages in a request.

Record
CVE-2013-2178
Updated
2026-11-02
OSVDEBIAN-CVE-2013-2178 No score

The apache-auth.conf, apache-nohome.conf, apache-noscript.conf, and apache-overflows.conf files in Fail2ban before 0.8.10 do not properly validate log messages, which allows remote attackers to block arbitrary IP addresses via certain messages in a request.

Record
DEBIAN-CVE-2013-2178
Updated
2026-11-02
OSVMGASA-2013-0192 No score

Updated fail2ban packages fix CVE-2013-2178

Krzysztof Katowicz-Kowalewski discovered a vulnerability in Fail2ban, a log monitoring and system which can act on attack by preventing hosts to connect to specified services using the local firewall.

When using Fail2ban to monitor Apache logs, improper input validation in log parsing could enable a remote attacker to trigger an IP ban on arbitrary addresses, thus causing a denial of service (CVE-2013-2178).

Record
MGASA-2013-0192
Updated
2026-11-02
OSVopenSUSE-SU-2024:10347-1 No score

SuSEfirewall2-fail2ban-0.9.5-1.1 on GA media

These are all security issues fixed in the SuSEfirewall2-fail2ban-0.9.5-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10347-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
fail2ban
Debian:12
before 0.8.10-1
0.8.10-1
fail2ban
Debian:13
before 0.8.10-1
0.8.10-1
fail2ban
Debian:14
before 0.8.10-1
0.8.10-1
fail2ban
Debian:6.0
before 0.8.4-3+squeeze2, plus listed versions
0.8.4-30.8.4-3+squeeze1
0.8.4-3+squeeze2
fail2ban
Debian:7
before 0.8.6-3wheezy2, plus listed versions
0.8.6-3wheezy1
0.8.6-3wheezy2
fail2ban
Mageia:2
before 0.8.6-3.2.mga2
0.8.6-3.2.mga2
fail2ban
Mageia:3
before 0.8.8-6.1.mga3
0.8.8-6.1.mga3
fail2ban
openSUSE:Tumbleweed
before 0.9.5-1.1
0.9.5-1.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-2178 is a medium vulnerability (CVSS 5.0) in Fail2ban, published June 16, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.76%, the 78th percentile. Fixed in fail2ban 0.8.10-1.

References

Show 9 moreShow less
MoveEnter Open