CVE-2013-2221
Heap-based buffer overflow in the ZRtp::storeMsgTemp function in GNU ZRTPCPP before 3.2.0 allows...
Heap-based buffer overflow in the ZRtp::storeMsgTemp function in GNU ZRTPCPP before 3.2.0 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a large packet.
Exploit likelihood
What each source reports
NVD Score used
7.5
Heap-based buffer overflow in the ZRtp::storeMsgTemp function in GNU ZRTPCPP before 3.2.0 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a large packet.
- Record
CVE-2013-2221- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
Heap-based buffer overflow in the ZRtp::storeMsgTemp function in GNU ZRTPCPP before 3.2.0 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a large packet.
- Record
CVE-2013-2221- Updated
- 2026-11-02
EUVDEUVD-2013-2174 No score
Heap-based buffer overflow in the ZRtp::storeMsgTemp function in GNU ZRTPCPP before 3.2.0 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a large packet.
- Record
EUVD-2013-2174- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-3qf6-g2vg-3m4w No score
Heap-based buffer overflow in the ZRtp::storeMsgTemp function in GNU ZRTPCPP before 3.2.0 allows...
Heap-based buffer overflow in the ZRtp::storeMsgTemp function in GNU ZRTPCPP before 3.2.0 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a large packet.
- Record
GHSA-3qf6-g2vg-3m4w- Weakness
- CWE-119
- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10304-1 No score
libzrtpcpp-devel-4.6.4-1.1 on GA media
These are all security issues fixed in the libzrtpcpp-devel-4.6.4-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10304-1- Updated
- 2026-11-02
OSVUBUNTU-CVE-2013-2221 No score
Heap-based buffer overflow in the ZRtp::storeMsgTemp function in GNU ZRTPCPP before 3.2.0 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a large packet.
- Record
UBUNTU-CVE-2013-2221- Updated
- 2026-11-02
Affected products
History
| Recorded | Changed | Sources |
|---|---|---|
| facts | ||
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2013-2221 is a high vulnerability (CVSS 7.5) in Wernerd Zrtpcpp, published October 4, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.32%, the 91st percentile. No source names a fixed version.
References
lists.opensuse.org/opensuse-updates/2013-10/msg00053.html
github.com/wernerd/ZRTPCPP/commit/4654f330317c9948bb61d138eb24d49690ca4637
blog.azimuthsecurity.com/2013/06/attacking-crypto-phones-weaknesses-in.html
secunia.com/advisories/54998
lists.opensuse.org/opensuse-updates/2013-10/msg00052.html
security.gentoo.org/glsa/glsa-201309-13.xml
Show 9 moreShow less
seclists.org/oss-sec/2013/q2/638
secunia.com/advisories/53818
nvd.nist.gov/vuln/detail/CVE-2013-2221
github.com/advisories/GHSA-3qf6-g2vg-3m4w
ubuntu.com/security/CVE-2013-2221
cve.org/CVERecord?id=CVE-2013-2221
suse.com/security/cve/CVE-2013-2221
suse.com/security/cve/CVE-2013-2222
suse.com/security/cve/CVE-2013-2223