CVE-2013-2616
MiniMagick Gem for Ruby URI Handling Arbitrary Command Injection
lib/mini_magick.rb in the MiniMagick Gem 1.3.1 for Ruby allows remote attackers to execute arbitrary commands via shell metacharacters in a URL.
Exploit likelihood
What each source reports
NVD Score used
7.5
lib/mini_magick.rb in the MiniMagick Gem 1.3.1 for Ruby allows remote attackers to execute arbitrary commands via shell metacharacters in a URL.
- Record
CVE-2013-2616- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-94
- Updated
- 2026-11-02
CVE List No score
lib/mini_magick.rb in the MiniMagick Gem 1.3.1 for Ruby allows remote attackers to execute arbitrary commands via shell metacharacters in a URL.
- Record
CVE-2013-2616- Updated
- 2026-11-02
EUVDEUVD-2017-0322 No score
lib/mini_magick.rb in the MiniMagick Gem 1.3.1 for Ruby allows remote attackers to execute arbitrary commands via shell metacharacters in a URL.
- Record
EUVD-2017-0322- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-w754-gq8r-pf5f No score
MiniMagick Gem for Ruby URI Handling Arbitrary Command Injection
lib/mini_magick.rb in the MiniMagick Gem 1.3.1 for Ruby allows remote attackers to execute arbitrary commands via shell metacharacters in a URL.
- Record
GHSA-w754-gq8r-pf5f- Weakness
- CWE-94
- Updated
- 2026-11-02
OSVGHSA-w754-gq8r-pf5f No score
MiniMagick Gem for Ruby URI Handling Arbitrary Command Injection
lib/mini_magick.rb in the MiniMagick Gem 1.3.1 for Ruby allows remote attackers to execute arbitrary commands via shell metacharacters in a URL.
- Record
GHSA-w754-gq8r-pf5f- Weakness
- CWE-94
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mini_magickRubyGems |
before 3.6.0 | 3.6.0 |
mini_magickRubyGems |
before 3.6.0, plus listed versions 1.0.11.1.01.2.01.2.11.2.2 Show 18 moreShow less1.2.31.2.51.3.01.3.11.3.21.3.32.0.02.0.12.0.22.12.33.03.13.23.2.13.33.43.5.0 |
3.6.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2013-2616 is a high vulnerability (CVSS 7.5) in Rubygems Mini Magick, published March 20, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.63%, the 89th percentile. Fixed in mini_magick 3.6.0.