Every CVE Search/ Get API key

CVE-2013-2777

sudo before 1.7.10p5 and 1.8.x before 1.8.6p6, when the tty_tickets option is enabled, does not...

4.4 MediumFix available

sudo before 1.7.10p5 and 1.8.x before 1.8.6p6, when the tty_tickets option is enabled, does not properly validate the controlling terminal device, which allows local users with sudo permissions to hijack the authorization of another terminal via vectors related to a session without a controlling terminal device and connecting to the standard input, output, and error file descriptors of another terminal. NOTE: this is one of three closely-related vulnerabilities that were originally assigned CVE-2013-1776, but they have been SPLIT because of different affected versions.

Exploit likelihood

0.36%Down 1.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.4

sudo before 1.7.10p5 and 1.8.x before 1.8.6p6, when the tty_tickets option is enabled, does not properly validate the controlling terminal device, which allows local users with sudo permissions to hijack the authorization of another terminal via vectors related to a session without a controlling terminal device and connecting to the standard input, output, and error file descriptors of another terminal. NOTE: this is one of three closely-related vulnerabilities that were originally assigned CVE-2013-1776, but they have been SPLIT because of different affected versions.

Record
CVE-2013-2777
CVSS 2.0
4.4 MediumAV:L/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

sudo before 1.7.10p5 and 1.8.x before 1.8.6p6, when the tty_tickets option is enabled, does not properly validate the controlling terminal device, which allows local users with sudo permissions to hijack the authorization of another terminal via vectors related to a session without a controlling terminal device and connecting to the standard input, output, and error file descriptors of another terminal. NOTE: this is one of three closely-related vulnerabilities that were originally assigned CVE-2013-1776, but they have been SPLIT because of different affected versions.

Record
CVE-2013-2777
Updated
2026-11-02
EUVDEUVD-2013-2716 No score

sudo before 1.7.10p5 and 1.8.x before 1.8.6p6, when the tty_tickets option is enabled, does not properly validate the controlling terminal device, which allows local users with sudo permissions to hijack the authorization of another terminal via vectors related to a session without a controlling terminal device and connecting to the standard input, output, and error file descriptors of another terminal. NOTE: this is one of three closely-related vulnerabilities that were originally assigned CVE-2013-1776, but they have been SPLIT because of different affected versions.

Record
EUVD-2013-2716
Updated
2026-11-03
GitHub AdvisoriesGHSA-qjfx-m5pf-3ccg No score

sudo before 1.7.10p5 and 1.8.x before 1.8.6p6, when the tty_tickets option is enabled, does not...

sudo before 1.7.10p5 and 1.8.x before 1.8.6p6, when the tty_tickets option is enabled, does not properly validate the controlling terminal device, which allows local users with sudo permissions to hijack the authorization of another terminal via vectors related to a session without a controlling terminal device and connecting to the standard input, output, and error file descriptors of another terminal. NOTE: this is one of three closely-related vulnerabilities that were originally assigned CVE-2013-1776, but they have been SPLIT because of different affected versions.

Record
GHSA-qjfx-m5pf-3ccg
Updated
2026-11-02
OSV No score

sudo before 1.7.10p5 and 1.8.x before 1.8.6p6, when the tty_tickets option is enabled, does not properly validate the controlling terminal device, which allows local users with sudo permissions to hijack the authorization of another terminal via vectors related to a session without a controlling terminal device and connecting to the standard input, output, and error file descriptors of another terminal. NOTE: this is one of three closely-related vulnerabilities that were originally assigned CVE-2013-1776, but they have been SPLIT because of different affected versions.

Record
CVE-2013-2777
Updated
2026-11-02
OSVDEBIAN-CVE-2013-2777 No score

sudo before 1.7.10p5 and 1.8.x before 1.8.6p6, when the tty_tickets option is enabled, does not properly validate the controlling terminal device, which allows local users with sudo permissions to hijack the authorization of another terminal via vectors related to a session without a controlling terminal device and connecting to the standard input, output, and error file descriptors of another terminal. NOTE: this is one of three closely-related vulnerabilities that were originally assigned CVE-2013-1776, but they have been SPLIT because of different affected versions.

Record
DEBIAN-CVE-2013-2777
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
sudo
Debian:12
before 1.8.5p2-1+nmu1
1.8.5p2-1+nmu1
sudo
Debian:13
before 1.8.5p2-1+nmu1
1.8.5p2-1+nmu1
sudo
Debian:14
before 1.8.5p2-1+nmu1
1.8.5p2-1+nmu1
sudo
Debian:6.0
From an advisory covering 4 CVEs
before 1.7.4p4-2.squeeze.4, plus listed versions
1.7.4p4-2.squeeze.11.7.4p4-2.squeeze.21.7.4p4-2.squeeze.3
1.7.4p4-2.squeeze.4
sudo
Red Hat:enterprise_linux:6::client
From an advisory covering 3 CVEs
before 0:1.8.6p3-12.el6
0:1.8.6p3-12.el6
sudo-debuginfo
Red Hat:enterprise_linux:6::client
From an advisory covering 3 CVEs
before 0:1.8.6p3-12.el6
0:1.8.6p3-12.el6
sudo-devel
Red Hat:enterprise_linux:6::client
From an advisory covering 3 CVEs
before 0:1.8.6p3-12.el6
0:1.8.6p3-12.el6
sudo
Red Hat:enterprise_linux:6::computenode
From an advisory covering 3 CVEs
before 0:1.8.6p3-12.el6
0:1.8.6p3-12.el6
sudo-debuginfo
Red Hat:enterprise_linux:6::computenode
From an advisory covering 3 CVEs
before 0:1.8.6p3-12.el6
0:1.8.6p3-12.el6
sudo-devel
Red Hat:enterprise_linux:6::computenode
From an advisory covering 3 CVEs
before 0:1.8.6p3-12.el6
0:1.8.6p3-12.el6
Show 6 moreShow less
Affected packages
PackageAffectedFixed
sudo
Red Hat:enterprise_linux:6::server
From an advisory covering 3 CVEs
before 0:1.8.6p3-12.el6
0:1.8.6p3-12.el6
sudo-debuginfo
Red Hat:enterprise_linux:6::server
From an advisory covering 3 CVEs
before 0:1.8.6p3-12.el6
0:1.8.6p3-12.el6
sudo-devel
Red Hat:enterprise_linux:6::server
From an advisory covering 3 CVEs
before 0:1.8.6p3-12.el6
0:1.8.6p3-12.el6
sudo
Red Hat:enterprise_linux:6::workstation
From an advisory covering 3 CVEs
before 0:1.8.6p3-12.el6
0:1.8.6p3-12.el6
sudo-debuginfo
Red Hat:enterprise_linux:6::workstation
From an advisory covering 3 CVEs
before 0:1.8.6p3-12.el6
0:1.8.6p3-12.el6
sudo-devel
Red Hat:enterprise_linux:6::workstation
From an advisory covering 3 CVEs
before 0:1.8.6p3-12.el6
0:1.8.6p3-12.el6

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-2777 is a medium vulnerability (CVSS 4.4) in Todd Miller Sudo, published March 9, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.36%, the 30th percentile. Fixed in sudo 1.8.5p2-1+nmu1.

References

Show 30 moreShow less
MoveEnter Open