Every CVE Search/ Get API key

CVE-2013-4234

Multiple heap-based buffer overflows in the (1) abc_MIDI_drum and (2) abc_MIDI_gchord functions...

6.8 MediumFix available

Multiple heap-based buffer overflows in the (1) abc_MIDI_drum and (2) abc_MIDI_gchord functions in load_abc.cpp in libmodplug 0.8.8.4 and earlier allow remote attackers to cause a denial of service (memory corruption and crash) and possibly execute arbitrary code via a crafted ABC.

Exploit likelihood

4.35%Down 0.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

Multiple heap-based buffer overflows in the (1) abc_MIDI_drum and (2) abc_MIDI_gchord functions in load_abc.cpp in libmodplug 0.8.8.4 and earlier allow remote attackers to cause a denial of service (memory corruption and crash) and possibly execute arbitrary code via a crafted ABC.

Record
CVE-2013-4234
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Multiple heap-based buffer overflows in the (1) abc_MIDI_drum and (2) abc_MIDI_gchord functions in load_abc.cpp in libmodplug 0.8.8.4 and earlier allow remote attackers to cause a denial of service (memory corruption and crash) and possibly execute arbitrary code via a crafted ABC.

Record
CVE-2013-4234
Updated
2026-11-02
EUVDEUVD-2013-4138 No score

Multiple heap-based buffer overflows in the (1) abc_MIDI_drum and (2) abc_MIDI_gchord functions in load_abc.cpp in libmodplug 0.8.8.4 and earlier allow remote attackers to cause a denial of service (memory corruption and crash) and possibly execute arbitrary code via a crafted ABC.

Record
EUVD-2013-4138
Updated
2026-11-03
GitHub AdvisoriesGHSA-2qqr-78hq-cvh8 No score

Multiple heap-based buffer overflows in the (1) abc_MIDI_drum and (2) abc_MIDI_gchord functions...

Multiple heap-based buffer overflows in the (1) abc_MIDI_drum and (2) abc_MIDI_gchord functions in load_abc.cpp in libmodplug 0.8.8.4 and earlier allow remote attackers to cause a denial of service (memory corruption and crash) and possibly execute arbitrary code via a crafted ABC.

Record
GHSA-2qqr-78hq-cvh8
Weakness
CWE-119
Updated
2026-11-02
OSV No score

Multiple heap-based buffer overflows in the (1) abc_MIDI_drum and (2) abc_MIDI_gchord functions in load_abc.cpp in libmodplug 0.8.8.4 and earlier allow remote attackers to cause a denial of service (memory corruption and crash) and possibly execute arbitrary code via a crafted ABC.

Record
CVE-2013-4234
Updated
2026-11-02
OSVDEBIAN-CVE-2013-4234 No score

Multiple heap-based buffer overflows in the (1) abc_MIDI_drum and (2) abc_MIDI_gchord functions in load_abc.cpp in libmodplug 0.8.8.4 and earlier allow remote attackers to cause a denial of service (memory corruption and crash) and possibly execute arbitrary code via a crafted ABC.

Record
DEBIAN-CVE-2013-4234
Updated
2026-11-02
Show 4 moreShow less
OSVMGASA-2013-0271 No score

Updated libmodplug packages fixes security vulnerabilities

An integer overflow within the "abc_set_parts()" function (src/load_abc.cpp) can be exploited to corrupt heap memory via a specially crafted ABC file (CVE-2013-4233).

An error within the "abc_MIDI_drum()" and "abc_MIDI_gchord()" functions (src/load_abc.cpp) can be exploited to cause a buffer overflow via a specially crafted ABC file (CVE-2013-4234).

Record
MGASA-2013-0271
Updated
2026-11-02
OSVopenSUSE-SU-2024:10514-1 No score

libmodplug-devel-0.8.8.5-4.9 on GA media

These are all security issues fixed in the libmodplug-devel-0.8.8.5-4.9 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10514-1
Updated
2026-11-02
OSVSUSE-SU-2018:1441-1 No score

Security update for libmodplug

This update for libmodplug fixes the following issues:

  • Update to version 0.8.9.0+git20170610.f6dd59a bsc#1022032:

    • PSM: add missing line to commit
    • ABC: prevent possible increment of p past end
    • ABC: ensure read pointer is valid before incrementing
    • ABC: terminate early when things don't work in substitute
    • OKT: add one more bound check
    • FAR: out by one on check
    • ABC: 10 digit ints require null termination
    • PSM: make sure reads occur of only valid ins
    • ABC: cleanup tracks correctly.
    • WAV: check that there is space for both headers
    • OKT: ensure file size is enough to contain data
    • ABC: initialize earlier
    • ABC: ensure array access is bounded correctly.
    • ABC: clean up loop exiting code
    • ABC: avoid possibility of incrementing *p
    • ABC: abort early if macro would be blank
    • ABC: Use blankline more often
    • ABC: Ensure for loop does not increment past end of loop
    • Initialize nPatterns to 0 earlier
    • Check memory position isn't over the memory length
    • ABC: transpose only needs to look at notes (<26)
  • Update to version 0.8.9.0+git20171024.e9fc46e:

    • Spelling fixes
    • Bump version number to 0.8.9.0
    • MMCMP: Check that end pointer is within the file size
    • WAV: ensure integer doesn't overflow
    • XM: additional mempos check
    • sndmix: Don't process row if its empty.
    • snd_fx: dont include patterns of zero size in length calc
    • MT2,AMF: prevent OOB reads
  • Add patch for broken pc file where quite some upstream refer to modplug directly without specifying the subdir it is in.

  • Update to version 0.8.8.5

    • Some security issues: CVE-2013-4233, CVE-2013-4234, as well as many fixes suggested by static analyzers: clang build-scan, and coverity.
  • Stop using dos2unix

  • Run through spec-cleaner

  • Use full URL in Source tag

Record
SUSE-SU-2018:1441-1
Updated
2026-11-02
OSVUBUNTU-CVE-2013-4234 No score

Multiple heap-based buffer overflows in the (1) abc_MIDI_drum and (2) abc_MIDI_gchord functions in load_abc.cpp in libmodplug 0.8.8.4 and earlier allow remote attackers to cause a denial of service (memory corruption and crash) and possibly execute arbitrary code via a crafted ABC.

Record
UBUNTU-CVE-2013-4234
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libmodplug
Debian:12
before 1:0.8.8.4-4
1:0.8.8.4-4
libmodplug
Debian:13
before 1:0.8.8.4-4
1:0.8.8.4-4
libmodplug
Debian:14
before 1:0.8.8.4-4
1:0.8.8.4-4
libmodplug
Debian:6.0
From an advisory covering 2 CVEs
before 1:0.8.8.1-1+squeeze2+git20130828, plus listed versions
1:0.8.8.1-11:0.8.8.1-1+squeeze11:0.8.8.1-1+squeeze2
1:0.8.8.1-1+squeeze2+git20130828
libmodplug
Debian:7
From an advisory covering 2 CVEs
before 1:0.8.8.4-3+deb7u1+git20130828, plus listed versions
1:0.8.8.4-3
1:0.8.8.4-3+deb7u1+git20130828
libmodplug
Mageia:2
From an advisory covering 2 CVEs
before 0.8.8.4-1.1.mga2
0.8.8.4-1.1.mga2
libmodplug
Mageia:3
From an advisory covering 2 CVEs
before 0.8.8.4-3.1.mga3
0.8.8.4-3.1.mga3
libmodplug
SUSE:Linux Enterprise Desktop 12 SP3
From an advisory covering 2 CVEs
before 0.8.9.0+git20170610.f6dd59a-15.4.1
0.8.9.0+git20170610.f6dd59a-15.4.1
libmodplug
SUSE:Linux Enterprise Software Development Kit 12 SP3
From an advisory covering 2 CVEs
before 0.8.9.0+git20170610.f6dd59a-15.4.1
0.8.9.0+git20170610.f6dd59a-15.4.1
libmodplug
SUSE:Linux Enterprise Server 12 SP3
From an advisory covering 2 CVEs
before 0.8.9.0+git20170610.f6dd59a-15.4.1
0.8.9.0+git20170610.f6dd59a-15.4.1
libmodplug
SUSE:Linux Enterprise Server for SAP Applications 12 SP3
From an advisory covering 2 CVEs
before 0.8.9.0+git20170610.f6dd59a-15.4.1
0.8.9.0+git20170610.f6dd59a-15.4.1

History

History
RecordedChangedSources
affected, facts
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-4234 is a medium vulnerability (CVSS 6.8) in Konstanty Bialkowski Libmodplug, published September 4, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.35%, the 91st percentile. Fixed in libmodplug 1:0.8.8.4-4.

References

Show 12 moreShow less
MoveEnter Open