Every CVE Search/ Get API key

CVE-2013-4422

SQL injection vulnerability in Quassel IRC before 0.9.1, when Qt 4.8.5 or later and PostgreSQL 8...

6.8 MediumFix available

SQL injection vulnerability in Quassel IRC before 0.9.1, when Qt 4.8.5 or later and PostgreSQL 8.2 or later are used, allows remote attackers to execute arbitrary SQL commands via a \ (backslash) in a message.

Exploit likelihood

2.11%Up 0.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

SQL injection vulnerability in Quassel IRC before 0.9.1, when Qt 4.8.5 or later and PostgreSQL 8.2 or later are used, allows remote attackers to execute arbitrary SQL commands via a \ (backslash) in a message.

Record
CVE-2013-4422
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-89
Updated
2026-11-02
CVE List No score

SQL injection vulnerability in Quassel IRC before 0.9.1, when Qt 4.8.5 or later and PostgreSQL 8.2 or later are used, allows remote attackers to execute arbitrary SQL commands via a \ (backslash) in a message.

Record
CVE-2013-4422
Updated
2026-11-02
EUVDEUVD-2013-4299 No score

SQL injection vulnerability in Quassel IRC before 0.9.1, when Qt 4.8.5 or later and PostgreSQL 8.2 or later are used, allows remote attackers to execute arbitrary SQL commands via a \ (backslash) in a message.

Record
EUVD-2013-4299
Updated
2026-11-03
GitHub AdvisoriesGHSA-74wc-8g6w-h6ww No score

SQL injection vulnerability in Quassel IRC before 0.9.1, when Qt 4.8.5 or later and PostgreSQL 8...

SQL injection vulnerability in Quassel IRC before 0.9.1, when Qt 4.8.5 or later and PostgreSQL 8.2 or later are used, allows remote attackers to execute arbitrary SQL commands via a \ (backslash) in a message.

Record
GHSA-74wc-8g6w-h6ww
Weakness
CWE-89
Updated
2026-11-02
OSV No score

SQL injection vulnerability in Quassel IRC before 0.9.1, when Qt 4.8.5 or later and PostgreSQL 8.2 or later are used, allows remote attackers to execute arbitrary SQL commands via a \ (backslash) in a message.

Record
CVE-2013-4422
Updated
2026-11-02
OSVDEBIAN-CVE-2013-4422 No score

SQL injection vulnerability in Quassel IRC before 0.9.1, when Qt 4.8.5 or later and PostgreSQL 8.2 or later are used, allows remote attackers to execute arbitrary SQL commands via a \ (backslash) in a message.

Record
DEBIAN-CVE-2013-4422
Updated
2026-11-02
OSVMGASA-2013-0311 No score

Updated quassel packages fix CVE-2013-4422

Updated quassel packages fix security vulnerability:

Quassel IRC before 0.9.1 is vulnerable to SQL injection if used with Qt 4.8.5, due to a change in Qt's postgres driver, allowing other IRC users to trick the Quassel core into executing SQL queries (CVE-2013-4422).

This update provides Quassel 0.9.1, which fixes this and several other issues.

Record
MGASA-2013-0311
Updated
2026-11-02
OSVopenSUSE-SU-2024:10119-1 No score

quassel-base-0.12.4-3.3 on GA media

These are all security issues fixed in the quassel-base-0.12.4-3.3 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10119-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
quassel
Debian:12
before 0.9.1-1
0.9.1-1
quassel
Debian:13
before 0.9.1-1
0.9.1-1
quassel
Debian:14
before 0.9.1-1
0.9.1-1
quassel
Mageia:3
before 0.9.1-1.mga3
0.9.1-1.mga3
quassel
openSUSE:Tumbleweed
From an advisory covering 3 CVEs
before 0.12.4-3.3
0.12.4-3.3

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-4422 is a medium vulnerability (CVSS 6.8) in Quassel-irc Quassel Irc, published October 17, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.11%, the 81st percentile. Fixed in quassel 0.9.1-1.

References

Show 11 moreShow less
MoveEnter Open