Every CVE Search/ Get API key

CVE-2013-4505

The is_this_legal function in mod_dontdothat for Apache Subversion 1.4.0 through 1.7.13 and 1.8.0...

2.6 LowFix available

CVE-2013-4505 is a low vulnerability (CVSS 2.6) in Apache Subversion, published November 30, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 7.86%, the 94th percentile. Fixed in subversion 1.7.14-1.

The is_this_legal function in mod_dontdothat for Apache Subversion 1.4.0 through 1.7.13 and 1.8.0 through 1.8.4 allows remote attackers to bypass intended access restrictions and possibly cause a denial of service (resource consumption) via a relative URL in a REPORT request.

Exploit likelihood

7.86%Up 6.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 2.6

The is_this_legal function in mod_dontdothat for Apache Subversion 1.4.0 through 1.7.13 and 1.8.0 through 1.8.4 allows remote attackers to bypass intended access restrictions and possibly cause a denial of service (resource consumption) via a relative URL in a REPORT request.

Record
CVE-2013-4505
CVSS 2.0
2.6 LowAV:N/AC:H/Au:N/C:N/I:N/A:P
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

The is_this_legal function in mod_dontdothat for Apache Subversion 1.4.0 through 1.7.13 and 1.8.0 through 1.8.4 allows remote attackers to bypass intended access restrictions and possibly cause a denial of service (resource consumption) via a relative URL in a REPORT request.

Record
CVE-2013-4505
Updated
2026-11-02
EUVDEUVD-2013-4366 No score

The is_this_legal function in mod_dontdothat for Apache Subversion 1.4.0 through 1.7.13 and 1.8.0 through 1.8.4 allows remote attackers to bypass intended access restrictions and possibly cause a denial of service (resource consumption) via a relative URL in a REPORT request.

Record
EUVD-2013-4366
Updated
2026-11-03
GitHub AdvisoriesGHSA-cr4v-cvvq-g798 No score

The is_this_legal function in mod_dontdothat for Apache Subversion 1.4.0 through 1.7.13 and 1.8.0...

The is_this_legal function in mod_dontdothat for Apache Subversion 1.4.0 through 1.7.13 and 1.8.0 through 1.8.4 allows remote attackers to bypass intended access restrictions and possibly cause a denial of service (resource consumption) via a relative URL in a REPORT request.

Record
GHSA-cr4v-cvvq-g798
Updated
2026-11-02
OSV No score

The is_this_legal function in mod_dontdothat for Apache Subversion 1.4.0 through 1.7.13 and 1.8.0 through 1.8.4 allows remote attackers to bypass intended access restrictions and possibly cause a denial of service (resource consumption) via a relative URL in a REPORT request.

Record
CVE-2013-4505
Updated
2026-11-02
OSVDEBIAN-CVE-2013-4505 No score

The is_this_legal function in mod_dontdothat for Apache Subversion 1.4.0 through 1.7.13 and 1.8.0 through 1.8.4 allows remote attackers to bypass intended access restrictions and possibly cause a denial of service (resource consumption) via a relative URL in a REPORT request.

Record
DEBIAN-CVE-2013-4505
Updated
2026-11-02
OSVMGASA-2013-0360 No score

Updated subversion package fixes security vulnerabilities

mod_dontdothat allows you to block update REPORT requests against certain paths in the repository. It expects the paths in the REPORT request to be absolute URLs. Serf based clients send relative URLs instead of absolute URLs in many cases. As a result these clients are not blocked as configured by mod_dontdothat (CVE-2013-4505).

When SVNAutoversioning is enabled via "SVNAutoversioning on", commits can be made by single HTTP requests such as MKCOL and PUT. If Subversion is built with assertions enabled any such requests that have non-canonical URLs, such as URLs with a trailing /, may trigger an assert. An assert will cause the Apache process to abort (CVE-2013-4558).

Record
MGASA-2013-0360
Updated
2026-11-02
OSVopenSUSE-SU-2024:10538-1 No score

libsvn_auth_gnome_keyring-1-0-1.9.5-1.1 on GA media

These are all security issues fixed in the libsvn_auth_gnome_keyring-1-0-1.9.5-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10538-1
Updated
2026-11-02
OSVSUSE-SU-2015:0709-1 No score

Security update for subversion

Subversion has been updated to fix a security problem:

* bnc#889849: Reveal authentication information through an md5
  collision attack on authentication realm (CVE-2014-3528)

Security Issues:

* CVE-2014-3528
  <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-3528>
Record
SUSE-SU-2015:0709-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
subversion
Debian:12
before 1.7.14-1
1.7.14-1
subversion
Debian:13
before 1.7.14-1
1.7.14-1
subversion
Debian:14
before 1.7.14-1
1.7.14-1
subversion
Mageia:3
before 1.7.14-1.mga3
1.7.14-1.mga3
subversion
openSUSE:Tumbleweed
before 1.9.5-1.1
1.9.5-1.1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 56 moreShow less
MoveEnter Open