Every CVE Search/ Get API key

CVE-2013-4549

QXmlSimpleReader in Qt before 5.2 allows context-dependent attackers to cause a denial of service...

5.0 MediumFix available

CVE-2013-4549 is a medium vulnerability (CVSS 5.0) in Digia Qt, published December 5, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.10%, the 87th percentile. Fixed in qtbase-opensource-src 5.1.1+dfsg-6.

QXmlSimpleReader in Qt before 5.2 allows context-dependent attackers to cause a denial of service (memory consumption) via an XML Entity Expansion (XEE) attack.

Exploit likelihood

3.10%Up 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

QXmlSimpleReader in Qt before 5.2 allows context-dependent attackers to cause a denial of service (memory consumption) via an XML Entity Expansion (XEE) attack.

Record
CVE-2013-4549
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

QXmlSimpleReader in Qt before 5.2 allows context-dependent attackers to cause a denial of service (memory consumption) via an XML Entity Expansion (XEE) attack.

Record
CVE-2013-4549
Updated
2026-11-02
EUVDEUVD-2013-4408 No score

QXmlSimpleReader in Qt before 5.2 allows context-dependent attackers to cause a denial of service (memory consumption) via an XML Entity Expansion (XEE) attack.

Record
EUVD-2013-4408
Updated
2026-11-03
GitHub AdvisoriesGHSA-73gj-v8wr-fjfj No score

QXmlSimpleReader in Qt before 5.2 allows context-dependent attackers to cause a denial of service...

QXmlSimpleReader in Qt before 5.2 allows context-dependent attackers to cause a denial of service (memory consumption) via an XML Entity Expansion (XEE) attack.

Record
GHSA-73gj-v8wr-fjfj
Weakness
CWE-20
Updated
2026-11-02
OSV No score

QXmlSimpleReader in Qt before 5.2 allows context-dependent attackers to cause a denial of service (memory consumption) via an XML Entity Expansion (XEE) attack.

Record
CVE-2013-4549
Updated
2026-11-02
OSVDEBIAN-CVE-2013-4549 No score

QXmlSimpleReader in Qt before 5.2 allows context-dependent attackers to cause a denial of service (memory consumption) via an XML Entity Expansion (XEE) attack.

Record
DEBIAN-CVE-2013-4549
Updated
2026-11-02
Show 6 moreShow less
OSVMGASA-2014-0009 No score

Updated qt4 package fixes security vulnerability

It was discovered that QXmlSimpleReader in Qt incorrectly handled XML entity expansion. An attacker could use this flaw to cause Qt applications to consume large amounts of resources, resulting in a denial of service (CVE-2013-4549).

Record
MGASA-2014-0009
Updated
2026-11-02
OSVMGASA-2014-0115 No score

Updated qt5 packages fix security vulnerability.

It was discovered that QXmlSimpleReader in Qt incorrectly handled XML entity expansion. An attacker could use this flaw to cause Qt applications to consume large amounts of resources, resulting in a denial of service (CVE-2013-4549)

Record
MGASA-2014-0115
Updated
2026-11-02
OSVMGASA-2014-0263 No score

Updated qt3 packages fix security vulnerabilities

Updated qt3 packages fix security vulnerabilities:

QXmlSimpleReader in Qt versions prior to 5.2 supports expansion of internal entities in XML documents without placing restrictions to ensure the document does not cause excessive memory usage. If an application using this API processes untrusted data then the application may use unexpected amounts of memory if a malicious document is processed (CVE-2013-4549).

A NULL pointer dereference flaw was found in QGIFFormat::fillRect in QtGui. If an application using the qt-x11 libraries opened a malicious GIF file with invalid width and height values, it could cause the application to crash (CVE-2014-0190)..

Record
MGASA-2014-0263
Updated
2026-11-02
OSVopenSUSE-SU-2024:10180-1 No score

libqt4-32bit-4.8.7-5.4 on GA media

These are all security issues fixed in the libqt4-32bit-4.8.7-5.4 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10180-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:10287-1 No score

qt3-3.3.8c-140.6 on GA media

These are all security issues fixed in the qt3-3.3.8c-140.6 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10287-1
Updated
2026-11-02
OSVUBUNTU-CVE-2013-4549 No score

QXmlSimpleReader in Qt before 5.2 allows context-dependent attackers to cause a denial of service (memory consumption) via an XML Entity Expansion (XEE) attack.

Record
UBUNTU-CVE-2013-4549
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
qtbase-opensource-src
Debian:12
before 5.1.1+dfsg-6
5.1.1+dfsg-6
qtbase-opensource-src
Debian:13
before 5.1.1+dfsg-6
5.1.1+dfsg-6
qtbase-opensource-src
Debian:14
before 5.1.1+dfsg-6
5.1.1+dfsg-6
qt4
Mageia:3
before 4.8.5-1.3.mga3
4.8.5-1.3.mga3
qtbase5
Mageia:3
before 5.0.2-1.1.mga3
5.0.2-1.1.mga3
qt3
Mageia:3
before 3.3.8b-32.1.mga3
3.3.8b-32.1.mga3
qt3
Mageia:4
before 3.3.8b-33.2.mga4
3.3.8b-33.2.mga4
qt4-x11
Ubuntu:14.04:LTS
before 4:4.8.4+dfsg-0ubuntu20, plus listed versions
4:4.8.4+dfsg-0ubuntu184:4.8.4+dfsg-0ubuntu19
4:4.8.4+dfsg-0ubuntu20
qtbase-opensource-src
Ubuntu:14.04:LTS
before 5.0.2+dfsg1-7ubuntu13, plus listed versions
5.0.2+dfsg1-7ubuntu115.0.2+dfsg1-7ubuntu12
5.0.2+dfsg1-7ubuntu13
phantomjs
Ubuntu:Pro:14.04:LTS
before 1.9.0-1ubuntu0.1~esm1, plus listed versions
1.9.0-1
1.9.0-1ubuntu0.1~esm1
qt3
openSUSE:Tumbleweed
before 3.3.8c-140.6
3.3.8c-140.6

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 35 moreShow less
MoveEnter Open