Every CVE Search/ Get API key

CVE-2013-4852

Integer overflow in PuTTY 0.62 and earlier, WinSCP before 5.1.6, and other products that use...

6.8 MediumFix available

Integer overflow in PuTTY 0.62 and earlier, WinSCP before 5.1.6, and other products that use PuTTY allows remote SSH servers to cause a denial of service (crash) and possibly execute arbitrary code in certain applications that use PuTTY via a negative size value in an RSA key signature during the SSH handshake, which triggers a heap-based buffer overflow.

Exploit likelihood

3.45%Down 0.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

Integer overflow in PuTTY 0.62 and earlier, WinSCP before 5.1.6, and other products that use PuTTY allows remote SSH servers to cause a denial of service (crash) and possibly execute arbitrary code in certain applications that use PuTTY via a negative size value in an RSA key signature during the SSH handshake, which triggers a heap-based buffer overflow.

Record
CVE-2013-4852
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-189
Updated
2026-11-02
CVE List No score

Integer overflow in PuTTY 0.62 and earlier, WinSCP before 5.1.6, and other products that use PuTTY allows remote SSH servers to cause a denial of service (crash) and possibly execute arbitrary code in certain applications that use PuTTY via a negative size value in an RSA key signature during the SSH handshake, which triggers a heap-based buffer overflow.

Record
CVE-2013-4852
Updated
2026-11-02
EUVDEUVD-2013-4697 No score

Integer overflow in PuTTY 0.62 and earlier, WinSCP before 5.1.6, and other products that use PuTTY allows remote SSH servers to cause a denial of service (crash) and possibly execute arbitrary code in certain applications that use PuTTY via a negative size value in an RSA key signature during the SSH handshake, which triggers a heap-based buffer overflow.

Record
EUVD-2013-4697
Updated
2026-11-03
GitHub AdvisoriesGHSA-x52x-v8xm-9r9j No score

Integer overflow in PuTTY 0.62 and earlier, WinSCP before 5.1.6, and other products that use...

Integer overflow in PuTTY 0.62 and earlier, WinSCP before 5.1.6, and other products that use PuTTY allows remote SSH servers to cause a denial of service (crash) and possibly execute arbitrary code in certain applications that use PuTTY via a negative size value in an RSA key signature during the SSH handshake, which triggers a heap-based buffer overflow.

Record
GHSA-x52x-v8xm-9r9j
Updated
2026-11-02
OSV No score

Integer overflow in PuTTY 0.62 and earlier, WinSCP before 5.1.6, and other products that use PuTTY allows remote SSH servers to cause a denial of service (crash) and possibly execute arbitrary code in certain applications that use PuTTY via a negative size value in an RSA key signature during the SSH handshake, which triggers a heap-based buffer overflow.

Record
CVE-2013-4852
Updated
2026-11-02
OSVDEBIAN-CVE-2013-4852 No score

Integer overflow in PuTTY 0.62 and earlier, WinSCP before 5.1.6, and other products that use PuTTY allows remote SSH servers to cause a denial of service (crash) and possibly execute arbitrary code in certain applications that use PuTTY via a negative size value in an RSA key signature during the SSH handshake, which triggers a heap-based buffer overflow.

Record
DEBIAN-CVE-2013-4852
Updated
2026-11-02
Show 4 moreShow less
OSVMGASA-2013-0242 No score

Updated putty and filezilla packages fixes security vulnerability

PuTTY versions 0.62 and earlier - as well as all software that integrates these versions of PuTTY - are vulnerable to an integer overflow leading to heap overflow during the SSH handshake before authentication, caused by improper bounds checking of the length parameter received from the SSH server. This allows remote attackers to cause denial of service, and may have more severe impact on the operation of software that uses PuTTY code (CVE-2013-4852).

PuTTY versions 0.62 and earlier - as well as all software that integrates these versions of PuTTY - are vulnerable to a heap-corrupting buffer underrun bug in the modmul function which performs modular multiplication (CVE-2013-4206).

PuTTY versions 0.62 and earlier - as well as all software that integrates these versions of PuTTY - are vulnerable to a buffer overflow vulnerability in the calculation of modular inverses when verifying a DSA signature (CVE-2013-4207).

PuTTY versions 0.62 and earlier - as well as all software that integrates these versions of PuTTY - are vulnerable to private keys left in memory after being used by PuTTY tools (CVE-2013-4208).

Record
MGASA-2013-0242
Updated
2026-11-02
OSVopenSUSE-SU-2024:10374-1 No score

putty-0.67-1.5 on GA media

These are all security issues fixed in the putty-0.67-1.5 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10374-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:10399-1 No score

filezilla-3.23.0.2-1.1 on GA media

These are all security issues fixed in the filezilla-3.23.0.2-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10399-1
Updated
2026-11-02
OSVUBUNTU-CVE-2013-4852 No score

Integer overflow in PuTTY 0.62 and earlier, WinSCP before 5.1.6, and other products that use PuTTY allows remote SSH servers to cause a denial of service (crash) and possibly execute arbitrary code in certain applications that use PuTTY via a negative size value in an RSA key signature during the SSH handshake, which triggers a heap-based buffer overflow.

Record
UBUNTU-CVE-2013-4852
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
filezilla
Debian:12
before 3.7.3-1
3.7.3-1
filezilla
Debian:13
before 3.7.3-1
3.7.3-1
filezilla
Debian:14
before 3.7.3-1
3.7.3-1
putty
Debian:12
before 0.63-1
0.63-1
putty
Debian:13
before 0.63-1
0.63-1
putty
Debian:14
before 0.63-1
0.63-1
putty
Debian:6.0
before 0.60+2010-02-20-1+squeeze2, plus listed versions
0.60+2010-02-20-10.60+2010-02-20-1+squeeze1
0.60+2010-02-20-1+squeeze2
putty
Debian:7
before 0.62-9+deb7u1, plus listed versions
0.62-9
0.62-9+deb7u1
putty
Mageia:2
before 0.63-1.mga2
0.63-1.mga2
filezilla
Mageia:2
before 3.7.3-1.mga2
3.7.3-1.mga2
Show 5 moreShow less
Affected packages
PackageAffectedFixed
putty
Mageia:3
before 0.63-1.mga3
0.63-1.mga3
filezilla
Mageia:3
before 3.7.3-1.mga3
3.7.3-1.mga3
putty
Ubuntu:14.04:LTS
before 0.63-1
0.63-1
putty
openSUSE:Tumbleweed
before 0.67-1.5
0.67-1.5
filezilla
openSUSE:Tumbleweed
before 3.23.0.2-1.1
3.23.0.2-1.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-4852 is a medium vulnerability (CVSS 6.8) in Putty, published August 9, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.45%, the 89th percentile. Fixed in filezilla 3.7.3-1.

References

Show 23 moreShow less
MoveEnter Open