Every CVE Search/ Get API key

CVE-2013-4956

Puppet Module Tool (PMT), as used in Puppet 2.7.x before 2.7.23 and 3.2.x before 3.2.4, and...

3.6 LowFix available

Puppet Module Tool (PMT), as used in Puppet 2.7.x before 2.7.23 and 3.2.x before 3.2.4, and Puppet Enterprise 2.8.x before 2.8.3 and 3.0.x before 3.0.1, installs modules with weak permissions if those permissions were used when the modules were originally built, which might allow local users to read or modify those modules depending on the original permissions.

Exploit likelihood

0.38%Down 0.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 3.6

Puppet Module Tool (PMT), as used in Puppet 2.7.x before 2.7.23 and 3.2.x before 3.2.4, and Puppet Enterprise 2.8.x before 2.8.3 and 3.0.x before 3.0.1, installs modules with weak permissions if those permissions were used when the modules were originally built, which might allow local users to read or modify those modules depending on the original permissions.

Record
CVE-2013-4956
CVSS 2.0
3.6 LowAV:L/AC:L/Au:N/C:P/I:P/A:N
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

Puppet Module Tool (PMT), as used in Puppet 2.7.x before 2.7.23 and 3.2.x before 3.2.4, and Puppet Enterprise 2.8.x before 2.8.3 and 3.0.x before 3.0.1, installs modules with weak permissions if those permissions were used when the modules were originally built, which might allow local users to read or modify those modules depending on the original permissions.

Record
CVE-2013-4956
Updated
2026-11-02
EUVDEUVD-2013-4800 No score

Puppet Module Tool (PMT), as used in Puppet 2.7.x before 2.7.23 and 3.2.x before 3.2.4, and Puppet Enterprise 2.8.x before 2.8.3 and 3.0.x before 3.0.1, installs modules with weak permissions if those permissions were used when the modules were originally built, which might allow local users to read or modify those modules depending on the original permissions.

Record
EUVD-2013-4800
Updated
2026-11-03
GitHub AdvisoriesGHSA-3jgg-vqj7-2c3r No score

Puppet Module Tool (PMT), as used in Puppet 2.7.x before 2.7.23 and 3.2.x before 3.2.4, and...

Puppet Module Tool (PMT), as used in Puppet 2.7.x before 2.7.23 and 3.2.x before 3.2.4, and Puppet Enterprise 2.8.x before 2.8.3 and 3.0.x before 3.0.1, installs modules with weak permissions if those permissions were used when the modules were originally built, which might allow local users to read or modify those modules depending on the original permissions.

Record
GHSA-3jgg-vqj7-2c3r
Updated
2026-11-02
OSV No score

Puppet Module Tool (PMT), as used in Puppet 2.7.x before 2.7.23 and 3.2.x before 3.2.4, and Puppet Enterprise 2.8.x before 2.8.3 and 3.0.x before 3.0.1, installs modules with weak permissions if those permissions were used when the modules were originally built, which might allow local users to read or modify those modules depending on the original permissions.

Record
CVE-2013-4956
Updated
2026-11-02
OSVDEBIAN-CVE-2013-4956 No score

Puppet Module Tool (PMT), as used in Puppet 2.7.x before 2.7.23 and 3.2.x before 3.2.4, and Puppet Enterprise 2.8.x before 2.8.3 and 3.0.x before 3.0.1, installs modules with weak permissions if those permissions were used when the modules were originally built, which might allow local users to read or modify those modules depending on the original permissions.

Record
DEBIAN-CVE-2013-4956
Updated
2026-11-02
OSVMGASA-2013-0259 No score

Updated puppet and puppet3 package fix security vulnerabilities

It was discovered that Puppet incorrectly handled the resource_type service. A local attacker on the master could use this issue to execute arbitrary Ruby files (CVE-2013-4761).

It was discovered that Puppet incorrectly handled permissions on the modules it installed. Modules could be installed with the permissions that existed when they were built, possibly exposing them to a local attacker (CVE-2013-4956).

Record
MGASA-2013-0259
Updated
2026-11-02
OSVopenSUSE-SU-2024:10581-1 No score

ruby2.2-rubygem-puppet-3.8.7-2.2 on GA media

These are all security issues fixed in the ruby2.2-rubygem-puppet-3.8.7-2.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10581-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
puppet
Debian:11
before 3.2.4-1
3.2.4-1
puppet
Debian:7
before 2.7.23-1~deb7u1, plus listed versions
2.7.18-42.7.18-5
2.7.23-1~deb7u1
puppet
Mageia:2
before 2.7.23-1.mga2
2.7.23-1.mga2
puppet
Mageia:3
before 2.7.23-1.mga3
2.7.23-1.mga3
puppet3
Mageia:3
before 3.2.4-1.mga3
3.2.4-1.mga3
facter
Red Hat:openstack:3::el6
before 0:1.6.6-1.el6_4
0:1.6.6-1.el6_4
hiera
Red Hat:openstack:3::el6
before 0:1.0.0-3.el6_4
0:1.0.0-3.el6_4
puppet
Red Hat:openstack:3::el6
before 0:3.2.4-1.el6_4
0:3.2.4-1.el6_4
puppet-server
Red Hat:openstack:3::el6
before 0:3.2.4-1.el6_4
0:3.2.4-1.el6_4
ruby-augeas
Red Hat:openstack:3::el6
before 0:0.4.1-1.el6_4
0:0.4.1-1.el6_4
Show 5 moreShow less
Affected packages
PackageAffectedFixed
ruby-augeas-debuginfo
Red Hat:openstack:3::el6
before 0:0.4.1-1.el6_4
0:0.4.1-1.el6_4
ruby-shadow
Red Hat:openstack:3::el6
before 0:1.4.1-13.el6_4
0:1.4.1-13.el6_4
ruby-shadow-debuginfo
Red Hat:openstack:3::el6
before 0:1.4.1-13.el6_4
0:1.4.1-13.el6_4
ruby193-puppet
Red Hat:openstack:3::el6
before 0:3.1.1-11.1.el6ost
0:3.1.1-11.1.el6ost
ruby193-puppet-server
Red Hat:openstack:3::el6
before 0:3.1.1-11.1.el6ost
0:3.1.1-11.1.el6ost

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-4956 is a low vulnerability (CVSS 3.6) in Puppet, published August 20, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.38%, the 32nd percentile. Fixed in puppet 3.2.4-1.

References

Show 34 moreShow less
MoveEnter Open