CVE-2013-5671
Code injection in dragonfly gem
lib/dragonfly/imagemagickutils.rb in the fog-dragonfly gem 0.8.2 for Ruby allows remote attackers to execute arbitrary commands via unspecified vectors.
Exploit likelihood
What each source reports
NVD Score used
7.5
lib/dragonfly/imagemagickutils.rb in the fog-dragonfly gem 0.8.2 for Ruby allows remote attackers to execute arbitrary commands via unspecified vectors.
- Record
CVE-2013-5671- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
lib/dragonfly/imagemagickutils.rb in the fog-dragonfly gem 0.8.2 for Ruby allows remote attackers to execute arbitrary commands via unspecified vectors.
- Record
CVE-2013-5671- Updated
- 2026-11-02
EUVDEUVD-2017-0293 No score
lib/dragonfly/imagemagickutils.rb in the fog-dragonfly gem 0.8.2 for Ruby allows remote attackers to execute arbitrary commands via unspecified vectors.
- Record
EUVD-2017-0293- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-qrgf-jqqm-x7xv No score
Code injection in dragonfly gem
lib/dragonfly/imagemagickutils.rb in the fog-dragonfly gem 0.8.2 for Ruby allows remote attackers to execute arbitrary commands via unspecified vectors.
- Record
GHSA-qrgf-jqqm-x7xv- Weakness
- CWE-74
- Updated
- 2026-11-02
OSVGHSA-qrgf-jqqm-x7xv No score
Code injection in dragonfly gem
lib/dragonfly/imagemagickutils.rb in the fog-dragonfly gem 0.8.2 for Ruby allows remote attackers to execute arbitrary commands via unspecified vectors.
- Record
GHSA-qrgf-jqqm-x7xv- Weakness
- CWE-74
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
dragonflyRubyGems |
before 1.0.0 | 1.0.0 |
fog-dragonflyRubyGems |
through 0.9.15 | None known |
dragonflyRubyGems |
before 1.0.0, plus listed versions 0.1.00.1.10.1.40.1.50.1.6 Show 45 moreShow less0.2.10.3.00.3.20.3.30.3.40.3.50.3.60.3.70.3.80.4.00.4.10.4.20.4.30.4.40.5.00.5.10.5.20.5.30.5.40.5.50.5.60.5.70.6.00.6.10.6.20.7.00.7.10.7.20.7.30.7.40.7.50.7.60.7.70.8.00.8.10.8.20.8.40.8.50.8.60.9.00.9.10.9.100.9.110.9.120.9.13 |
1.0.0 |
fog-dragonflyRubyGems |
through 0.9.15, plus listed versions 0.8.10.8.2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2013-5671 is a high vulnerability (CVSS 7.5) in Mark Evans Fog-dragonfly, published May 12, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.19%, the 82nd percentile. Fixed in dragonfly 1.0.0.
References
Left out here: 8 versions. The JSON record has them.