Every CVE Search/ Get API key

CVE-2013-5958

Symfony Denial of Service Via Long Password Hashing

5.0 MediumFix available

The Security component in Symfony 2.0.x before 2.0.25, 2.1.x before 2.1.13, 2.2.x before 2.2.9, and 2.3.x before 2.3.6 allows remote attackers to cause a denial of service (CPU consumption) via a long password that triggers an expensive hash computation, as demonstrated by a PBKDF2 computation, a similar issue to CVE-2013-5750.

Exploit likelihood

1.87%Up 0.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

The Security component in Symfony 2.0.x before 2.0.25, 2.1.x before 2.1.13, 2.2.x before 2.2.9, and 2.3.x before 2.3.6 allows remote attackers to cause a denial of service (CPU consumption) via a long password that triggers an expensive hash computation, as demonstrated by a PBKDF2 computation, a similar issue to CVE-2013-5750.

Record
CVE-2013-5958
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-399
Updated
2026-11-02
CVE List No score

The Security component in Symfony 2.0.x before 2.0.25, 2.1.x before 2.1.13, 2.2.x before 2.2.9, and 2.3.x before 2.3.6 allows remote attackers to cause a denial of service (CPU consumption) via a long password that triggers an expensive hash computation, as demonstrated by a PBKDF2 computation, a similar issue to CVE-2013-5750.

Record
CVE-2013-5958
Updated
2026-11-02
EUVDEUVD-2022-3620 No score

The Security component in Symfony 2.0.x before 2.0.25, 2.1.x before 2.1.13, 2.2.x before 2.2.9, and 2.3.x before 2.3.6 allows remote attackers to cause a denial of service (CPU consumption) via a long password that triggers an expensive hash computation, as demonstrated by a PBKDF2 computation, a similar issue to CVE-2013-5750.

Record
EUVD-2022-3620
Updated
2026-11-03
GitHub AdvisoriesGHSA-cr49-fx2v-9p57 No score

Symfony Denial of Service Via Long Password Hashing

The Security component in Symfony 2.0.x before 2.0.25, 2.1.x before 2.1.13, 2.2.x before 2.2.9, and 2.3.x before 2.3.6 allows remote attackers to cause a denial of service (CPU consumption) via a long password that triggers an expensive hash computation, as demonstrated by a PBKDF2 computation, a similar issue to CVE-2013-5750.

Record
GHSA-cr49-fx2v-9p57
Weakness
CWE-789
Updated
2026-11-02
OSVGHSA-cr49-fx2v-9p57 No score

Symfony Denial of Service Via Long Password Hashing

The Security component in Symfony 2.0.x before 2.0.25, 2.1.x before 2.1.13, 2.2.x before 2.2.9, and 2.3.x before 2.3.6 allows remote attackers to cause a denial of service (CPU consumption) via a long password that triggers an expensive hash computation, as demonstrated by a PBKDF2 computation, a similar issue to CVE-2013-5750.

Record
GHSA-cr49-fx2v-9p57
Weakness
CWE-789
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
symfony/symfony
Packagist
2.0.0 up to 2.0.25
2.0.25
symfony/symfony
Packagist
2.1.0 up to 2.1.13
2.1.13
symfony/symfony
Packagist
2.2.0 up to 2.2.9
2.2.9
symfony/symfony
Packagist
2.3.0 up to 2.3.6
2.3.6
symfony/polyfill
Packagist
1.0.0 up to 1.10.0
1.10.0
symfony/security
Packagist
2.0.0 up to 2.0.25
2.0.25
symfony/security
Packagist
2.1.0 up to 2.1.13
2.1.13
symfony/security
Packagist
2.2.0 up to 2.2.9
2.2.9
symfony/security
Packagist
2.3.0 up to 2.3.6
2.3.6
symfony/symfony
Packagist
2.0.0 up to 2.0.25, plus listed versions
2.0.42.0.52.0.62.0.7v2.0.10
Show 15 moreShow less
v2.0.11v2.0.12v2.0.13v2.0.14v2.0.15v2.0.16v2.0.17v2.0.18v2.0.19v2.0.20v2.0.21v2.0.22v2.0.23v2.0.24v2.0.9
2.0.25
Show 8 moreShow less
Affected packages
PackageAffectedFixed
symfony/symfony
Packagist
2.1.0 up to 2.1.13, plus listed versions
v2.1.0v2.1.1v2.1.10v2.1.11v2.1.12
Show 8 moreShow less
v2.1.2v2.1.3v2.1.4v2.1.5v2.1.6v2.1.7v2.1.8v2.1.9
2.1.13
symfony/symfony
Packagist
2.2.0 up to 2.2.9, plus listed versions
v2.2.0v2.2.1v2.2.2v2.2.3v2.2.4
Show 4 moreShow less
v2.2.5v2.2.6v2.2.7v2.2.8
2.2.9
symfony/symfony
Packagist
2.3.0 up to 2.3.6, plus listed versions
v2.3.0v2.3.1v2.3.2v2.3.3v2.3.4v2.3.5
2.3.6
symfony/polyfill
Packagist
1.0.0 up to 1.10.0, plus listed versions
v1.0.0v1.0.1v1.1.0v1.1.1v1.2.0
Show 8 moreShow less
v1.3.0v1.3.1v1.4.0v1.5.0v1.6.0v1.7.0v1.8.0v1.9.0
1.10.0
symfony/security
Packagist
2.0.0 up to 2.0.25, plus listed versions
2.0.42.0.52.0.62.0.7v2.0.10
Show 14 moreShow less
v2.0.12v2.0.13v2.0.14v2.0.15v2.0.16v2.0.17v2.0.18v2.0.19v2.0.20v2.0.21v2.0.22v2.0.23v2.0.24v2.0.9
2.0.25
symfony/security
Packagist
2.1.0 up to 2.1.13, plus listed versions
v2.1.0v2.1.1v2.1.10v2.1.11v2.1.12
Show 8 moreShow less
v2.1.2v2.1.3v2.1.4v2.1.5v2.1.6v2.1.7v2.1.8v2.1.9
2.1.13
symfony/security
Packagist
2.2.0 up to 2.2.9, plus listed versions
v2.2.0v2.2.1v2.2.2v2.2.3v2.2.4
Show 4 moreShow less
v2.2.5v2.2.6v2.2.7v2.2.8
2.2.9
symfony/security
Packagist
2.3.0 up to 2.3.6, plus listed versions
v2.3.0v2.3.1v2.3.2v2.3.3v2.3.4v2.3.5
2.3.6

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-5958 is a medium vulnerability (CVSS 5.0) in Sensiolabs Symfony, published December 27, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.87%, the 79th percentile. Fixed in symfony/symfony 2.0.25.

References

MoveEnter Open